TK.

Upcoming MBHP_MF_NG module

353 posts in this topic

[29462.603] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.613] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.623] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.642] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.652] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.662] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.673] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.692] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.702] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.712] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.722] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.741] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.752] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.762] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.772] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.792] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.802] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.812] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.823] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.842] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.852] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.862] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.872] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.892] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.902] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.912] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.922] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.942] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.952] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.963] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29462.973] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29462.992] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.002] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.012] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.022] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.042] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.052] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.062] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.072] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.091] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.101] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.112] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.122] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.142] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.152] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.162] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.172] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.192] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.202] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.212] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.222] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.241] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.252] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.262] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.272] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.292] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.302] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.312] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.323] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.342] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.352] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.362] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.372] 90 68 00   Chn# 1  Note Off G#6 (optimized)
[29463.394] 90 68 7f   Chn# 1  Note On  G#6  Vel:127
[29463.404] 90 68 00   Chn# 1  Note Off G#6 (optimized)

Share this post


Link to post
Share on other sites

Ok, which program did you load inside the MF tool? Mackie protocol or something else?

 

Which fader did you touch?

 

Are you experiencing any problems when you move the fader you touched? Like the motors preventing you from moving the fader?

 

Are you using a laptop? If so, are you running it on batteries or on a psu when you are using the MF module?

 

A lot of questions, I know. But answering them could bring us closer to a solution.

 

my regards

Share this post


Link to post
Share on other sites

This was with mackie control, I get a variation of the same thing for the other types too.

I touched the first fader.

When I move the motors fight me if I have a DAW program up. In mios studio, they don't fight.

I am on a MacBook Pro. I have used it on battery and wall adaptor psu. No change in behavior.

Share this post


Link to post
Share on other sites

Hi Nick M

Did you ever tested your faders with the Mios Studio MF_NG Program? It seams to me that the motor is inverse or the 0%/100% Pin is miss connected to Wiper. 

Test the two buttons top and bottom. If the fader goes up and down and up again it wold seam to me all right...

Here is a Connection diagram: http://dl.dropboxusercontent.com/u/29658831/midibox/MF_NG/MF_NG_connection_diagram.pdf

Check if the connections are right and be aware that the motor has to be on top. If you whant to have the motor botom sided you need to inverse both. Motor A/B and 0%/100% of your fader...

best regards

Novski

Share this post


Link to post
Share on other sites
Hi Nick M

Did you ever tested your faders with the Mios Studio MF_NG Program? It seams to me that the motor is inverse or the 0%/100% Pin is miss connected to Wiper. 

Test the two buttons top and bottom. If the fader goes up and down and up again it wold seam to me all right...

Here is a Connection diagram: http://dl.dropboxusercontent.com/u/29658831/midibox/MF_NG/MF_NG_connection_diagram.pdf

Check if the connections are right and be aware that the motor has to be on top. If you whant to have the motor botom sided you need to inverse both. Motor A/B and 0%/100% of your fader...

best regards

Novski

I have gone over this many, many times.  

All my wiring is correct, this I am sure of.  I cannot get rid of the  constant stream of on/off when I touch a fader.  It recognizes the correct fader, stops the stream when I release.  

 

The faders seem to work fine if I disable the touch sensors.  I just don't like how loud or choppy they are.  I don't fully understand the settings in the mios tool.  I cant seem to find a setting that would be acceptable.  They are all just different versions of ok at best.  What do you guys set your calibration settings to?

Share this post


Link to post
Share on other sites
I cannot get rid of the  constant stream of on/off when I touch a fader.

 

Probably the "Touchsensor Sensitivity" is too low. I think that 3 is the best value. Change it - and if it works, push the "send" button to ensure that this configuration is permanently saved (and will be restored after power-on)

 

 

 

The faders seem to work fine if I disable the touch sensors.

 

Once you get the touch sensors working, I strongly recommend you to select the touch sensor mode which ensures that no fader event is sent as long as the sensor is not pressed (last option)

 

 

 

I just don't like how loud or choppy they are.

 

General hint: than lower the motor voltage (can be adjusted with P1 on the MBHP_MF_NG module), than quieter the faders.

For Alps RSAON the default Duty settings (48/64) are ok for both directions. PWM Steps should be 64.

These are the default values...

 

Adjust the motor voltage, starting from the lowest value, increase the voltage until all faders are moving and don't get stucked.

The "Slow Sine" testmode is very useful for this procedure.

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Hi Bela,

 

it's very similar to the faders that I'm using, they are just smaller.

So: yes, they should work :)

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites
Hi Bela,

 

it's very similar to the faders that I'm using, they are just smaller.

So: yes, they should work :smile:

 

Best Regards, Thorsten.

 

Thank you Thorsten, now I'm going to smashTV :D

Share this post


Link to post
Share on other sites

Hi TK, Happy New Year. Is there a way to get the PWM into the 20khz -30khz range? Thanks KUI

Share this post


Link to post
Share on other sites

Unfortunately this isn't possible - the PWM is already generated as fast as possible (assembler optimized)

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Quick question...I see a board layout....are there downloadable schematics around? I need to make changes to motor power, and really do not want to retype the entire schematic.

Share this post


Link to post
Share on other sites

What changes need to be made if using a motorfader with a 5k linear track as opposed to a 10k? 

Share this post


Link to post
Share on other sites

5k is perfect (actually I would even prefer such faders instead of 10k due to the better signal/noise ratio!)

No changes are required.

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

I´ve made an adapter - pcb - layout with eagle for mbhp_mf_ng_v1 pcb from smashtv.

 

This pcb supports eight box headers, to connect each motorfader with a seperate ribbon cable.

 

 

post-7219-0-80276700-1397149820_thumb.jp

post-7219-0-87097400-1397149841_thumb.jp

post-7219-0-77961500-1397149853_thumb.jp

mbhp_mf_Adapter_v1.zip

post-7219-0-03678900-1397745963_thumb.pn

Edited by mindjuice
1 person likes this

Share this post


Link to post
Share on other sites

Hey,

 

I set up my motorfaders and try to get the touchsensors running. For testing I use just one fader and limit the numbers of faders in to MF_NG tool inside MIOS Studio to 1 to not get any jitter values of the open fader-ports.

I connected T0 of the PCB to the touchsensor of my motorfader (ALPS coreless 100mm 10k lin.), GND to GND of the motorfader. There is nothing happening... even if I disconnect the touchsensor-cable I would expect, that I get a lot of random values, because the touchsensor port is open and not connected to anything. But: The monitor says nothing. 

 

It also doesn't care which fader-mode I use... same with touchsensor-mode and touchsensor sensibility.  

 

Well, it's late now so I will give it a fresh look tomorrow. But any tipps are welcome :)

 

Thanks,

Chris

Share this post


Link to post
Share on other sites

Nice work, mindjuice. Would you mind sharing the layout?

 

Greets

Share this post


Link to post
Share on other sites

Could someone explain to me what this is good for? Isn't it way cheaper and more practical to connect the faders via a 2-pin cable??

Share this post


Link to post
Share on other sites

You've to connect the analog input, Gnd, Vss, touchsensor as well.

 

So, actually really a nice work. :)

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Nice! i also did the hole thing in a similar way once. But unfourtunately i didn't get so far to test it completely until now.

Im currently making my page new. After that i will be able to provide all designs as Eagle file an lib... as opensource. Just give me a month or two...

 

 

If anybody is interested in beta-testing i have a spare unequiped pcb (foto) to give away. 

post-10711-0-73923000-1397395120_thumb.j

1 person likes this

Share this post


Link to post
Share on other sites

Hey people,

 

for those of you who are using motorfader with a 4pin connector I created a PCB. 

 

6pin connector Fader_01, Fader_02, is going to the 4pin connector on the fader plus two cables for the motor.

2pin connector Motor_01, Motor_02, etc. is going to the MF_NG pcb. 

J1 is going to J2 (analog inputs).

J2 is going to J14 (touch sensors). 

 

Because this one is a single-layer layout, you need to connect the vias. I named the signals in eagle (use the info-tool).

 

post-10331-0-41334000-1398700937_thumb.p

MF_Adapter.brd.zip

Share this post


Link to post
Share on other sites

Hey Guys, havent been here for a while now. Projekt runs Great will Update this in the next weeks i promise. I am just struggeling with the Motorfaders ATM. Turns out it is a Problem for the Midibox to accept Movements of 2 Faders at the same time. 

 

First my Conifguration of MF_NG Modules: Ive got two of them in a chain which are connected to an lp17 core which runs Midibox_NG and outputs the Midinotes to an PC Over USB.

 

My Problem is when i move 2 or more faders the output monitored on the pc inst correct... it loses Steps. Fader (Physicaly) is at 100% but the outputted value is anywhere between 0-127 how can that be?

 

Any Sugestions are welcome.

 

Best regards Alexander

Share this post


Link to post
Share on other sites

Have you tried calibrating the faders?

Share this post


Link to post
Share on other sites

Isnt the config just for the motors? I think it is more a general problem or a transmission problem between MF_NG and Midibox_ NG.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now