Vinylrider

MIDIBOX NG SD CARD PROBLEM

10 posts in this topic

Hello,

i have just assembled my first LPC core and i will use the MIDIBOX NG firmware.

i have also made the sd card adaptor as in the schematics.For a memory card i use a 4 gb micro sd.

 

When i open the core i get the message that there is NO sd card pluged.

 

when i write on the terminal the command "sdcard" i get this :    attached file at the bottom "reply.jpg"

 

 

I have checked 4 times all the connections from j16 to sd card adaptor and from the j16 to the pins of the LPC.

I have also checked the presence of 3,3 volt and all seem perfect!

 

I can't find what am i do wrong. I am waitting for suggestions in order to continue my project.

thanks in advance

 

 

post-11562-0-96820700-1357741323_thumb.j

Share this post


Link to post
Share on other sites

Does the card work with other devices?

Share this post


Link to post
Share on other sites

On http://www.ucapps.de/mbhp/mbhp_sdcard.pdf the schematic shows DO connecting to DO.  But the "NOTE:" says DO connects to SI and DI connects to SO.  I found this confusing and by looking at other schematics, found that DO of the core did have to go to the SI of the card.  Maybe you have the 2 signals reversed?

Share this post


Link to post
Share on other sites
On http://www.ucapps.de/mbhp/mbhp_sdcard.pdf the schematic shows DO connecting to DO.  But the "NOTE:" says DO connects to SI and DI connects to SO.  I found this confusing and by looking at other schematics, found that DO of the core did have to go to the SI of the card.  Maybe you have the 2 signals reversed?

The schematic in your post shows the correct connections to make.

Note the "notch" on left of J1. This is how the connector (actually called J16 on the LPC17 Core) is viewed looking down on the core PCB. 

SI and SO are just the names of the signals in the core circuit. If you look at the pin called J1.DO this is the same as J16.SI on the core_lpc17 circuit.

Share this post


Link to post
Share on other sites
The schematic in your post shows the correct connections to make.

Note the "notch" on left of J1. This is how the connector (actually called J16 on the LPC17 Core) is viewed looking down on the core PCB. 

SI and SO are just the names of the signals in the core circuit. If you look at the pin called J1.DO this is the same as J16.SI on the core_lpc17 circuit.

yes i know but i gave it a try and i changed the cables. i but them back now.

Share this post


Link to post
Share on other sites
yes i know but i gave it a try and i changed the cables. i but them back now.

I have no idea what this means.

 

Re-check the SD Card on a computer to make sure you have not damaged it.

The schematic and also the series of photo's showing how to wire the SD Card on ucapps.de are correct. Follow the photos.

Share this post


Link to post
Share on other sites

ok it is solved.

My stupidity has no boundaries!

For the history this was my mistake:

 

It is the way you look the j1 if you look this way "attach file 1" its wrong

 

but if you look that way "attach file 2" is the proper way.

 

Thank you for the quick answers

 

post-11562-0-52206200-1357752506_thumb.j

post-11562-0-14913300-1357752642_thumb.j

Share this post


Link to post
Share on other sites

Fine! :)

 

My first assumption was, that the SD Card has the wrong format (no FAT32).

Therefore I added a new "sdcard_format" command into V1.011 - which could be helpful in future

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now