Jump to content

MB 6582 PSU A, not getting 9v on 9v pins?


Recommended Posts

Today I completed my base PCB for the MB 6582. I only have 8505 chips so I went with PSU option A. I tested the board voltages for the first time this afternoon and got proper readings for all the 5v pins on the SIDs, COREs, etc, but when I've tried testing for 9v (on J4 for example or J25) I don't get 9v. On J4 I just read 0v and on J25 I'll sometimes read around 5v (which drops down to 0 eventually).

I don't have any chips placed in their sockets yet, but wanted to figure out why I'm not seeing 9v before placing them.


Link to comment
Share on other sites

Hi and welcome!


Did you check the voltages on the PSU power plug? Maybe you have a failed Commodore PSU, which occasionally happens. But when it fails, usually the 5V DC rail blows, not the 9V AC rail. If the PSU is all right, work your way back from the power plug of the MB6582, measuring at the rectifier and after the 9V Vreg (7809).


Many greets,


Link to comment
Share on other sites

Plugged in the PSU so I could test the outputs on each pin. It was difficult to keep the probes on my multimeter steady enough to get consistent readings, but I am only seeing power on the 5v pin. Pins 6 and 7 (9v according to the back of the PSU) give me negative readings, so I guess I just have a bad PSU :(.


Maybe someone in the For Sale section has a legit power supply for PSU option A.

Link to comment
Share on other sites

  • 5 weeks later...

Got a new PSU in the mail. This one is in much better condition but is still the same shape and size of the other adapter. They must be different models though since the information on the bottom is slightly different (though all of the specs are the same of course).


On the 9v pin I am now reading 6.88v and reading it consistently across the IC socket, so that is reassuring. One thing I would offer for others trying to diagnose a PSU issue is to remember to put all your jumpers on the voltage selector pins on each SID before testing voltage. I realized I didn't have them on when initially testing :|


On a related note, I was able to test my LCD module with the powered main board today and it looks like it's working alright. After adjusting the contrast I saw a single character (u) in the bottom right-hand corner of the LCD. The main board and control board are not yet soldered together so I assume this is just a test character (or I've done something very wrong).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...