Jump to content

Recommended Posts

Hi,

 

im trying to use 2 KS0108-Displays on my LPC17-Core-Board. With the Bootloader i can setup lcd_width @255 maximum, which results in one unused column at the right side of the 2nd display. has anyone experienced similar problems and what is the workaround to get all the 256 lcd-columns working properly ??

 

regards,

mOnO

 

Link to post
Share on other sites

Hi,

 

what size are your displays? 128x64? If so, you have to set up the display size in bootloader to lcd_width 128, so you have to set this parameter to the size of one of your displays in a chain. With lcd_num_x (or _y) you define how many of your (128px wide) displays you want to use.

 

my regards

Link to post
Share on other sites

@John: KS0108 has a special treatment where lcd_num_x doesn't play a role. J28 always has 4 CS lines enabled.

Actually it's a part of the universal driver which needs to be overworked, so that CS lines are specified with lcd_num_x

 

However, I changed MIOS32_LCD, so that lcd_width 255 results into the actual width 256

This coding could become important in future. E.g. if there are displays which support 320 pixel, I could use the number 254 for this, etc.

 

Best Regards, Thorsten.

Link to post
Share on other sites

ok. ive updated the mios32_lcd file and re-compiled my programm. finally all the 256 colums work, which gives me 70x8 characters on two ks0108-displays. thanks a lot for that. :rolleyes:

 

kind regards,

mOnO

Link to post
Share on other sites
  • 6 years later...

Hello mono and Tk.

I have 2 KS0108-Displays ( 128x64 , 2CS each ) with no wirring error ( quintuple check for a week now ) on a LPC17 .

I can't figure how to configure the lcd in the bootloader the right way .

One display with 128x64 and num_x = 1 work perfectly , I swaped the ribbon cable and the lcd ... both cable work and lcd are ok 

But when i try two displays , only one at a time is working , the one wich is on CS1 and CS2 line .

  • TEST 1 : lcd_width 128x64  AND   lcd_num_x = 2    :
  • work only with the lcd wich is connected to cs 1 and 2 and print  LCD #1.1 ready . LCD wich is on cs3 and cs 4 is blank
  • If i swap the j15a and J15b ( but don't touch j28 ), the second LCD print  LCD #2.1 ready  and the first one wich is now on cs3 and cs 4 is blank
  •  
  • TEST 2 :  lcd_width255x64  AND   lcd_num_x = 1   OR lcd_num_x = 2
    • all lcd are blank 

I traced CS3 ( WS ) and CS4 ( MCLK ) on the LPC17 and it seem ok .

I use bootloader 1018 and MBNG 1.036

Any idea on what i am missing ?

Thank you , 

Hope you're all ok !!

Loic 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...