Jump to content

Chain MIDIboxes


Recommended Posts

14 hours ago, weasel said:

@Zam would you mind shedding some light on your midi router/merger thing? i see you keep calling it USB midi, but if i just hijack the J11 pins to connect boards directly, it still is UART midi right? i would enable the second set of 4 midi ports in NG events?

I have a 3 cores "chain"

one master to/from computer and DAW via USB midi (4 port enabled)

Two slaves, both connected to master via direct J11 connection, uart midi (same PSU and short cable).

Using NG, master have global router function enabled, UART1 to/from USB2 and UART2 to/from USB3, USB1 being master

I also have few special routing at master (via sender/receiver) to handle functions that I have at slave HW and requested as master events (USB1) for DAW (like transport)

So my computer/DAW see 4 midi USB port at my "MCU device", my DAW talk with each one and the master core handle routing to slave




Link to comment
Share on other sites

  • 1 year later...

I'd like to catch up on this topic because I ran into a problem.

I've connected two NG-cores with a direct connection without optocoupler and stuff. The only thing that I've added is a 1k pullup to +5V at the midi-inputs. I use the fourth MIDI I/O on the first core and the first MIDI I/O on the second core.

The first core is connected to a computer via USB. I've added a router-setting so that the fourth MIDI I/O is routed to the second USB port. That allows me to access the second core which works great so far. I can access the SD Card through MIOS Studio of both cores. Fine!

But: When I try to write a file to the SD card of the second core I do get an error message:

ERROR: the application has requested file position 0x00000140, but filebrowser expected 0x000000120! Please check with TK! 

The numbers are differing from time to time. Also it seems to be related to the size of the text-file. I can perfectly write a simple file with RESET_HW and a few router-settings. But as soon as it has some more lines / rows, it gives me that error message.

I'm not sure why. I double checked the firmware at my side and also tried the original firmware from TK. No luck so far. 

Any ideas?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...