Jump to content

Recommended Posts

Hi everyone ! :)

We bought a MF_NG Module kit to control motorized faders.
We soldered all components on the board. We assembled the pic18f452 with the PICkit2 on a breadboard. With the pickit2 v2.60 application, we charged on it "bootloader-> burner-> bootloader_v1_2b_pic18f452.hex ». The PIC was happy !
-> However, we don’t if we have to put the "midi -> mios8_v1_9h_pic18f452.hex"  program with the picket 2.60 application or the the MIOS Studio application, we tested both but without success…
-> Also, once the pic18f452 is on the MF_NG board, MIOS Studio doesn’t recognize it, does it lack a little program with midi data or do we have a soldering problem ? We can’t verify it because others midi devices doesn’t seems to be recognize either, is it normal ?

Has anybody made this board before ? Can you explain precisely the steps to make it work ? We are a little bit lost in the ucapps website !!
 
Thanks a lot and have a good day  !!

Edited by zennro
nothing
Link to post
Share on other sites

re flash the bootloader onto pic using your pickit2

fit the pic into your mb_ng make sure you have polarity correct pin 1 to pin 1

once you have done that you need to connect a midi interface to your computer, and connect the in and out midi ports to the midi in and out on the mb_ng module. 

MB_NG OUT----> COMPUTER MIDI INTERFACE IN

COMPUTER MIDI INTERFACE OUT----> MB_NG IN

open Mios Studio

If you are using port 1 in and out on your midi interface then select the interface in the drop down menu for in and also for out

 snip.thumb.JPG.ae64e91bb656f67aeb53f3a33

 

then you load the mb_ng hex file

snip2.thumb.JPG.a98f39f2b6e7e72eec6b7ff9

send to your MB_NG pressing start button

the mb_ng wont show up just your midi interface, you choose the ports that its connected to.

when i did mine i used my GM5 interface

so in Mios studio it showed just the midi interface ports

I chose gm5 port 1 for in and out in mios

 

I hope this helps, if not let me know and i will grab mine and do a reflash with photos to show you.

 

 

 

Link to post
Share on other sites

Thanks for your answer !

I will re program the pic18f452...

But the fact is that MIOS Studio don't recognize the MF_NG with the pic18F452. Does the LED have to light up when MIDI is plug ?

If it's a soldering problem, what can I do to repair it ? Have you got photos of your MF_NG working ?

Thanks again

Zennro

Link to post
Share on other sites

put pictures of yours up, the front and back of the board, make sure they are clear photos. The only way to know if anything isnt right is by photos,of the pcb both side.

are you sure have the right midi in and out selected in mios studio?

Thnigs to do

1: take good clear pictures of the pcb top and bottom

2: what midi interface are you using?

3: screenshot of mios studio with your midi interface connected and the in out ports shown setup.

4: try sending the hex file and take a screenshot of the mios studio window when this is done if it fails or not.

Then we can start looking at this for you.

I will dig out my board and gm5 and show you mine linked up this weekend.

hopefully it will help.

regards!

Link to post
Share on other sites

Oh I didn't see there was multiple threads for this problem :)

As I said in the thread inthe french forum, the module needs to be powered in order to work (only the midi connection is not enought).

Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...