Sign in to follow this  
Followers 0
Captain_Hastings

testing midibox64 core with one pot

4 posts in this topic

Hi,

I'm building a midibox64 and i've finished the core module. Measured voltages and everything is OK, programmed the PIC with the 0.034b firmware.

I wondered if i'm able to do a quick test with one pot connected to A0 of J5, A1-7 connected to ground (thus without needing to connect an AIN module)?

s_core_minimaltest.gif

Do i need to connect anything else? Other ways to quickly test?

Sorry if this sounds like a super newbie question, 'cos i am!  ;D

thanks in advance!

Share this post


Link to post
Share on other sites

I don't think so...

You have to make the ainx4 and connect it to the core

Only then you can connect 1 pot and connect to ground all  other 7 individual inputs...

Share this post


Link to post
Share on other sites

You can also check it without an AINX4 module - the MIDIbox64 will send 8 values at the same time due to the missing multiplexer, but for testing purposes this is ok - your schematic is correct.

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Thanks!

I wanted to verify this because i wasn't getting *any* MIDI output at all.

The problem seems to be my PIC programmer... Although i get a programmed & verified OK (verify during and after switched on) - if i read the PIC i get nothing but zeros...   ???

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0