TK.

MIDIbox SEQ V4 Release + Feedback

1,459 posts in this topic

7 hours ago, TK. said:

Which CC is sent by the footcontroller?

I use the cc to enter remote control mode - I set up cc80 in MBSEQHW.  And then  tap tempo could be added to the remote function - some notes are still free.

But depending on the foot controller, it might also make sense to bypass remote function activation and have a CC to directly tap in the tempo. For me it does not really matter which cc number on which channel.  Best is possibly to make a configurable cc tap tempo number, but that requires more code i expect.

 

 

 

Share this post


Link to post
Share on other sites
10 hours ago, latigid on said:

Couldn't you just save a "tuning" track, and then load/play when you want to tune up?

 

Of course you could, that's how I do it right now. But this needs tweeking everytime,.. like setting witch output,... if you want to hear 2 or more synths to listen to the drifting of VCO's you need more tracks. And with this 'tuning tracks' you have to run the sequencer, it sends out all other kind of information, Ok.. you can mute everything except for the tuning track etcetc . In the end it's quite a hassle. It's much easier to stop the sequencer and send a C3 note-on command to all machines. And hearing all those drifting/droning oscillators plaing just a C3 is quite impressive, I would love this feature.

Share this post


Link to post
Share on other sites

Hi all
Some ideas:


- Autosave mode when pattern changing (cool for editing , not for live....) or a buffer for not loosing work....( more complicated for engine ressource cause the buffer must remember all pattern change)

Save : normal /auto /buffer

 -multiloop mode (each track have this own loop settings) could be cool with a BLM dedicated page! for jam with micro loops!

in loop page:

all tracks (static/view)
selected track (static/ view)
independant tracks (static / view)

selection of loop-on per tracks but shorcut ALL+ loop-on will loop all tracks  (with preselected value).

- MIDI FILTER for midi in (Song position Pointer/MMC/CC/Note)

- MIXER Map item at DEF. page port selection ( you could leave all your pattern in DEF port and a have one midi config for all your patterns.... nice if midi config change and quick way to config ) for EDIT mode.

- SYNC/QUANTIZE parameter per track (global track/pattern synchronisation in option page are not ideal for me, think need more brainstorming on this )
the problem is for the pattern change if you configure quick pattern change you can't use the sync to mesure function.... or i've don't understand something :D

- BLOCK selection page for copying pattern blocks where you want in the pattern.... (could be cool with the BLM)

select with two GP button the block (interval between the two GP button) to copy and with SELECT+ GP button or the datawheel the point in the timeline to paste.
it's like the *press & hold* COPY function but with selectionnable paste in the timeline...

- REDO

i don't learn at 100% the seq possibilities so there's certainly some possibilities that i miss.....or ideas that already implemented!

 

Edited by tashikoma

Share this post


Link to post
Share on other sites

After a day watching some very good instructional youtube videos  I have FINALLY after all these years, got my head around the transpose track function...I LOVE it, it's beautiful....however... can I make a suggestion?

seeing as the pitch name on the transpose page (C3 etc) is not directly related to the pitch of the transposed track, could this be changed optionally to use something like "Nashvile Notation" where C=1, D=2, E=3, F=4, G=5, A=6, B=7 and octaves are the second number ( i.e C3 would be 1/3)  ..to me it would just be less mind boggling then looking as my transpose tracks G3 or whatever and having to think "this means A in my song" etc

 

thanks as always for listening. 
 

Share this post


Link to post
Share on other sites
Quote

would be possible to have Recording going ON after UTILITY->CLR (maybe little check why data is not recorded)and Recording stay ON after SELECT+CLEAR ?

or is this how its intended?

I've to check the issue that you've reported, it isn't intended.

Quote

also one moment had idea that different Timing DIVIDE'rs for each layer could be great.

Unfortunately this is impossible - each track has only a single set of track progression parameters (including divider)
You've to use a second track assigned to the same MIDI port and channel.

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites
Quote

- Autosave mode when pattern changing (cool for editing , not for live....) or a buffer for not loosing work....( more complicated for engine ressource cause the buffer must remember all pattern change)

Save : normal /auto /buffer

At least I added it to the wish list now, but I've to warn you: this will require some work, and might result into some unexpected issues which need to be solved. So, please don't expect a perfect implementation from the beginning.

Quote

-multiloop mode (each track have this own loop settings) could be cool with a BLM dedicated page! for jam with micro loops!

actually the entry of multiple loops only makes sense in conjunction with a BLM...

Added it to the wish list.

Quote

MIDI FILTER for midi in (Song position Pointer/MMC/CC/Note)

will allocate a lot of RAM.

However, added to the wishlist for MBSEQ V4 Plus

Quote

- MIXER Map item at DEF. page port selection ( you could leave all your pattern in DEF port and a have one midi config for all your patterns.... nice if midi config change and quick way to config ) for EDIT mode.

need more details to understand the request

Quote

- BLOCK selection page for copying pattern blocks where you want in the pattern.... (could be cool with the BLM)

select with two GP button the block (interval between the two GP button) to copy and with SELECT+ GP button or the datawheel the point in the timeline to paste.
it's like the *press & hold* COPY function but with selectionnable paste in the timeline...

Is there really a difference compared to the current COPY/PASTE function?

By holding PASTE you can move the block

Quote

- REDO

for which purpose?

Quote

seeing as the pitch name on the transpose page (C3 etc) is not directly related to the pitch of the transposed track, could this be changed optionally to use something like "Nashvile Notation" where C=1, D=2, E=3, F=4, G=5, A=6, B=7 and octaves are the second number ( i.e C3 would be 1/3)  ..to me it would just be less mind boggling then looking as my transpose tracks G3 or whatever and having to think "this means A in my song" etc

So, instead of transposing semitones, you would like to transpose the whole notes, and they should be displayed as 1/<octave>..7/<octave> - correct?

I could add this as an option, but before I need to know, if this is the only change, or if variants are required. E.g. depending on the selected scale?

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites
Just now, TK. said:

So, instead of transposing semitones, you would like to transpose the whole notes, and they should be displayed as 1/<octave>..7/<octave> - correct?

As a suggestion, we could instead use the "Roman" notation as discussed earlier in the week. 

Naturally this would have to take the current scale into account; is this too limiting for "non-Western" scales?

Share this post


Link to post
Share on other sites

Hi Thorsten,

On 13/3/2016 at 10:31 PM, TK. said:

At least I added it to the wish list now, but I've to warn you: this will require some work, and might result into some unexpected issues which need to be solved. So, please don't expect a perfect implementation from the beginning.

When you have a lot of patterns to edit or make change, to speed the workflow , and sometimes i switch between patterns and forget to save...(i have to educate myself to remember saving:decayed:)
it's the habitude/pratice with other gear or daw, you edit all you save all at the end....
i don't want to waste your time ! if it's complicated forget it!
it's just an idea to discuss not a real request.

 

On 13/3/2016 at 10:31 PM, TK. said:

actually the entry of multiple loops only makes sense in conjunction with a BLM...

Added it to the wish list.

  GREAT i really think it's a great feature.... (real request)

 

On 13/3/2016 at 10:31 PM, TK. said:

 

need more details to understand the request

 

(it's for multiple midi outs config, like each different midi ports assigned to each tracks)

i use at 80% time the seq in edit mode. in this mode perhaps i'm wrong (i certainly missed something) but you can't assign a global mixer map (for the midi out ports and channels) for all patterns,  in a same time?
you have to edit the midi outs and channels for each tracks of each patterns (could be very long).


in midi configuration there are the defaut port setting with available ports.... perhaps have the possibility to select a mixer map than a port on this page.
you stay with def. in event page for all tracks of all patterns and you select a mixer map int the def page that will act for all patterns...
if a track have a midi port assigned in event page it stay on this setting , but if def. is selectionned (event) and a mixer map selectionned in the def page (midi config) permit to have global (for all patterns) midi out config.
great for speed the workflow or for quick config change.
I hope to be understandable with my frenglich...

reEDIT:
 request: the LIVE SEND function on MIXER MAPS (press n' hold SELECT) active in edit mode will do the job.

 

On 13/3/2016 at 10:31 PM, TK. said:

By holding PASTE you can move the block

 

Great! that's it ! sorry for that! don't know the paste feature! perfect! also perhaps be cool to control that with the BLM...

 

On 13/3/2016 at 10:31 PM, TK. said:

for which purpose?

 

after do a UNDO you could do a REDO! (not important )

it's just some ideas....or lack of knowledge, some are pertinent other are foolish!
thanks
Best

Edited by tashikoma

Share this post


Link to post
Share on other sites
1 hour ago, tashikoma said:

When you have a lot of patterns to edit or make change, to speed the workflow , and sometimes i switch between patterns and forget to save...(i have to educate myself to remember saving:decayed:)
it's the habitude/pratice with other gear or daw, you edit all you save all at the end....
i don't want to waste your time ! if it's complicated forget it!
it's just an idea to discuss not a real request.

You could assign "SAVE_ALL" to one of the F1-F4 buttons in the HW setup file. This allows you could save all patterns (in fact the whole session) with one button, regardless of the page you happen to be on, and make a habit of pressing it every now and then for just in case :-) The HW setup file is in the root of SD card, it's called MBSEQ_HW.V4. (The section of the draft beginner's user manual that deals with changing the HW setup file is coming up next weekend :-)

1 person likes this

Share this post


Link to post
Share on other sites

Thanks jjonas, HW setup edited! 
thanks too for your great manual.... :love:

Share this post


Link to post
Share on other sites

I moved the firmware 4.091 beta testing feedback here from the draft user manual thread (firmware download link is there too).

One thing that should be fixed before further testing is feasible is that GP buttons 15–16 behave strangely now, on the EDIT page they do something else than just switch on the gate, and when the seq is running, the LEDs behave strangely. The crucial problem is that on the EVENT page I'm not able to use GPB16 to initialise a track to test different track configurations (several note layers, chord layers etc). Another thing I noticed offhand was that on the EVENT page, using GPK9 to change from Layer A or C to Layer B lights up the BPM LED (it's lit when Layer B is selected).

Edited by jjonas
typo

Share this post


Link to post
Share on other sites

No problem at my side, something is probably wrong in your MBSEQ_HW.V4 file

Try the original hwcfg/wilba/MBSEQ_HW.V4 file, if you notice the same, then maybe related to a connection issue? 
In this case, I would expect that the same issue happens with older versions

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

No problem at my side, something is probably wrong in your MBSEQ_HW.V4 file

Try the original hwcfg/wilba/MBSEQ_HW.V4 file, if you notice the same, then maybe related to a connection issue? 
In this case, I would expect that the same issue happens with older versions

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Changing the HW file helped, now it seems to work normally. I'll write some test results tomorrow.

Share this post


Link to post
Share on other sites
10 hours ago, jjonas said:

 

 GP buttons 15–16 behave strangely now,

No bug on my side with  GP buttons on 4.091 beta.

but in MIXER maps does the hold SELECT button for activing LiveSend is implemented in EDIT Mode?

Edited by tashikoma

Share this post


Link to post
Share on other sites

i'm not sure if i'm the first to find this problem.....

Drum triggers from analog out  via ch16 will turn off if a delay of "0ms" is selected on all the midi outs in the bpm page.

In other words I can mute and unmute my 16 DOUT drum triggers by toggling between 0ms and -1ms on any midi out in the bpm page.

Currently running v 4.089 maybe this is already fixed in v 4.091?

Edited by k-rAd MB6401
confusing

Share this post


Link to post
Share on other sites

Since I changed my SD card I can upload MBSEQ_HW.V4 and save it on my sd card to use my wilba's frontpanel. But later if I try for example to change the midi port ( pressed MENU + MIDI and select Midi Router on the left LCD ) I have an error :

[16338.948] [SEQ_FILE_C] Failed to open/create config file, status: -11
[16338.949] [SDCARD_ERROR:-11] DFS_OpenFile(..DFS_WRITE..) failed

What do you think ? hardware or software error ?

Thanks for the answer

Share this post


Link to post
Share on other sites

Feedback on 4.091 beta. To the extent I tested, everything worked except one thing:

  • I assigned JAM_LIVE and JAM_STEP to the F1–F4 buttons (and disabled the "zero-address" lines for the buttons from elsewhere in the HW setup file). JAM_LIVE has no visible effect, while JAM_STEP takes you to the Jam page, but the Step/Live mode is always what you have chosen manually on the Jam page earlier. In this sense BUTTON_JAM_STEP works like the old BUTTON_RECORD.

The things that I tested and found working:

  • I replaced the frontpanel Pause button+LED with Rec button+led: it works.
  • I tested Fwd button by reassigning it temporarily to one of the F1–F4 buttons: it works.
  • "Edit Recording Mode" works with mono and poly, in both "press a GP button" and "toggle with SELECT"
  • Live Recording mode (mono/poly) + AStart works, records all played notes always in the first step, regardless of cursor position at the time of AStart trigger
  • Using a dedicated Rec on/off button you can switch rec off while the seq is running, and jam on top of what you recorded, then switch rec back on to record over the track, wholly or in part: this works
  • Step Recording mode (mono/poly) + AStart works, seq starts at first note, everything is recorded in current cursor position, regardless of running cursor position
  • Key change with internal CCs, in CC layer (on Note track or CC track) works, I don't know why I didn't get it working with 4.090, but it doesn't matter, now I have it working and can document it

If there's other areas that should be tested in 4.091 beta, I'm happy to take pointers.

BTW at some point in the draft manual thread I suggested that the default F1–F4 button functions in the HW setup file should be updated. I'm sorry to flip-flop on this, but since I made that suggestion I found that the Bookmarks page is actually available rather easily with MENU + SELECT, and tap tempo is available similarly with MENU + PLAY. On the other hand, the Track Selection (TRACK_SEL) page is not available easily, so probably it should take the place of bookmarks or tap tempo in the F1–F4 button default options...?

Edited by jjonas
typo

Share this post


Link to post
Share on other sites
12 hours ago, tashikoma said:

but in MIXER maps does the hold SELECT button for activing LiveSend is implemented in EDIT Mode?

The LiveSend on/off option in the menu that's available on the MIXER page, by pressing SELECT, works only with the MIXER page settings. It doesn't work on the EDIT page (if that is what you mean).

LiveSend 'on' means that the changes you make to the different parameters on the MIXER page get sent immediately to the Port and Channel that are set for that slot on mixer map pages 1 and 2 (there are 16 slots per page). If LiveSend is 'off', changing e.g. the program change or volume page value has no immediate effect (you have to 'Dump' the mixer map with the SELECT menu if you want them to have effect), but if LiveSend is 'on', the changes to the values on the MIXER page will be sent immediately.

1 person likes this

Share this post


Link to post
Share on other sites

Feedback on 4.091 beta5, the extended chord table function.

  • configured a track for chords, initialized it, then set the parameter layer to Chrd2 and confirmed with GP button
  • switched to edit mode, stepped though all chords while playing them on my sound card.
  • Technically no issues found, only the 13  chords  (maj13, dom13, min13) are off  - my bad! all '20'  in the extended chord table code should be '21'.

updated 6 note extended chord table in C code:

 
{{0,7,-1,-1,-1,-1}, 'Pwr5'},
{{0,7,12,-1,-1,-1}, 'Pwr8'},
{{0,4,-1,-1,-1,-1}, 'R+mj3'},
{{0,3,-1,-1,-1,-1}, 'R+min3'},
{{0,4,7,-1,-1,-1}, 'Maj '},
{{0,5,7,-1,-1,-1}, 'Sus4'},
{{0,4,8,-1,-1,-1}, 'Maj+'},
{{0,4,7,9,-1,-1}, 'Maj6'},
{{0,4,7,11,-1,-1}, 'Maj7'},
{{0,4,7,14,-1,-1}, 'add9'},
{{0,4,7,11,14,-1}, 'Maj9'},
{{0,4,7,11,14,17}, 'Maj11'},
{{0,4,7,11,14,21}, 'Maj13'},
{{0,3,7,-1,-1,-1}, 'Min'},
{{0,3,7,9,-1,-1}, 'Min6'},
{{0,3,7,10,-1,-1}, 'Min7'},
{{0,3,7,14,-1,-1}, 'Minad9'},
{{0,3,7,10,14,-1}, 'Min9'},
{{0,3,7,10,14,17}, 'Min11'},
{{0,3,7,10,14,21}, 'Min13'},
{{0,4,7,10,-1,-1}, 'Dom7'},
{{0,5,7,10,-1,-1}, '7Sus4'},
{{0,4,7,10,14,-1}, 'Dom9'},
{{0,4,7,10,14,17}, 'Dom11'},
{{0,4,7,10,14,21}, 'Dom13'},
{{0,4,6,10,-1,-1}, '7b5'},
{{0,4,8,10,-1,-1}, '7#5'},
{{0,4,7,10,13,-1}, '7b9'},
{{0,4,7,10,15,-1}, '7#9'},
{{0,3,6,-1,-1,-1}, 'DimTri'},
{{0,3,6,9,-1,-1}, 'Dim'},
{{0,3,6,10,-1,-1}, 'm7b5'},

Share this post


Link to post
Share on other sites

One additional note to 4.091 beta: When AStart is 'on', the first played note gets recorded correctly on the active track, but if there are notes in other tracks, the notes in the first steps of those other tracks won't be played.

Share this post


Link to post
Share on other sites

First steps are also not played when midi delay is used. 

Share this post


Link to post
Share on other sites

Could it be possible that there is a little failure in the Step_digits shematic?

http://www.ucapps.de/midibox_seq/mbseq_v4_bpm_digits.pdf

I added the Step_digits to my box this week, everything works fine, but i had to swap the pinning dout -> 7 segment digits by 180°

I use Kingbright sc39 common cathode 7 segment digits and 4x Dout boards from mikes shop.

I checked the wiring twice, by driving the digits segment after segment with an external powersuppyl from my 8 pin dout connector.

Everything is connected as described in the shematic, but it only works right when i turn the connector 180°

No Issue as everything works great now:

http://midibox.org/forums/topic/12238-midibox-of-the-week-midibox-seq-of-gridracer/#comment-110125

But may be someone will run into the same problem.

Best Regards, Gridracer

 

 

Step_digits.jpg

Share this post


Link to post
Share on other sites
On 17. März 2016 at 2:06 PM, doc007 said:

Since I changed my SD card I can upload MBSEQ_HW.V4 and save it on my sd card to use my wilba's frontpanel. But later if I try for example to change the midi port ( pressed MENU + MIDI and select Midi Router on the left LCD ) I have an error :

[16338.948] [SEQ_FILE_C] Failed to open/create config file, status: -11
[16338.949] [SDCARD_ERROR:-11] DFS_OpenFile(..DFS_WRITE..) failed

What do you think ? hardware or software error ?

Thanks for the answer

Could it be, that no session has been created yet?

On 17. März 2016 at 10:45 PM, EsotericLabs said:

Feedback on 4.091 beta5, the extended chord table function.

  • configured a track for chords, initialized it, then set the parameter layer to Chrd2 and confirmed with GP button
  • switched to edit mode, stepped though all chords while playing them on my sound card.
  • Technically no issues found, only the 13  chords  (maj13, dom13, min13) are off  - my bad! all '20'  in the extended chord table code should be '21'.

updated 6 note extended chord table in C code:

Now also updated in the pre-release below

On 17. März 2016 at 9:05 AM, k-rAd MB6401 said:

i'm not sure if i'm the first to find this problem.....

Drum triggers from analog out  via ch16 will turn off if a delay of "0ms" is selected on all the midi outs in the bpm page.

In other words I can mute and unmute my 16 DOUT drum triggers by toggling between 0ms and -1ms on any midi out in the bpm page.

Currently running v 4.089 maybe this is already fixed in v 4.091?

please try the pre-release below (but I haven't changed anything for the drum triggers...)

22 hours ago, k-rAd MB6401 said:

First steps are also not played when midi delay is used. 

I can't reproduce this, the first steps are played when MIDI delay is used.
Is this somehow related to the issue that you reported on the 17th march?

On 19. März 2016 at 8:53 AM, jjonas said:

One additional note to 4.091 beta: When AStart is 'on', the first played note gets recorded correctly on the active track, but if there are notes in other tracks, the notes in the first steps of those other tracks won't be played.

I can't reproduce this, the first steps of all other tracks are played in step and live recording mode

On 17. März 2016 at 2:59 PM, jjonas said:

Feedback on 4.091 beta. To the extent I tested, everything worked except one thing:

  • I assigned JAM_LIVE and JAM_STEP to the F1–F4 buttons (and disabled the "zero-address" lines for the buttons from elsewhere in the HW setup file). JAM_LIVE has no visible effect, while JAM_STEP takes you to the Jam page, but the Step/Live mode is always what you have chosen manually on the Jam page earlier. In this sense BUTTON_JAM_STEP works like the old BUTTON_RECORD.

should work in the pre-release below

3 hours ago, Gridracer said:

Could it be possible that there is a little failure in the Step_digits shematic?

http://www.ucapps.de/midibox_seq/mbseq_v4_bpm_digits.pdf

Step_digits.jpg

Thanks for pointing this out! The schematic has been fixed.

On 17. März 2016 at 2:59 PM, jjonas said:

BTW at some point in the draft manual thread I suggested that the default F1–F4 button functions in the HW setup file should be updated. I'm sorry to flip-flop on this, but since I made that suggestion I found that the Bookmarks page is actually available rather easily with MENU + SELECT, and tap tempo is available similarly with MENU + PLAY. On the other hand, the Track Selection (TRACK_SEL) page is not available easily, so probably it should take the place of bookmarks or tap tempo in the F1–F4 button default options...?

I changed the Fx assignments again:

   o hwcfg/wilba*/MBSEQ_HW.V4: default F1-F4 assignments changed to:
     F1: Track Select, F2: Live Forwarding, F3: Recording, F4: Save All

Here a link to the pre-release:
-> (removed obsolete link)
-> please find pre7 in one of the next postings

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites
7 minutes ago, TK. said:

I can't reproduce this, the first steps of all other tracks are played in step and live recording mode

I tested some more, and found the first notes of other tracks won't play with AStart when Fwd is 'off'.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now