Search the Community

Showing results for tags 'Problem nach set USB-Name'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 6 results

  1. Hello everyone, at first I want to thank everyone who pushed along this project, I'm quite impressed about what I have seen in this forum and on ucapps !!  My problem is that everytime I try to make the skeleton version 1.1 I'm getting an error saying that pic18f452.h is not found. I checked all the PATH variables and the mios toolchain is located at usr/local. Hopefully some can help me please, my hairs already stand to the mountain and I don't know what to try anymore. Osx version: 10.14.2 Gputils version: 1.5.0-1 Sdcc version: 3.8.0 My Error Code: WARNING: Command line option --use-non-free not present.          When compiling for PIC14/PIC16, please provide --use-non-free          to get access to device headers and libraries.          If you do not use these, you may provide --no-warn-non-free          to suppress this warning (not recommended). In file included from main.c:20: /usr/local/bin/../share/sdcc/include/pic16/pic18fregs.h:427:25: fatal error: pic18f452.h: No such file or directory compilation terminated. ./include/c/cmios.h:250: syntax error: token -> 'char' ; column 43 make: *** [_output/main.o] Error 1   best regards  Jakob    
  2. Hi, I'm finishing my MB-6582 and can't find where I messed up. Encoders work, LEDs work, buttons work but don't do what they should do. Third bottom button for example makes third horizontal LED line blink, and LED's go on and of everywhere every time I push a button (LCD menu also changes) Encoders work fine. With the matrix test every LED lights up except the Control Env LED. When I push buttons nothing happens en the LCD. No shorts on the U20, 5V on the pins coming from JD5 and 10kOhm to 5V on every pin. I have not used the BC547 transistors and have bridged across. But that should work, right? Will be great full for any insights! Cheers FC
  3. wilba panel button issue

    first of all: thanks to TK for all your great work!!   so i finally got a seq v4 and soldered everything yesterday.   i got a MBHP_CORE_STM32F4, Wilba SEQ CS board and MBHP_MIDI_IO. i used the wilba MBSEQ_HW.V4 file without any changes and the newest firmware version (088)   no magic smoke after the first power up, but not all the buttons are working. only step  6,7, 10 ,11 of the step buttons are working and some of the other buttons also do nothing. (i didnt check which ones exactly, because i am unfamiliar with the user interface and never sure if every button should do something in the menu page i am in)   the encoders all work fine.   i didn't solder the leds yet, because the panel is not ready and it will be easier to get them in the right position if i do them later.   i did check the solder joints visually and the orientation of the ics on the CS Pcb -no obvious problems there. my roommate also build a unit for himself and we sourced all the parts together. his unit has the exact same problem. thats why i think it is not a simple solder error like a short or wrong orientation of some part. (because that would be unlikely to happen twice.)   please help me with troubleshooting. i don't really know where to start looking.   i am a midibox noob by the way. (only did a seqv4lite in the past) so it is probably a noob mistake...  
  4. Cannot upload MIOS V1.9G

    Hello,   I have built many MIDIbox projects over the years including the SEQV3, SEQV4 and recently the SEQV4L.  I had an unused MBHP8 core lying around and I thought I would try playing with the MB808 project to see what it is like.   It's been a while since I worked with the MBHP8 core so maybe I am missing something simple.  I can't seem to get the MIOS V1.9G to load into the PIC.  I burned the Bootloader V1.2B_pic_18F4620 into the PIC with no problem and in MIOS Studio 2 it sees the MBHP8 core and says that it is ready.  I browsed to the MIOS V1.9 hex file and started the upload.  After quite a while (about 15-20 minutes) it reaches 100% and looks like the upload was successful.   I restart the core and the two 2x40 displays never show anything.  I tried this procedure many times and can never get any display on the LCDs.  I removed the pic18F4620 from my SEQV3 and plugged it in and the displays work normally so I know the core board and wiring are all good.   I have tried two different PIC 4620 chips, two different USB/MIDI converters and two different computers.  One computer uses XP and the other one is Windows 7.   Burning the bootloader and then the MIOS into the PIC has always been easy, but I have spent two days on this with no success.   Any ideas on what I am missing?   Regards,   Tim Heffield 
  5. Hallo zusammen,   bei der Hitze ist es im Keller am schönsten, so dass ich etwas an meinem Bolltone-Orgel Controller gearbeitet habe. Ich habe die aktuelle MBNG-Software  aufgespielt und festgestellt dass die LCD-Ausgabe mittels Bootloader Updater korrekt gesetzt werden muss. Also Bootloader Updater 1.013 aufgespielt und Einstellung vorgenommen, LCD Ausgabe läuft. Bei der Gelegenheit fand ich es eine gute Idee den USB-Namen des Controller zu verändern, um eine eindeutige Zuordnung zu haben. Leider wird danach nur noch ein USB-Port im MIOS-Studio unter WIN7 angezeigt. Ich hätte allerdings schon gerne alle 4 möglichen. Single-USB ist auf 0 gesetzt, kannst also nicht sein.   Hat jemand einen Tip für mich?   Gruss   Roman
  6. MIDIBOX NG SD CARD PROBLEM

    Hello, i have just assembled my first LPC core and i will use the MIDIBOX NG firmware. i have also made the sd card adaptor as in the schematics.For a memory card i use a 4 gb micro sd.   When i open the core i get the message that there is NO sd card pluged.   when i write on the terminal the command "sdcard" i get this :    attached file at the bottom "reply.jpg"     I have checked 4 times all the connections from j16 to sd card adaptor and from the j16 to the pins of the LPC. I have also checked the presence of 3,3 volt and all seem perfect!   I can't find what am i do wrong. I am waitting for suggestions in order to continue my project. thanks in advance