Jump to content

MB-6582 CAN Bus Problem?


Recommended Posts

Hi all,


I've been lurking around here on the forums for a while now. Some years ago i built my first MBSID v2, completely based on the modular mbhp. The device didn't last very long as i decided to do some modifications and then never finished the work. So poor little sid had to wait for some time, but now i'm back putting the system back together. this time with a mb6582 board.


Now, this board is actually finished and tested and looks good and is supposedly working. But there's this one annoying problem i can't get rid of:


i can upload to the first core (id 0) and it clones to the second core (id 1). After that it resets again and gets stuck for a while with this display output:


Cloning Slave 02

Address: 0r Reset


After this core 4 (id 3) gets cloned properly.



Sadly, uploading the SID application to each core separately doesn't solve the situation. The problem stays and after every "cold" boot, the problem occurs again, sometimes even after the reset after core 3 got cloned.


important to know: i'm working with an adapted setup_8580 at the moment, the control surface i (re)built is customized and a mix between mb6582 cs and old sid v2 cs. but that's another topic, first i have to get the thing to boot properly.

I've also tried all the other .hex files, but they don't help either.



Well, i've already spent way too much time on this, any input is appreciated,






Link to comment
Share on other sites

Hi Jakob,


cloning will only work if the MBSID firmware is already installed on each PIC core.


Did you already check if the third PIC is working by putting it into the socket of the first PIC core?

If it isn't working: are you able to upload the firmware with MIOS Studio?


Best Regards, Thorsten.

Link to comment
Share on other sites

Hello Thorsten,


thanks for your reply!


Yes, the pic itself is working in the first socket and i'm able to upload the firmware. I have just confirmed that the problem still exists occurs the same way.

Also i discovered that even if only a single pic is installed in socket U1_CORE1 it is trying to clone itself to other pics.

Is this normal behaviour?


Of course this fails (with a long wait period for each of the pics 01-03) with error message:

Address: 0D !!!!


By the way, at the moment i'm still working with only the mb-6582 base board, nothing attached except 5V supply, 8x 24LC512 and MIDI In/Out. No Pics installed, but all shift registers stuffed. Maybe this causes strange behaviour?

Link to comment
Share on other sites

It's the normal behaviour that the master PIC tries to clone to all 3 slaves, regardless if they have been detected or not (fail-save measure).


But it isn't normal that cloning starts without pushing the MENU button during the boot phase.

In other words: it will only start on demand.


So, I assume that something is wrong with the DIN shift registers, because it seems that the firmware scans an actively pushed MENU button.

Or the pull-up resistors for digital inputs haven't been mounted yet.


Assumed that you've soldered at least the 10k pull-up at Pin #20 of the first PIC, it's better if you would remove all 74HC165 until the CS has been completed.


Thereafter cloning (and other random actions) shouldn't take place anymore.


Try cloning again once the CS is complete, and once you've to install a new firmware release.


Best Regards, Thorsten.

Link to comment
Share on other sites

Thanks for you help, Thorsten!


Indeed there was one shift register causing the cloning during reboot. I could identify it and change it to a new one. Problem solved for the moment and i can continue testing the CS.


What still doesn't seem to work is cloning and/or uploading via MIDI to PIC 02, MIDI connection in general to this core seems to be an issue too (and the jumper in the right place of course).

I guess it's possible that some incomplete uploading action has compromised the PIC in some way so i'll put this problem away and focus on the CS for the moment.


I'll keep you updated and will share some pictures soon ;)


Thanks again,



Link to comment
Share on other sites

I guess it's possible that some incomplete uploading action has compromised the PIC in some way so i'll put this problem away and focus on the CS for the moment.


You could "repair" the app installation the following way:

- put the PIC into the first socket (normally used for the master core)

- open MIOS Studio and select device ID 2 in MIOS Studio (assumed that you've already programmed the correct ID)

- power-off the MIDIbox

- load the mios_v1_9g/pic18f4685/midi/mios_v1_9g_pic18f4685.hex file into MIOS Studio and push the start button

- power-on the MIDIbox -> upload should start (if not: doublecheck the device ID)

- thereafter install the MIDIbox SID application

-> done


Best Regards, Thorsten.

Link to comment
Share on other sites

  • 2 weeks later...

Well, that's been quite a bit of work, but finally, i've found and fixed this.


It turns out (after checking really every slightest little other possibility) that the 10 MHz oscillator on this core was broken. I've changed it to a new one, as the last step before coming back here. Now all Cores are working and talking on MBNet!


Thank you again for the support on this and while i'm here:

a huge thank you in general to you, Thorsten, and the whole community here. There's so many amazing projects here and it's beautiful to see the development and all the new ideas after not visiting for a few years.


Currently i'm working on the last issue i have with my handwired CS... this too was 'quite a bit of work' so far. I hope to get this last problem sorted out this week so i can start making music with the beauty!

Although, right now i just remember that i haven't done a single audio test so far... i hope i don't run into bigger troubles again there :)

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...