Jump to content

unorthodox behavior midibox ng


Recommended Posts

Hi all,

i've connected a fatar df 61 keybed (now 49 keys working fine with midibox kb (v1.016) on lpc17) and now changed fw to midibox ng (v1.033) and have got some problems.

The order of the keys is wrong (rows etc.) and no velocity. No problem I thought and tried to adapt the keybed by setting kb 1 and tried debug mode via miosstudio but this is not working. The parameters seem to change but no visual or audible effect. The wrong order and missing velocity is still there. So what is wrong or do I have to compile the firmware first with other settings, if I want to use it with my keybed?



Edited by clem!
LPC17 added
Link to comment
Share on other sites


there is no need to recompile the firmware, all parameters can be configured in the .NGC file.

Could you please show me your configuration?

And do you get any error messages while uploading or editing the file?
(messages will be print in MIOS Terminal)

Best Regards, Thorsten.


Link to comment
Share on other sites

Thank you Thorsten for your help.

I've got the problem under control - yes there was an error, don't know why. But after formatting the sdcard and inserting the " typical keyboard configuration for a Fatar DF type with 61 keys" from the "midibox_ng_manual_ngc" into the default.ngc everything works as expected


[96240.295] [MBNG_LCD] no response from CLCD #1.1

[96240.295] [MBNG_LCD] no response from CLCD #2.1

[96240.295] Init DHCP
[96240.395] [network_device_init] PHY initialized
[96241.300] SD Card connected:
[96241.377] [MBNG_LCD] no response from CLCD #1.1
[96241.452] [MBNG_LCD] no response from CLCD #2.1
[96241.781] Init DHCP
[96241.786] [MBNG_FILE_C] Event Pool Number of Items: 198
[96241.786] [MBNG_FILE_C] Event Pool Allocation: 8636 of 24576 bytes (35%)
[96241.801] [MBNG_FILE_L:23] ERROR: 'EVENT std_rgbled': label too long, should be 8 chars maximum!
[96241.806] [MBNG_FILE_L] 1 error has been found while generating the .BIN file - please fix DEFAULT.NGL!
[96241.813] [MBNG_FILE_S] snapshot #0 not stored in /DEFAULT.NGS yet
[96241.817] [MBNG_FILE_R] /DEFAULT.NGR (optional run script) not found
[96243.817] Creating initial DEFAULT.NGL file
[96243.817] [MBNG_FILE_L] The file '/DEFAULT.NGL' already exists - won't create a new one!
[96243.818] Failed to create file! (status: -1)




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...