Jump to content

!! HARD FAULT !! at PC=0Xffff0201 when using SECTION CONTROL


Recommended Posts

Hi, I have built the Midiphy version of the SEQ4+ and I stumbled upon some weird behaviour.

I tried to use the Section Control tool, but it crashes from the moment I press the E key and above on my external keyboard.
Then the screen shows “TODO page”. It still plays the partial sequence though, but When I press EDIT It sometimes returns back to the edit page but mostly it crashes and reads “!! HARD FAULT !! at PC=0Xffff0201”
This happens in every octave. I've tried several different keyboards.
The first three keys C, C# (from an external keyboard) work as intentioned, but from D on it shows errated LED flashing and from E it goes to a TODO page… weird

This whole behaviour renders the Section Control function useless of course.
Anyone experienced this before? Any ideas?

I'm on the latest firmware.

Link to comment
Share on other sites

Thanks for the feedback! It was a nice challenge to nail down this issue, because it only appears in conjunction with the TPD, which explains why many other MBSEQ users didn't notice this so far! :)

Please try this version: http://www.ucapps.de/mios32/midibox_seq_v4_098_pre3.zip

Best Regards, Thorsten.

P.S.: background -> https://github.com/midibox/mios32/commit/66fa4df5960d51c93ee90c065062c5ba28fdde69

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...