Jump to content

odd response in mios studio after uploading modified mb64 hex


Recommended Posts


After uploading a .hex I built myself from a very slightly modified version of midibox64 I get a weird response in MIOS studio when querying the device

"Detected MIOS8 and MIOS32 response - selection not supported yet!

Check MIDI IN/OUT connections

and Device ID!"

The midibox application runs fine on the device, all midi works as expected, but MIOS studio appears unable to speak to it.

I'm not an assembly guy, I'm a PHP guy, but I'm generally good to go at making small hacks in OS software and getting it to build. Here's what I did...

I wanted to remap the pins that the menu's were assigned to in midibox 64, so I grabbed midibox64_v2_4d.zip from the MIOS8 download section here http://ucapps.de/mios_download.html

I'm on OS X so I used homebrew to grab and build GPUtils 0.13.7.

I edited setup_midibox64.asm and changed the pin numbers here.


#define DEFAULT_DIN_MENU_EXEC 32 ; menu exec button assigned to DIN pin #7

#define DEFAULT_DIN_MENU_RIGHT 36 ; menu right button assigned to DIN pin #6

#define DEFAULT_DIN_MENU_LEFT 39 ; menu left button assigned to DIN pin #5

#define DEFAULT_DIN_MENU_SNAPSHOT 33 ; menu snapshot button assigned to DIN pin #4


typed make, got no errors and a brand new .hex so I uploaded it and here I am.

I have also tried upgrading MIOS on the core to V1.9g which went fine, and then uploaded the new .hex again with the same end result that I get the "Detected MIOS8 and MIOS32 response" error.

If I query the core in the 2secs after cold start then MIOS studio shows the resonse..

"Operating System: MIOS8

Board: MBHP_CORE or similar

Core Family: PIC18F

Bootloader is up & running!"

I can only assume I've skipped some docs somewhere and missed some fundamental build step here, and would appreciate a point in the right direction.

Link to comment
Share on other sites


how is your core module connected to your computer?

Are you using a MIOS32 based core module as a USB-MIDI interface, and does it have the same device ID like the PIC?

In this case, MIOS Studio would respond with this message on a query.

If this isn't the case: needs further analysis, but here a trick which should always help:

- power-off the core

- start .hex upload, you will be asked to power-on the core

- power-on the core

Best Regards, Thorsten.

Link to comment
Share on other sites

Hi Thorsten,

First off general thanks for ucapps/MIOS/midibox in general, please enjoy a beer on me :D

I've only got the one core. The core is connected to a usb midisport 4x4 which had worked fine for a couple of sysx reads and writes earlier in the day. There's no other midi gear connected.

I'll have another play with it in a bit.

What sort of .hex are you suggesting I try, an app or mios? The initial boot loader does respond so I can apparently rewrite mios and then upload an app without any probs.

Edited by jentulman
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...