Jump to content

[solved] Address exceeds maximum range for this processor


Recommended Posts

Hi all,

if i try to compile one of the orginal FM 1.4 pic18f452.asm

via make then i get a lot of

"Address exceeds maximum range for this processor."

make: *** [setup_pic18f452_mbfm_tk.hex] Error 1


I suspected there is may some pic18f4685 option enabled

inside the asm but they are all turned off.

The pic18f4685.asm are compiled successful.

I have installed the correct version from the toolchain:

SDCC 2.80

MYSYS 1.0.11

Gputils 0.14.3 (also tried 1.0)

The forum search did not find a working solution.

Someone know what to do?

Best regards


Edited by Marxon
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...