Sign in to follow this  
Followers 0
niles

SD Card detection - not found

1 post in this topic

Hi - very new to the forums and building a kit for the seq v4+, I have received some great help from Andy and Peter over on the seq v4+ troubleshooting thread but I have a more general SD card handling question. 

Background: I'm having a hard time getting the SD card to be 'found' so I can load a test program, and have not had success at all with that. Just keeps saying SD card not found. I've tried many variations of cards, my latest is a brand new 4GB sandisk SDHC microsd with adapter formatted FAT32. I have NG 1.036 installed and everything seems to be good so far...MIOS studio recognizes it no problem but just no SD card is found. I can confirm the cable is fine, no shorts between pins, I have continuity from card socket (a SD-RSMT-2-MQ) to the MCU board and even tried the 'simple SD card cable' from TK's website. Nothing so far has worked getting the SD card found. I'm on Win10 but same happens on Mac laptop. I think I had the cable backwards the first time on power up but I don't see how that could have fried anything, besides it still runs in MIOS studio. 

How does the SD card get detected in the STM32F4? Is it the mechanical switch on the side where the 'write protect' and 'card insert detection' are both tied to ground? Or is it one of the pins like CS? (I've read there are a few ways possible).CS (SD socket pin 1, J16 pin 10, RC1) is tied to GND. Is that right?

Is there any type of way to 'fake' SD card detected because maybe it can read/write it ok but thinks it's not in there? Or perhaps a MIOS studio diagnostic? I see there is some commands via the 'help' command but not sure if any apply to SD card testing. 

I appreciate any insight anyone has into this, 

Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0