Jump to content

Increase USB midi input buffer: How to?


Recommended Posts

My MIO32 application is failing when the host computer sends too much USB sysex to my F4 core at application startup. 

I have tried to increase MIOS32_USB_MIDI_RX_BUFFER_SIZE to 0x400 and MIOS32_USB_MIDI_DATA_IN_SIZE to 128 (256 and the USB of the core basically stops working) This has not changed the behaviour...

I'm not sure what I'm doing but I would like to increase the USB midi data rx buffer.

Thanks for any help. 

Link to post
Share on other sites

Hello

Don't know if it's related but I remember having app issue (MB_NG) when in debug mode combined with large "regular" data transfer or config file update from/to computer.

So maybe as a start just be sure debug mod is off as soon as you don't need it and send lot of data.

Best

Zam

 

Link to post
Share on other sites

Thanks for the hint!

It caused me to look at the size of another queue in my app which made a difference. However it did not come fully good until I disabled debug messages as you suggested. I had been using

#define MIOS32_MIDI_DEBUG_PORT UART0

 which I didn't would be a problem but it clearly is/was.

I'm now thinking about how I increase the (data buffer) capacity for debug messages. My app is not resource heavy and I'm using an F4 core, so there should be plenty available. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...