Jump to content

ksir

Members
  • Posts

    80
  • Joined

  • Last visited

  • Days Won

    5

ksir last won the day on January 15

ksir had the most liked content!

Profile Information

  • Gender
    Male
  • Location
    Montélimar, Drôme, France

Recent Profile Visitors

3,875 profile views

ksir's Achievements

MIDIbox Addict

MIDIbox Addict (2/4)

7

Reputation

  1. I now have to manage to turn off and on the rgbled under the switches. I succeeded with something like:
  2. I understood I have to use set_active . I managed to make it work on encoder and push button set_active (id)ENC:10 1 set_active (id)BUTTON:117 1 I didn't succeed on Ainser, I tried: set_active (id)AINSER:133 1 #EDIT: There were errors in my code. It works now. The code below works
  3. Good morning SetBankOfHwId only works on encoders? I tried on fader and Switch without result
  4. ksir

    Modul Box NG V2

    J'ai approfondi mes tests. Si je ne connecte pas l'alimentation externe, je n'ai pas de problème avec le clignotement des LED. si j'ajoute de l'alimentation les LED clignotent voici comment je branche l'alimentation : (après avoir déconnecté le j17) le câblage est-il correct ? j'ai lu ici : http://www.ucapps.de/midibox_ng_manual_hw.html dois-je connecter j4.vs à une alimentation 0V ? et j4b.5v à 5v psu ? ( i use this PSU : https://secure.reichelt.com/fr/fr/bloc-d-alimentation-d-coupage-ferm-50-w-5-v-10-a-mw-lrs-50-5-p202960.html?&trstct=pol_4&nbc=1 )
  5. ksir

    Modul Box NG V2

    I tried adding a 10uf capacitor every 128 LEDs. I tried to connect dout of the last led to gnd. I tried to connect the end of the last LED to a 120 homs resistor. the last LEDs still flicker ( just for information I specify that I modified mios32\apps\controllers\midibox_ng_v1\src\mbng_rgbled.c line 116 : u32 num_leds = 15; // TODO: we could make this configurable! )
  6. hello, I use my controller with fl studio with which it is possible to create python scripts. https://www.image-line.com/fl-studio-learning/fl-studio-online-manual/html/midi_scripting.htm I have already tried with a small script which allows you to create a “learn” mode Would it be possible to display the name of the parameter that I can retrieve with "getParamName" to display them on the screens of my midibox ng? I think that fl studio's python scripts can be a very powerful tool combined with midibox ng. but I have no other idea of what could be interesting. If you have any suggestions thank you # name=ModulBox # définir les variables # Importer les modules nécessaires pour utiliser les fonctionnalités de FL Studio import midi import device import playlist import channels import mixer import patterns import arrangement import ui import transport import plugins import general import launchMapPages # Définir le numéro du contrôleur MIDI que vous souhaitez utiliser pour le bouton Learn BoutonLearn = 31 # Initialiser la variable Mode_Learn avec une valeur booléenne, Cette variable indique si le mode Learn est actif ou non ModeLearn = False # Fonction appelée lorsqu'un message MIDI est reçu par FL Studio def OnMidiMsg(event): # Utiliser la variable globale Mode_Learn dans la fonction OnMidiMsg global ModeLearn # Indiquer que l'événement n'a pas encore été traité event.handled = False # Afficher des informations sur l'événement MIDI reçu print('MidiId: ', event.midiId, 'EventData1: ', event.data1, 'eventData2: ', event.data2,'eventMidiChan', event.midiChan, 'eventMidiPort: ', event.port) # Si l'événement correspond à l'appui sur le bouton Learn, activer ou désactiver le mode Learn en fonction de la valeur de l'événement if event.data1 == BoutonLearn and event.data2 == 127: ModeLearn = True print(ModeLearn,"Mode Learn actif.") elif event.data1 == BoutonLearn and event.data2 == 0: ModeLearn = False print(ModeLearn,"Mode Learn Inactif.") # Si la valeur de l'événement est supérieure à 0 et que le mode Learn est actif, lier le dernier paramètre modifié au contrôleur MIDI utilisé et désactiver le mode Learn if event.data2 >0 and ModeLearn==True and event.data1 != BoutonLearn: # Utiliser la fonction device.linkToLastTweaked() avec les arguments appropriés device.linkToLastTweaked(event.data1, event.midiChan+1,) ModeLearn = False #test extinction led #device.midiOutMsg(176, event.midiChan, BoutonLearn, 0) device.midiOutMsg(176, 15, BoutonLearn, 0) print(ModeLearn,"Mode Learn Inactif.") # Indiquer que l'événement a été traité par le script en mettant la valeur de event.handled à True event.handled = True # Indiquer que l'événement a été traité par le script en mettant la valeur de event.handled à True #event.handled = True ''' '''
  7. ksir

    Modul Box NG V2

    Hello, first of all thank you for your previous answers. I haven't fixed the problem with the pads yet. I'm focusing on another problem for now: with the LED rings. with 16 led ring of 16 led no problem. when I add more, the LEDs flicker. https://youtu.be/HyLkVeFtALw?si=gT09lbCxEwLRmHt8 I read here: http://midibox.org/forums/topic/21095-lre-4x1-breakable-rgb-led-ringrotary-encoder-pcb-bulk-order/?do=findComment&comment=184155 FantomXR had flickering problems, solved with a 10uf capacitor. Should I add a 10uf capacitor at the input of my LED ring cards? (as in the image below) (C129) To understand my configuration see the pdfs: LEDRING: https://drive.google.com/file/d/1XpDQBUE42IqXpXicO--B2gfIoNQDh5ga/view?usp=drive_link “power card”: https://drive.google.com/file/d/1NJ-H-QXD-tl9rU6nbYdEh2Q4jFqjWt6b/view?usp=drive_link I made a PCB that I call a “power card” that I supply with 5v 10 amps. The J2 connector of the "power card" is connected to J4b of core 32. Connector J44 of the first OLED card is connected to J3 of the “power card” Connector J45 of the first OLED card is connected to J4 of the “power card” Connector J44 of the second OLED card is connected to J5 of the “power card” Connector J45 of the second OLED card is connected to J6 of the “power card” etc.. Thank you
  8. ksir

    Ssd1322

    THANKS . I don't understand the interconnection diagram clearly. My screen has 16 pins not 20 pins and the name of the pins on the seller's diagram does not correspond. hence my confusion ( https://fr.aliexpress.com/item/32414142892.html?gatewayAdapt=glo2fra ) I just tried to match : it's ok ? i can't fide GLCD_SSD1322
  9. ksir

    Ssd1322

    Hello, I have a tw56640320b03 screen, is it possible to make it work with midibox ng? THANKS https://s.alicdn.com/@sc01/kf/HTB19t6LcXkoBKNjSZFkq6z4tFXa3/232025343/HTB19t6LcXkoBKNjSZFkq6z4tFXa3.jpg
  10. I am interested in the 2 white ones with push button
  11. ksir

    Modul Box NG V2

    thank you for your help I tried : #PADS EVENT_BUTTON id= 65 hw_id= 33 fwd_id=RGBLED:137 type=CC chn= 1 cc= 33 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 50:100:10 debounce_cycles=65535 EVENT_BUTTON id= 66 hw_id= 35 fwd_id=RGBLED:138 type=CC chn= 1 cc= 34 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 100:100:10 debounce_cycles=65535 EVENT_BUTTON id= 67 hw_id= 37 fwd_id=RGBLED:139 type=CC chn= 1 cc= 35 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 0:100:10 debounce_cycles=65535 EVENT_BUTTON id= 68 hw_id= 39 fwd_id=RGBLED:140 type=CC chn= 1 cc= 36 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 200:100:10 debounce_cycles=65535 EVENT_BUTTON id= 69 hw_id= 34 fwd_id=RGBLED:141 type=CC chn= 1 cc= 37 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 50:100:10 debounce_cycles=65535 EVENT_BUTTON id= 70 hw_id= 36 fwd_id=RGBLED:142 type=CC chn= 1 cc= 38 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 100:100:10 debounce_cycles=65535 EVENT_BUTTON id= 71 hw_id= 38 fwd_id=RGBLED:143 type=CC chn= 1 cc= 39 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 0:100:10 debounce_cycles=65535 EVENT_BUTTON id= 72 hw_id= 40 fwd_id=RGBLED:144 type=CC chn= 1 cc= 40 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 200:100:10 debounce_cycles=65535 #PADS EVENT_BUTTON id= 73 hw_id= 41 fwd_id=RGBLED:129 type=CC chn= 1 cc= 41 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 50:100:10 debounce_cycles=65535 EVENT_BUTTON id= 74 hw_id= 43 fwd_id=RGBLED:130 type=CC chn= 1 cc= 42 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 100:100:10 debounce_cycles=65535 EVENT_BUTTON id= 75 hw_id= 45 fwd_id=RGBLED:131 type=CC chn= 1 cc= 43 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 0:100:10 debounce_cycles=65535 EVENT_BUTTON id= 76 hw_id= 47 fwd_id=RGBLED:132 type=CC chn= 1 cc= 44 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 200:100:10 debounce_cycles=65535 EVENT_BUTTON id= 77 hw_id= 42 fwd_id=RGBLED:133 type=CC chn= 1 cc= 45 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 50:100:10 debounce_cycles=65535 EVENT_BUTTON id= 78 hw_id= 44 fwd_id=RGBLED:134 type=CC chn= 1 cc= 46 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 100:100:10 debounce_cycles=65535 EVENT_BUTTON id= 79 hw_id= 46 fwd_id=RGBLED:135 type=CC chn= 1 cc= 47 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 0:100:10 debounce_cycles=65535 EVENT_BUTTON id= 80 hw_id= 48 fwd_id=RGBLED:136 type=CC chn= 1 cc= 48 button_mode= Toggle label= "^std_btn" bank= 1 hsv= 200:100:10 debounce_cycles=65535 doesn't seem to work
  12. ksir

    Modul Box NG V2

    Hello, I haven't studied your answer in depth yet, but here is an example of declaration of my pads in ngc file #PADS EVENT_BUTTON id= 33 fwd_id=RGBLED:137 hsv=50:100:10 type=CC chn= 1 cc= 33 button_mode=Toggle label="^std_btn" EVENT_BUTTON id= 35 fwd_id=RGBLED:138 hsv=100:100:10 type=CC chn= 1 cc= 35 button_mode=Toggle label="^std_btn"
  13. ksir

    Modul Box NG V2

    Hello, I have a rebound problem with the sparkfun pads, do you have an idea how to fix this? Hardware? Software ? Thanks The rest works fine
  14. ksir

    Modul Box NG V2

    yes all encoders work, after having pushed the tests a little, I have the impression that it is the accent (é) in the comments of my code which poses a problem and erases lines at the end of my ngc file
  15. ksir

    Modul Box NG V2

    Thank you again for your help I tried : # encode hardware configuration ENC n= 16 sr= 4 pins=5:4 type=non_detented ENC n= 15 sr= 4 pins=7:6 type=non_detented ENC n= 2 sr= 1 pins=1:0 type=non_detented ENC n= 1 sr= 1 pins=3:2 type=non_detented ENC n= 4 sr= 1 pins=5:4 type=non_detented ENC n= 3 sr= 1 pins=7:6 type=non_detented ENC n= 6 sr= 2 pins=1:0 type=non_detented ENC n= 5 sr= 2 pins=3:2 type=non_detented ENC n= 8 sr= 2 pins=5:4 type=non_detented ENC n= 7 sr= 2 pins=7:6 type=non_detented ENC n= 10 sr= 3 pins=1:0 type=non_detented ENC n= 9 sr= 3 pins=3:2 type=non_detented ENC n= 12 sr= 3 pins=5:4 type=non_detented ENC n= 11 sr= 3 pins=7:6 type=non_detented ENC n= 14 sr= 4 pins=1:0 type=non_detented ENC n= 13 sr= 4 pins=3:2 type=non_detented It's encoder 13 that didn't work anymore I moved the encoder hardware config code to the middle of the code, instead of putting it at the end, now it works
×
×
  • Create New...