Per S

MIOS Studio 2.2.3 and Midio128V2

5 posts in this topic

Yesterday I needed to update my Midio128V2. I tried the MIOS Studio for the first time but the result was more or less a disaster.

Here's the INI file:


##########################################

# Pin   # On Evnt # Off Evnt # Behaviour #

##########################################

    1 =  90 30 01   80 30 01   @OnOff # Spare

    2 =  90 31 02   80 31 02   @OnOff # Spare

    3 =  90 32 03   80 32 03   @OnOff # Spare

    4 =  90 33 04   80 33 04   @OnOff # Spare

    5 =  90 34 05   80 34 05   @OnOff # Spare

    6 =  90 35 06   80 35 06   @OnOff # Spare

The MIOS Studio looks like this:

post-3708-0-23324700-1335670950_thumb.jp

The problem seems to be that the Note Off in the Off Event is replaced by Disabled. If pressing Send all of the Note Off's are effectively removed.

I had to use the old fashioned way of using Midi-Ox to send the syx file to restore the function.

Share this post


Link to post
Share on other sites

Hi Per,

I would like to reproduce this, but need more informations.

Did you push the "Receive" button before changing the configuration, or did you just send a new configuration without taking care for the previous config?

And which MIDIO128 V2 version is installed? The latest release is v2.2c

Sidenote: instead of using MIDI-Ox, you could also upload the .syx file with the SysEx tool of MIOS Studio.

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Here’s some more information:

I pressed the Receive button first, so what you see in the attachment is what came out from a correct INI file (converted to SYX) and loaded by Midi-Ox.

I can also see that CC’s are correct. PC’s have Disabled in the Off Event and are coded OnOnly so I presume this is correct. I only have NoteOn/off, PC and CC in my application so I don’t know about other status bytes.

I run 2.2b as I saw no need for upgrading to 2.2c. Have not made any changes or updates for years, everything runs fine.

System is Win7 64bit.

Share this post


Link to post
Share on other sites

I run 2.2b as I saw no need for upgrading to 2.2c. Have not made any changes or updates for years, everything runs fine.

System is Win7 64bit.

As a general rule of thumb, when something does not work it's a good idea to update to the latest version before attempting to troubleshoot. Chances are the problem has been fixed already. Outdated versions are usually never supported longer, as this would create a lot of overhead for the developer.

Share this post


Link to post
Share on other sites

I have just had this exact same problem occur to me.

 

This is the first time I have had need to modify my MidiBox MIDIO128 system for about 4 years.  The system has been running beautifully for about 6 years and now I am adapting it to a new physical console.  This new MIOS Studio and the MIDIO128 tool are very good and such a long way from how we used to have to configure the MidiBox.  (I don't use Midi-Ox at all, as all functions are done beautifully in MIOS Studio)

 

In the new console I am using 1x CORE8 and 3x DIN.  I am using a MIDIO128 hex file that was distributed on the Miditzer forum.  This hex file has been specially modified to activate 3x Analogue inputs direct on the CORE8 to pins on J5A.  (I am not aware of an updated version of this file being circulated) [could the 3x analogue function be added into the standard application hex?]

 

Most of my inputs are Program Change messages so the OFF function doesn't matter.  I entered 25 lines of Note On - Note Off messages, up loaded it and all was good.  I then went back, received the config so far and proceeded to add another 8 lines of Note On - Note Off messages and upload.  They all checked out fine, but the notes of the previous 25 lines all kept playing.  I went back and had a look and they all had disable in the OFF message side.  I fixed them and went back and found that the other 8x had then done the same thing.  I re-entered all 33 lines and everything is now fine.

 

I can imagine if someone had many lines of Note On - Note Off messages this would cause a great deal of confusion and frustration.

 

In looking at it in detail I can report that trying to load a saved .syx file doesn't show the Note Off messages, and retrieving the current config from the CORE8 doesn't bring back the Note Off messages.  I hope this helps in trying to fix this.

 

Regards

Rick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now