Timsynth

Cannot upload MIOS V1.9G

6 posts in this topic

Hello,

 

I have built many MIDIbox projects over the years including the SEQV3, SEQV4 and recently the SEQV4L.  I had an unused MBHP8 core lying around and I thought I would try playing with the MB808 project to see what it is like.

 

It's been a while since I worked with the MBHP8 core so maybe I am missing something simple.  I can't seem to get the MIOS V1.9G to load into the PIC.  I burned the Bootloader V1.2B_pic_18F4620 into the PIC with no problem and in MIOS Studio 2 it sees the MBHP8 core and says that it is ready.  I browsed to the MIOS V1.9 hex file and started the upload.  After quite a while (about 15-20 minutes) it reaches 100% and looks like the upload was successful.

 

I restart the core and the two 2x40 displays never show anything.  I tried this procedure many times and can never get any display on the LCDs.  I removed the pic18F4620 from my SEQV3 and plugged it in and the displays work normally so I know the core board and wiring are all good.

 

I have tried two different PIC 4620 chips, two different USB/MIDI converters and two different computers.  One computer uses XP and the other one is Windows 7.

 

Burning the bootloader and then the MIOS into the PIC has always been easy, but I have spent two days on this with no success.

 

Any ideas on what I am missing?

 

Regards,

 

Tim Heffield 

Share this post


Link to post
Share on other sites

Hi Tim,

 

 

 

After quite a while (about 15-20 minutes) it reaches 100% and looks like the upload was successful.

 

something is wrong here, the upload shouldn't take more than 20 seconds... and not 20 minutes!

 

Could you please show the complete MIDI IN log?

(just right-click on the MIDI IN monitor panel, select copy, and then paste the log into this posting)

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Hi Thorsten,
 
Thanks so much for the reply!
 
The PC OS is Windows 7, 32 Bit and the USB/Midi interface is an Edirol UM-2EX.

 

Here is the data from the MIdi Mon Window:

 

Scanning for MIDI Inputs...
[1] Automap MIDI
[2] Automap Propellerhead
[3] UM-2 (*)
MIDI Monitor ready.
[13191.193] f0 00 00 7e 40 00 01 f7
 

 

 I have a screenshot of the MIOS screen once the upload is completed if that would be helpful, but i couldn't figure out how to attach it.

 

 

 

Regards,

 

Tim

Edited by Timsynth

Share this post


Link to post
Share on other sites

Hi Tim,

 

ok, it looks like the MIDI transfer between PC and PIC is not working, because the PIC doesn't respond on incoming commands.

So, there is either a problem with the MIDI OUT port of your PC, or with the MIDI IN of the MBHP_CORE module.

Here the troubleshooting guide which helps to find the root cause: http://www.ucapps.de/howto_debug_midi.html

 

It's a bug in MIOS Studio, that it says that the upload was successfull in this case!

I will improve the message (and I think that the best way would be to output the link to this troubleshooting page ;-))

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites
It's a bug in MIOS Studio, that it says that the upload was successfull in this case!

I will improve the message (and I think that the best way would be to output the link to this troubleshooting page ;-))

 

done in MIOS Studio 2.4.6

-> 

 

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Hi Thorsten,

 

I went through the first steps of the troubleshooting and it became obvious that the core was not receiving data as you said.  I looked more closely at the core and found that I installed the diode backwards on the input to the optocoupler so it was my fault.

 

Thanks so much for taking your time to check this out!  The MIOS and MB808 app loaded flawlessly within seconds.

 

So, problem completely solved.

 

Regards,

 

-Tim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now