Jump to content

usb only powers mbseqv4 How to enable usb to pass information?


Recommended Posts

Hi everyone & Happy New Year!

I am hoping my problem is very simple to fix!

If anyone can help me it would be very much appreciated!

I have read quite a few threads to try & find a solution, but I am still unsure of how to proceed as I am a newbie & I am very inexperienced with midibox.

The midiboxSEQv4 works fine with current firmware 0.89 apart from usb does not make contact to receive or pass information to computer or MIOS software

When I plug my midiboxSEQv4 in by usb to my computer (WIN7x64) nothing happens apart from powering the midibox.

I have tried installing the gm5x64 usb driver but it times out when midibox is connected.

I have tried a WIN7x32 computer too with the gm5x32 usb driver & I get the same result, time out.

In mios software using both Win7x64 & Win&x32 when the SEQv4 is connected by usb, no core/midibox is found in mios software midi ports.



If I use midi interface Edirol UM-880, 8 midi ports are picked up In & Out with mios software.

Using midi ports 1 In & Out on midibox results in contact with mios software                       





Checking midi on the thread How to debug midi  loopback works with midi using my interface UM-880 using mios virtual kb as can be seen below.




None of my usb ports are enabled on the SEQv4 if I understand this system information & that is why I can not upload firmware.



I can not seem to find the bootloader information using mios software, which from what I understand is what I need to enable usb.

When I have reset the SEQv4 using mios software it shows Bootloader mode for may be a second, then loads in to 0.89 firmware.


So there must be Bootloader already flashed?

Reading the MIOS32 Bootloader for Newbies thread  & Experts thread, From what I understand is that if the Bootloader is already present which it seem it is, I shouldn't have to open the actual midibox If I wanted to upload firmware.

Possibly fastboot is enabled, stopping upload?

How come my usb ports are disabled, when they should be enabled by default?



Explanation of the most important parameters:

  • fastboot: normaly after power-on the bootloader waits for an upload request for ca. 3 seconds before the actual application will be started.
    This is a fail-safe measure which is mainly relevant for developers who don't want to open their MIDIbox and stuff the "BSL Hold" jumper (J27) if the application crashed during the initialisation phase.
    However, for common users this wait phase shouldn't be really necessary, especially if they are using a stable application.
    Therefore: enter
         set fastboot 1
    in the MIOS Terminal to skip this phase, and to start the application immediately!
    You will like this option! :-)
    Note that no MIDI upload request will be sent during power-on anymore!
    Please consider this when reading documentation about MIDI troubleshooting.
  • single_usb: use this option if you are working with a Windows PC which can't handle multiple USB ports correctly.
    E.g. applications like MIDIO128, MIDIbox SEQ or MIDIbox NG enable 4 USB ports by default. Certain Windows versions (such as Windows XP) are failing: sometimes MIDI events get stucked, MIOS Studio filebrowser operations abort with an error message, etc.
    Even the installation of the GM5 USB MIDI driver doesn't help (which sometimes solves the issues under Windows7), or causes new issues when multiple core modules are connected.
    As a workaround, it's possible to enforce that only a single USB port is enabled:
         set single_usb 1
    This should solve the windows USB MIDI issues - with the drawback of the reduced functionality.
  • enforce_usb_device: this option has only an effect on core modules which support USB Host mode such as the MBHP_CORE_STM32F4 module.
    If set to 1, USB device mode will be selected regardless of the cable type A or B. If set to 0 (default), USB host mode will be selected with A type cables, and USB device mode with B type cables.
    This type of selection is also known as USB OTG (on-the-go).
    The usage of the default setup is normally save, "set enforce_usb_device 1" only if you are using an "unusual" cable.
    Note that setting this parameter could lead to a dilemma: it can only be set with a bidirectional MIDI connection between the core module and the MIOS Studio terminal. If you don't own a Micro-USB B type cable to establish this connection, the only possibility to change this parameter is a "traditional" MIDI connection via MIDI IN/OUT between the core module and your PC/Mac!
    If you don't own a MIDI interface for such a connection, it's cheaper to buy the right Micro-USB cable - once you've changed the parameter, you can use the "improper" cable for your core!


Do I have to follow the instructions on the MIOS32 Bootloader for Newbies thread to achieve the upload of the new MBSEQv4 firmware & to find out what version of Bootloader?


MBHP_CORE_STM32F4 and STM32F4DISCOVERY: press and hold the blue "User" button, trigger the black "Reset" button shortly. This will restart the core and enforce bootloader mode as long as the blue "User" button is pressed

Any ideas what I need to do?


If any more pictures or info is needed I will try to provide, no problem.

Sorry for the newbie questions everyone.

Thanks in advance

All the best

Long Shore Drift



Edited by LongShoreDrift
Pressed enter by mistake when creating title.
Link to comment
Share on other sites

Yes, the bootloader is already part of the firmware, and USB should work by default, no additional measures required.

Let's start with the stupid questions:

  • are you sure that your Micro USB cable is working?
    I mention this, since some mobile phones come with cables which can only be used to supply power for charging, but they can't be used for a data connection
  • did you already doublecheck in the windows system control panel, if a USB device has been detected but disabled?
    There are situations in Windows, where it will be disabled, e.g. when you disconnect the cable during the first registration of the new device.
    It helps to remove the disabled USB interface, and to reconnect the cable
  • if this doesn't help - just to be sure (because you are working under windows...)
    Did you already try to turn your PC off and on again? ;-)

Best Regards, Thorsten.

P.S.: the firmware version is V4.089, not 0.89

Link to comment
Share on other sites

Hi TK,

Thank you for your reply,

The Micro USB cable is an adapter to female USB B that has been glued over on the Micro USB section of the core.

I haven't been able to test the Micro cable adapter USB cable properly yet because of the glue, I have tried different Male USB B cables & get the same result.

Would using Isopropyl Alcohol be safe to use to remove the glue that covers the Micro USB, so I can test the cable, or is their a better method?.568aa125b7a80_MBSEQgluedmicroport.thumb.568aa14a4f865_MBSEQgluedmicroport2.thumb

I have un-installed the gm5x64 driver, the MIOS32 Bootloader driver, & the USB Composite Device (midibox) driver.

Rebooted PC checked in device manager for any more hidden drivers associated, found nothing else.

I powered on midibox through USB to PC, no drivers install or make the "USB Sound" I check device manger for midibox ,MIOS32 drivers nothing.


I hold "user" button & then click "reset" button once & keep "user" button pressed,  The USB Composite Device (midibox) driver & MIOS32 Bootloader driver install sucessfully,

I power cycled the midibox check MIOS software no midi port contact, I check device manager, USB Composite Device (midibox) driver has disappeared, MIOS32 Bootloader driver

says, "Currently, this hardware device is not connected to the computer. (Code 45)To fix this problem, reconnect this hardware device to the computer."



I reboot PC, power midibox, nothing apart from power to midibox. The midibox driver is gone & MIOS32 Bootloader driver is enabled in device manager only when the "user" button is pressed & held & "reset" clicked. In MIOS software MIOS32 Bootloader is available in midi ports but command terminal does not respond to any command.

When the "user" button is released, contact is lost with PC & MIOS software



Checking MIOS file browser this is the response I get.



I have updated ST firmware to V2 when checking Bootloader, Bootloader is up to date.

Upload of MBSEQV4.090 HEX to midibox went smoothly.

The hwcfg file though I can't upload via MIOS32 Bootloader, will try via Midi?

I can not find the SD card.

Do I create the directory in MIOS file browser if I can access it?

The midibox seems to be functioning so far as it should, but without USB driver function....

I'm not sure how to proceed next?



all the best











Link to comment
Share on other sites


the MIOS terminal and SD Card Filebrowser are not supported by the bootloader (which is a minimal program which only allows to update the application).

Did I capture this correctly: the USB connection is working with the bootloader, but it isn't working with the MIDIbox SEQ application?

Could you please try some other MIOS32 applications like MIDIO128 or MIDIbox NG to check if USB is working with these applications?
Please upload the applications via MIDI in bootloader mode.

Best Regards, Thorsten.

Link to comment
Share on other sites

Hi TK,

The USB Connection only works with the bootloader when the "user" button is held & "reset" button is clicked once. Soon as the "user" button is let go of, the USB Connection is terminated.

No USB connection is established with Midibox SEQ application, except for USB power.

I will try some other MIO32 applications now & will report back..


All the best


Link to comment
Share on other sites

Hi Mike,

ok, at least this means that it won't be required to remove the USB cable - these are the good news! :)

For the case that USB MIDI also doesn't work with the other applications: do you have a second computer for testing?

Best Regards, Thorsten.


Link to comment
Share on other sites

Hi TK,

That sounds good to me about the USB cable, It looks as though it is proper glued on!

I have a second computer I can use if need be, no problem.

I have just uploaded midio128 HEX via midi, Successfully.USB Connects after power cycle with MIOS software & stand alone                       568ad89a8e076_Midio128successful.thumb.j                                                                                                                                     568ad83d73d5e_MIOSmidiports.thumb.jpg.01

USB to PC appears as USB Composite Device driver & MIOS32 installed successfully!!

Here is MIOS terminal information from midio128 if it helps TK? midio128.txt

I will try midibox NG & get back to you ASAP

Thanks again TK

All the best


Link to comment
Share on other sites

This is really strange!

Could you please try this MIDIO128 version?
V1.019 has been built 2 years ago, this one is based on the latest MIOS32 version which is also used for MBNG and MBSEQ:

-> http://www.ucapps.de/mios32/midio128_v3_020_pre2.zip

If this the new MIDIO128 built isn't working, I've to check for the changes in MIOS32 that I did in the last 2 years

Best Regards, Thorsten.

Link to comment
Share on other sites

Very interesting!

I've a faint suspicion: nobody noticed such an USB issue with Win7 in the last 2 years so far, therefore a general MIOS32 driver problem can be excluded.

On the other hand I added USB host mode some months ago which makes a difference how the USB device is handled: if MIOS32 "assumes" that the an host cable is connected, it will turn the USB interface into a different mode which won't allow an USB host connection.

Your USB adapter might make the difference - it seems that it indicates a USB host device (which violates the USB spec...)

However, there is hope that the next test still doesn't require to remove the USB cable:
Please upload the USB bootloader update application, and then connect via your UM-880 to MIDI IN1/OUT1 
This will allow you to enter MIOS terminal commands.


set enforce_usb_device 1

Thereafter upload the MIDIbox SEQ V4 application - USB device mode should be enabled.

Hopefully this gives us new hints! :)

Best Regards, Thorsten.

Link to comment
Share on other sites

Good news!

That seems to have possibly fixed the issue, fingers crossed.

I followed exactly as you directed.

MIOS Software shots below.


Here is the Terminal informations if needed. MBSEQV4.090 terminal info.txt

MBSEQ memory Terminal info.txt

I'm guessing it wasn't a bug & it was just me getting use to using MIOS?

I really do appreciate your time & effort to help resolve this issue

Do you think the issue is now fixed Thorsten?

I hope the info can be of some help!

Please let me know if you need any more info to continue & proceed.

Thank you again

I owe you one! :cheers:


All the best


MBSEQ memory Terminal info.txt

MBSEQ memory Terminal info.txt

Link to comment
Share on other sites

Cool! :happy:

Actually you are the first person who requires this switch. I added it at the beginning for the unexpected case that a cable doesn't comply to the USB OTG standard, seems that we found one :)

Thanks for the very detailed reports, it was a pleasure to solve this puzzle ;-)

Best Regards, Thorsten.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...