Jump to content

MB Sid does not send sysex


Recommended Posts

i have a strange problem with my sidbox; it seems it does not send any sysex messages.

my setup:

-macbook with 10.9.5

-neusonik im/one midi-interface (successor of the uMIDI/O22 on the whitelist, claimed to be technically identic)

-sidbox (one core, two sids, latest firmware (v2_044))

Uploading the firmware works fine and i can also send patches from computer to sidbox (e.g. taken from the vintage bank). But if i click "receive patch" or "receive bank", the sidbox only sends short stuff like "F0 00 00 7E 4B 00 F7" or "F0 00 00 F7". Same thing when trying to dump with "shift+button5" from the sidbox CS. The different patch editors (tried jsynthlib, ctrlr and the MBSIDV2-Editor) also need bidirectional sysex, so don't work either.

i tried with another synth (ML-303; i think TK took a hand in this one, too :-D) to check if it is caused by the midi interface (or something else inside OSX or the software), but with this one, i can store/dump patches in both directions. 

i'm a bit perplexed; getting "Application is up & running!" and clock ticks indicates that the sidbox's midi-out port is working and there is no wiring error (there is only one TX-pin on the PIC..); the test with the 303 indicates that my midi-IF/computer/software setup should properly transmit sysex data in both directions. So why can't i get data from the sidbox? is there any option i could have missed? any ideas?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...