Rowan

Using a 16x4 BLM, TPD and Aout_NG together

5 posts in this topic

So I'm trying to use a 16X4 BLM and TPD with an AOUT_NG and having trouble getting the buttons and encoder working on the BLM and TPD

I think I have my HW config file set-up correctly. 

The way it's set up is a bit complicated so I'll explain that first. The modules are connected as follows. (I've omitted the AOUT_NG as it's working)

Core>Wilba's FP>Line Driver Transmitter>Line Driver Reciver>DOUTX4>Line Driver Transmitter>Line Driver Reciver>16x4 BLM>TPD

All of the LEDs and 7 segment displays work as they should, it's just the DIN side of things that isn't working. 

Having read the documentation for the Line Transmitter it would seem that I need to connect pin 10 of the last 74HC165 on the front panel PCB to J2:SI on the first Line Transmitter PCB. Is this correct and if so does anyone know which IC on Wilba's PCB is the last 74HC165 in the chain?

Share this post


Link to post
Share on other sites

As far as I can see, the split wiring is only necessary if you use separate DIN/DOUT modules. As you send/receive the full SRIO it should work with the J2_SI jumper installed and simple IDC10s.

Share this post


Link to post
Share on other sites

That is exactly what I thought but no dice! 

What I really need to do is bite the bullet and build the 16x16 BLM I got from you a few years ago. 

Share this post


Link to post
Share on other sites

Hehe, yes you should! I've got a set of blue/green LEDs if you want some.

For the 16x4, can you test the parts rather in stages? I.e. see if you can connect the SEQ to the Rx/Tx and check it works, then add the 16x4 then add the TPD. This should be doable by loading _NG and using set debug on in the MIOS Studio terminal.

Share this post


Link to post
Share on other sites

I've tested all the parts individually and everything works correctly. 

SEQ>Tx>Rx>DOUTX4 Works

SEQ>Tx>Rx>BLM>TPD Works

i'll spend some time in n it over the course of the next week and see if I have any further success. What I do need to do is interrupt the 5v power supply that is sent over the db25 cable and power the BLM & TPD with a local PSU. All these modules are drawing too much current from the SEQ causing the LCD displays to have virtually  no contrast.

PM me adopt the LEDs, I might take you up on them. I've got the buttons and all the parts for the core. The LEDs might be enough to push me over the edge and buy the rest of the components.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now