Sign in to follow this  
Followers 0
matcom3

midibox seq v2 (vintage) don´t react to midi CCs

5 posts in this topic

hi midiboxers

 

I´m trying to send midi CCs to my Midibox seq v2.4 vintage (the ones on the midi CC implementation chart) and nothing happends, for example i what to change the patern clock division via midi CC, etc,etc. Have I to send the CCs on a concrete midi chanel?... sometimes when I send the CCs the unit, it reboots. Any idea of what it´s worng?

thank you

 

 

Share this post


Link to post
Share on other sites

Hi,

CCs have to be explicitly enabled in the setup_*.asm file - by doing so, you also define the MIDI channels:

; Optional channels for configuration via CC (1-16, select 0 to disable)
#define DEFAULT_MIDI_CHANNEL_LAYER_A    0
#define DEFAULT_MIDI_CHANNEL_LAYER_B    0
#define DEFAULT_MIDI_CHANNEL_LAYER_C    0
#define DEFAULT_MIDI_CHANNEL_CFG        0

Best Regards, Thorsten.

 

Share this post


Link to post
Share on other sites

hi again

 

I just do it like this, and stil no response of CCs controls, are the CC chart correct? or its my foult?, I´ve tryed with chanel 16 and the same result...., the unit recive midi because the clock and themidi notes for the arpeggio works perfectly.

 

it´s necesary to use diferent chanel numbers for each layer or CFG?

 


; MIDI IN Channel which is used for the transpose/arpeggiator/remote function
; Allowed values: 1-16, select 0 to disable
#define DEFAULT_SEQUENCER_CHANNEL    1
;
; The Note number which activates the remote function (examples: 0x24 == C-2, 0x60 == C-7)
#define DEFAULT_MIDI_REMOTE_KEY        0x60    ; C-7
;
; Optional channels for configuration via CC (1-16, select 0 to disable)
#define DEFAULT_MIDI_CHANNEL_LAYER_A    1
#define DEFAULT_MIDI_CHANNEL_LAYER_B    1
#define DEFAULT_MIDI_CHANNEL_LAYER_C    1
#define DEFAULT_MIDI_CHANNEL_CFG    1
;
 

thank you

 

Edited by matcom3

Share this post


Link to post
Share on other sites

SOLVED!

 

I have change the chanels with diferent number for each layer and CFG and now WORKS!

 

; MIDI IN Channel which is used for the transpose/arpeggiator/remote function
; Allowed values: 1-16, select 0 to disable
#define DEFAULT_SEQUENCER_CHANNEL    1
;
; The Note number which activates the remote function (examples: 0x24 == C-2, 0x60 == C-7)
#define DEFAULT_MIDI_REMOTE_KEY        0x60    ; C-7
;
; Optional channels for configuration via CC (1-16, select 0 to disable)
#define DEFAULT_MIDI_CHANNEL_LAYER_A    13
#define DEFAULT_MIDI_CHANNEL_LAYER_B    14
#define DEFAULT_MIDI_CHANNEL_LAYER_C    15
#define DEFAULT_MIDI_CHANNEL_CFG    16

 

 

thanks!

Share this post


Link to post
Share on other sites

Cool! :)

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0