Jump to content

sammichSID help : swinsid vs real 6581


Recommended Posts

Hello everyone!

Last year i’ve built a sammichSID, which was functioning and sounding perfectly with a pair of SwinSid Nanos. Recently I got 2 6581 from a real C64, and they work well in the C64 but when i use them in the Sammich, i get no sound at all, and sometimes i can hear a little noise.

I’m using the right jumper configs to provide 12v to the 6581s. All measurements suggested in the build guide were double checked and everything seems normal.

Is there anything im missing? Why the real sid chips wouldnt work if the swinsids are?

Again, both 6581 Sids function perfectly inside my C64 breadbin.

Also: i've tried larger pins as suggested in this post : 

but it really doesnt change, im still having no sound from the sammich...

Let me know if you have an idea on how to troubleshoot it!


Edited by wardg
added important info
Link to comment
Share on other sites

If you're following the official sammichSID build guide (http://www.midibox.org/dokuwiki/lib/exe/fetch.php?media=projects:sammichSID_build_guide_v1_0.zip), you will have undoubtedly noticed the voltage test chart on page 18.

The chart is great, but it's slightly incomplete, in that it leaves out the voltage test for VDD in the upper right corners of the SID sockets, which should read ~12v for 6581s or ~9v for 8580s respectively.

Here's an updated chart that includes the additional test points.




According to the build guide, a 12v reading is ideal, but any reading between 12 - 10.5v should still work with 6581s.

Good luck.


Edited by dwestbury
Link to comment
Share on other sites

33 minutes ago, wardg said:

I'm getting slightly more than 12v, like 12.3. Is that a problem?

That minor of a variation shouldn't be a problem. According to the specs posted here: https://www.waitingforfriday.com/?p=661, the 6581 can handle 17v, although I'd never risk that!

Given that your SwinSIDs are working properly, you shouldn't have to worry about your audio out (SID pin 27) or the amplifier circuitry, but you could still have an issue with either your filters capacitors (C1L, C1R, C2L, C2R) or your audio-in path (J6LR 1/4" jack for Audio in, or either C6L or C6R). 

SwinSIDs don't use external filter caps and they don't support external audio in, so issues in these areas wouldn't affect SwinSID audio output performance, but they could affect a real SID.

Good luck!


Edited by dwestbury
Link to comment
Share on other sites

So i've checked the filter caps and audio-in path as you suggested.

Everything seems normal, i even changed the capacitors for different values to see if theres a change but no. I also tried to lift the audio input pin on the sid, but again it was not the culprit. I've checked the whole pcb for cold joints etc, but i couldnt find any. I am really lost in this one... 

Could it be an amperage issue, that the sid isnt getting enough amps to operate?


And thanks again for your suggestions and quick replies dwestbury!



Link to comment
Share on other sites

50 minutes ago, wardg said:

Could it be an amperage issue, that the sid isnt getting enough amps to operate?

From the same spec doc (link above), you can get a sense of the power supply current draw and total power dissipation to expect.

6581 SID Characteristics

Stresses above those listed under “Absolute Maximum Ratings” may cause permanent damage to the device. These are stress ratings only. Functional operation of this device at these or any other conditions above those indicated in the operational sections of this specification is not implied and exposure to absolute maximum rating conditions for extended periods may affect device reliability.



Unfortunately I'm not quite sure where to direct your attention next (beyond my remote diagnostic capabilities), but I'm sure others will have ideas.

Once again, good luck!





Edited by dwestbury
Link to comment
Share on other sites

I found the issue!

As TK. pointed out in the mentioned post :


  • pin #6: clock connection between SID and PIC. If no scope is available, you could check continuity by unplugging SID and PIC from their sockets.

i had a bad connexion for the clock input. I had to redo the connection with a wire to make it work (between pin 17 of the PIC and the pin 6 of the SID). There was no continuity even after de-soldering...


It works perfectly now!

Its not the best looking solution but it works :)


I would never imagine that the clock was crucial for the SID and not for the swinsid...




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...