Search the Community

Showing results for tags 'midibox kb'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 3 results

  1. Fatar TP/40L Midification

    Hi everybody, my name is Florian (aka Thoskan) and I live near Toulouse in France. First of all, Thanks to all of you for sharing all this documentation about the project MIDIBOX KB. Initially I wanted to buy the controller LMK2+ alone without the keyboard, but Doepfer wanted to sell me 500 euros. So I refuse and opt for the MIDIBOX project, more interesting, configurable and also much cheaper. My project is to midify a keyboard Fatar TP/40L, and I chose to use MIDIBOX KB, with the CORE_STM32F4 and DIO_MATRIX. I bought the 2 PCBs from https://modularaddict.com and I also printed the FantomXR PCB (Fatar keybed adapter http://www.midibox.org/dokuwiki/doku.php?id=fantomxr) at OSHpark. Thank you FantomXR for this missing piece to my project. For the moment, i just want to connect the keyboard (2 micromatch of 20 pins ), a sustain pedal and 2 yamaha FC7 pedals to control volume and fx. I bought all the components from https://www.reichelt.de/ from the orderlist. Moreover, the STM32F407G-DISC1 is available here: https://www.reichelt.de/?ACTION=3;ARTICLE=219363;SEARCH=STM32F407G-DISC1. It is a little more expensive than at Mouser but the shipping costs are lower (20 euros at mouser vs 5 euros at reichelt). I look forward to receive all these components and I hope that i will solder very soon. I will share every step of the construction, that's why I created this topic. I hope I will not have too many questions.  Thank you Thorsten for this great project and for your generosity.  
  2. Hello all, I've build my core stm32F4(fantomxr pcb) + diomatrix + fatar adapter to connect my 88 keyboard. I installed midibox kb and connected everything, but i can't output any midi, so i guess i did something wrong :) I tried the virtual keyboard and i didn't receive any midi input in my daw, so i was wondering if my setup was correct, it seems midibox kb is loaded correctly(cf picture). Here's the setup of my midibox kb: [13020.190] kb 1 debug on [13020.190] kb 1 midi_ports 0x0001 [13020.190] kb 1 midi_chn 1 [13020.190] kb 1 note_offset 21 [13020.190] kb 1 rows 12 [13020.191] kb 1 velocity on [13020.191] kb 1 release_velocity off [13020.191] kb 1 optimized on [13020.191] kb 1 dout_sr1 1 [13020.191] kb 1 dout_sr2 2 [13020.192] kb 1 din_sr1 1 [13020.192] kb 1 din_sr2 2 [13020.192] kb 1 din_key_offset 40 [13020.192] kb 1 din_inverted off [13020.193] kb 1 break_inverted off [13020.193] kb 1 make_debounced off [13020.193] kb 1 break_is_make off [13020.193] kb 1 delay_fastest 50 [13020.194] kb 1 delay_fastest_black_keys 0 [13020.194] kb 1 delay_fastest_release 150 [13020.195] kb 1 delay_fastest_release_black_keys 0 [13020.195] kb 1 delay_slowest 1000 [13020.195] kb 1 delay_slowest_release 1000 [13020.196] kb 1 ain_pitchwheel off [13020.196] kb 1 ctrl_pitchwheel 128 (PitchBend) [13020.196] kb 1 ain_pitchwheel_inverted off [13020.196] kb 1 ain_modwheel off [13020.198] kb 1 ctrl_modwheel 1 (CC) [13020.198] kb 1 ain_modwheel_inverted off [13020.198] kb 1 ain_expression off [13020.198] kb 1 ctrl_expression 11 (CC) [13020.199] kb 1 ain_expression_inverted off [13020.199] kb 1 ain_sustain off [13020.199] kb 1 ctrl_sustain 64 (CC) [13020.205] kb 1 ain_sustain_inverted off [13020.205] kb 1 ain_sustain_switch off [13020.205] kb 1 ain_bandwidth_ms 0 [13020.205] AIN Calibration Mode disabled. Then i wanted to check if my diomatrix was ok so i connected I1 to O1 on J3 to check for midi input, but i did not receive anything(no data in mios input). Is there a way to troubleshoot easily diomatrix ? or some tension to check on the core stm32F4 , i've checked my soldering and connection with a multimeter and everything seems ok. Thanks!            
  3. Hi all, after long absence I have decided to build a midibox kb. So I have soldered  LPC17, loaded up midibox kb and thought, DIO_matrix "1 to 1" connected to keybed (as shown here: http://www.ucapps.de/midibox_kb/midibox_kb_fatar_df_61_interconnections.pdf) and core would produce a working system. But it seems I have failed, I don't get midi note_on-messages from the core. Do I have to adapt the setup somehow or is the 1 to 1 connection the false option? Best clem!