Sign in to follow this  
Followers 0
Digispunk

Programming with Serge's Midibox64 editor

12 posts in this topic

Hi everyone

i'm trying to upload/send a new Midibox64 bank/preset using Serge's Midibox64 editor,

i've made the patch with all the desired button/pot commands, and saved the sysex file for future reference,

now the problem is - how to upload to my midibox?

i've tried using the 'send sysex' button and the dialogue box says its sending, but my midibox does not acknowledge the incoming data.

does the midibox need to be in a special mode to recieve the dump? if so my problem is that none of the buttons are currently progrmmed to navigate the menu structure.

for troubleshooting info -

im using MIOS 1.9

i have the midi in/out device set properly - tested and checked using Midi OX and also by way of learn commands so i dont think thats the issue

i dont have a bankstick attached yet

are there any detailed tutorials for uploading banks? i tried using the search terms 'serge / midibox64 editor / upload bank etc and not found one yet.

Share this post


Link to post
Share on other sites

It's like you are trying to open a .mp3 file on your computer, but no MP3 player is installed...

You've to upload the midibox64 application.

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

sorry if it wasnt clear - but i have uploaded the midibox application  :)

all the pots and buttons work, the lcd shows the values etc and when it boots up - so yes MB64 app is installed, and midi monitor app on the computer shows it is sending the correct midi messages

i just dont know the procedure for uploading a bank/patch to the unit with serge's editor, and i cant manually edit the box through hardware because the buttons arent programmed with the menu functions (they are all midi note messages)

Share this post


Link to post
Share on other sites

made some progress -

decided to start from scratch and reload MIOS - found that the MIDI in port cable was dodgey - so corrected it

successfully uploaded MIOS ver.9f to core

successfully uploaded Midibox64 app - ver 2.4

all pots, buttons, faders etc work, LCD displays all correctly and tested MIDI out with Ableton and it works fine -

now back to Serge's MIDI editor - try to upload new bank via sysex and get this reply

"MIDI time out! Whats up???".

serge editor displays problem/error messages when uploading

searched and found a similar problem here -

http://www.midibox.org/forum/index.php/topic,10877.msg94380.html#msg94380

was hoping to find the answer - but it seems that Foona manged to overcome the problem by switching to a new computer and MIDI interface - which is odd as he could upload MIOS/Midibox64 app etc without problem but got the time out error using serge -

any ideas besides switching to a new computer and Midi interface? i am using M-Audio UNO midi interface

after a short rest, i gave it another go with the same Midi interface etc, strangely the upload from serge to core worked a bit - i say a bit because the dump was registered on the core as successful, and the pots i re-labeled in serge worked, but the buttons didnt, not sure why. anyhow after a few more attempts, it stopped working altogether and went back to the 'midi time out' messages

i have tried adjusting the 'delay between sysex blocks' time but that doesn't help....

i will try again tomorrow.

Share this post


Link to post
Share on other sites

First of all it's important to use the "18f" version which can be found under http://miostools.midibox.org/

If SysEx transfers are unstable with this version, it could be related to a Windows driver issue of your MIDI interface (SysEx blocks > 256 bytes not transfered completely). Miditrix helps to overcome this - some informations can be found here

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

thanks, TK,

im definitely using the 18f version of Serge's editor, but i will try the Miditrix app to see if it improves sysex handling.

Share this post


Link to post
Share on other sites

well, i got some initial success using Miditrix and Mdi yoke,

i say initial, since i could upload Pot values without error, but the new button values dont update... need to investigate

thanks TK.

Share this post


Link to post
Share on other sites

I'm not really the most informed person on here (honest lo) but I did notice your using a M Auio Uno - I have noticed on other forums Behringer Uno etc that people have had lots of problems with this interface. Is there any chance you can borrow a different interface and try that ?

I hope that helps ish

Aus

Share this post


Link to post
Share on other sites

i've been using m-audio uno for midiboxing for a few years (under winxp). 

the only issue i've had is it doesn't support multiple clients at once.

i have not built the midibox64 though.

hope that helps...

Share this post


Link to post
Share on other sites

Hi Bug fight I'm sure the interface is very good - I use a 2x2 midisport but like I said I'm sure I have seen issues on a couple of sites - can't remember which maybe Guitar Rig or Behringer Uno.

It is worth a try then it can be eliminated and maybe check the cables too.

Aus

Share this post


Link to post
Share on other sites

I used a MIDIsport 2x2 many years w/o issues. But the driver is multi client capable.

If M-Audio Uno doesn't support multiple clients, this indicates that a different driver is used which could have bugs.

Best Rgards, Thorsten.

Share this post


Link to post
Share on other sites

IIRC, the uno uses the standard USB drivers built into your OS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0