Steven_C

Error when attempt at compiling the Motormix app

7 posts in this topic

Got the following error after I carefully followed the quickstart (http://www.midibox.org/dokuwiki/windows_toolchain_quickstart)

(I simply put the folder with the motormix files here: C:\midibox_mm_v2_0e (so first line in the cmd window was: cd c:\midibox_mm_v2_0e))

C:\midibox_mm_v2_0e>SET PATH=C:\MSYS\1.0\bin;%programfiles%\SDCC\bin;%PATH%


C:\midibox_mm_v2_0e>make

rm -rf _output/*

rm -rf _output

rm -rf *.cod *.map *.lst

rm -rf *.hex

mkdir -p _output

sh ./bin/mios-gpasm -c -p p18f452 -I./src -I ./include/asm -I ./include/share -I

 ./modules/app_lcd/dummy -DDEBUG_MODE=0  -DSTACK_HEAD=0x37f -DSTACK_IRQ_HEAD=0x3

3f -DDONT_INCLUDE_MIOS_ENC_TABLE -DDONT_INCLUDE_MIOS_MT_TABLE -I ./modules/mios_

wrapper modules/mios_wrapper/mios_wrapper.asm  -o _output/mios_wrapper.o

./bin/mios-gpasm: line 66: gpasm: command not found

make: *** [_output/mios_wrapper.o] Error 127
Then I realised I had to change the name of folder "programfiles" to "Program Files" in my entries in the CMD window. However, now I get this error:
C:\midibox_mm_v2_0e>make

rm -rf _output/*

rm -rf _output

rm -rf *.cod *.map *.lst

rm -rf *.hex

mkdir -p _output

sh ./bin/mios-gpasm -c -p p18f452 -I./src -I ./include/asm -I ./include/share -I

 ./modules/app_lcd/dummy -DDEBUG_MODE=0  -DSTACK_HEAD=0x37f -DSTACK_IRQ_HEAD=0x3

3f -DDONT_INCLUDE_MIOS_ENC_TABLE -DDONT_INCLUDE_MIOS_MT_TABLE -I ./modules/mios_

wrapper modules/mios_wrapper/mios_wrapper.asm  -o _output/mios_wrapper.o

sh ./bin/mios-gpasm -c -p p18f452 -I./src -I ./include/asm -I ./include/share -I

 ./modules/app_lcd/dummy -DDEBUG_MODE=0   modules/app_lcd/dummy/app_lcd.asm -o _

output/app_lcd.o

sh ./bin/mios-sdcc -c -mpic16 -p18f452 --fommit-frame-pointer --optimize-goto --

optimize-cmp --disable-warning 85 --obanksel=2  -I./src -I ./include/c -I ./incl

ude/share -DDEBUG_MODE=0  src/main.c -o _output/main.o

'sh' is not recognized as an internal or external command,

operable program or batch file.

make: *** [_output/main.o] Error 1


C:\midibox_mm_v2_0e>

This is my first attempt at compiling the app. I did not make any changes to the code, (apart from turning off the motorfaders off) just tried to compile to see if it would work.

I have checked that SDCC is installed here: C:\Program Files\SDCC

and MSYS is installed here: C:\msys\1.0

and GPutils is installed here: C:\Program Files\gputils

I noticed that my msys folder was in fact called msys (not MSYS) so I tried changing that in the CMD window, but still no-go.

Any suggestions?

Cheers,

Steve.

Edited by Steven_C

Share this post


Link to post
Share on other sites

Hi Steve,

'sh' is not recognized as an internal or external command,
operable program or batch file.[/code] Thats strange! It seems that the shell command cannot be found anymore (it's part of MSYS), although some previous "sh" commands worked w/o error. What happens if you type:
[code]
sh -c "echo test"
And what happens with:
sh ./bin/mios-sdcc -c -mpic16 -p18f452 --fommit-frame-pointer --optimize-goto --optimize-cmp --disable-warning 85 --obanksel=2 -I./src -I ./include/c -I ./include/share -DDEBUG_MODE=0 src/main.c -o _output/main.o

in the command window?

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

Cheers Thorsten,

The result:

C:\midibox_mm_v2_0e>sh -c "echo test"

test


C:\midibox_mm_v2_0e>sh .'bin/mios-sdcc -c -mpic16 -p18f452 --fommit-frame-pointe

r --optimize-goto --optimize-cmp --disable-warning 85 --obanksel=2 -I./src -I ./

include/c -I .include/share -DDEBUG_MODE=0 src/main.c -o _output/main.o

sh: .bin/mios-sdcc -c -mpic16 -p18f452 --fommit-frame-pointer --optimize-goto --

optimize-cmp --disable-warning 85 --obanksel=2 -I./src -I ./include/c -I .includ

e/share -DDEBUG_MODE=0 src/main.c -o _output/main.o: No such file or directory

Share this post


Link to post
Share on other sites

Great that you solved this :)

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites

i had the same problem on my Apple with Parallels XP. Writing it in to the System Path manually helped.

Thanks

novski

Share this post


Link to post
Share on other sites

So I tried it on another PC, still no go.

So I tried following the directions to make the path changes permanent at: http://www.midibox.org/dokuwiki/windows_toolchain_core#path_environment_variables

...and it worked! I now have a compiled .hex file :-D Time to load into the midibox to try it!

Thanks for your help TK.

Hello i want to add something:

For those user who run under windows 64bit the default installation directorie for the SDCC and the gputils is: C:\Program Files (x86)\

So you must add this line: C:\msys\1.0\bin;C:\Program Files (x86)\gputils\bin;C:\Program Files (x86)\SDCC\bin; to the path as described at the tutorial.

My path for example is like this:

C:\msys\1.0\bin;C:\Program Files (x86)\gputils\bin;C:\Program Files (x86)\SDCC\bin;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x86;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x64;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Common Files\DivX Shared\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\;C:\Program Files\MySQL\MySQL Server 5.1\bin;C:\Program Files (x86)\MATLAB\R2009b\runtime\win32;C:\Program Files (x86)\MATLAB\R2009b\bin;C:\Program Files (x86)\Java\jdk1.6.0_20\bin;C:\Program Files (x86)\Windows Live\Shared;C:\Users\vinylrider\Downloads\android-sdk-windows\tools\;C:\Program Files (x86)\Common Files\Roxio Shared\DLLShared\;C:\MinGW\bin\;

i hope i will help the others who read this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now