anderspe

Midibox64e with MB-LRE8x2CS problem

6 posts in this topic

I have made a midibox64e like this:

 

post-9684-0-45708800-1359019896_thumb.jp

 

Everything works perfectly, except for the LED rings.

 

The LED rings are turned all the way up regardless of what the encoder position is. When i go into "LED Patterns" and change to another pattern, all the rings starts to move except for the selected ring. Selecting a new pattern does not change anything - the encoder stays on pattern #1 and is turned all the way up.

 

Here is my .asm file:

 

setup_midibox64e.asm

 

What am I doing wrong here? Can somebody give me a pointer?

 

Kind Regards

 

Anders

Share this post


Link to post
Share on other sites

just wondering, did you ground the pins on J5 if you have no analogue inputs or did you change the asm file?

this is from on of my earlier posts:

When i need to test just one or two pots i just connect directly to J5, and i then go into the asm file and change these lines and then recompile, it saves me having to ground things.

So obviously i connect the pots as follows, Pot1: Vs/Vd/A0 Pot2: Vs/Vd/A1 Pot3: Vs/Vd/A2 (connecting to correct pins on pot!!)

So i open for example setup_midibox64e.asm in my text editor

#define DEFAULT_NUMBER_AIN 64 (the amount of pots/faders connected, more than 8 needs an ain board and MUX to be enabled)

#define DEFAULT_ENABLE_AIN_MUX 1 (needed for when you use the ain boards and more than 8 pots)

I then change them to this as i only need say for example 3 pots and no mux as im connected directly and not through an AIN board

#define DEFAULT_NUMBER_AIN 3

#define DEFAULT_ENABLE_AIN_MUX 0

by doing this, the software only looks for the first 3 inputs on J5, the other 5 are not looked at and therefore i do not need to ground them.

So if you do not have any pots or faders then change it to this

#define DEFAULT_NUMBER_AIN 0

#define DEFAULT_ENABLE_AIN_MUX 0

if the J5 pins are not grounded then they cause spurious midi data that is constantly running. As explained changing the code saves soldering!

see if that helps first

Its surprising how easy it is to forget to ground the pins on j5 or edit the asm.

Edited by ssp

Share this post


Link to post
Share on other sites

I have grounded the pins on j5. But I tried your suggestion anyway - but it did not help.....

 

I made a quick little video describing the problem:

 

http://youtu.be/EmKPuMzeqYk

 

If someone could please help me with this I'd be really happy!

 

just wondering, did you ground the pins on J5 if you have no analogue inputs or did you change the asm file?

this is from on of my earlier posts:

When i need to test just one or two pots i just connect directly to J5, and i then go into the asm file and change these lines and then recompile, it saves me having to ground things.

So obviously i connect the pots as follows, Pot1: Vs/Vd/A0 Pot2: Vs/Vd/A1 Pot3: Vs/Vd/A2 (connecting to correct pins on pot!!)

So i open for example setup_midibox64e.asm in my text editor


#define DEFAULT_NUMBER_AIN 64 (the amount of pots/faders connected, more than 8 needs an ain board and MUX to be enabled)

#define DEFAULT_ENABLE_AIN_MUX 1 (needed for when you use the ain boards and more than 8 pots)

I then change them to this as i only need say for example 3 pots and no mux as im connected directly and not through an AIN board

#define DEFAULT_NUMBER_AIN 3
#define DEFAULT_ENABLE_AIN_MUX 0

by doing this, the software only looks for the first 3 inputs on J5, the other 5 are not looked at and therefore i do not need to ground them.

So if you do not have any pots or faders then change it to this
#define DEFAULT_NUMBER_AIN 0
#define DEFAULT_ENABLE_AIN_MUX 0

if the J5 pins are not grounded then they cause spurious midi data that is constantly running. As explained changing the code saves soldering!

see if that helps first

Its surprising how easy it is to forget to ground the pins on j5 or edit the asm.

Share this post


Link to post
Share on other sites

The MB64E application isn't prepared for inverted selection signals.

You either have to replace the sink drivers (uln2803) by bridges, or you've to wait for the next version where this option will be available as a compile switch (i haven't integrated it yet...)

Best Regards, Thorsten.

Share this post


Link to post
Share on other sites
The MB64E application isn't prepared for inverted selection signals.

You either have to replace the sink drivers (uln2803) by bridges, or you've to wait for the next version where this option will be available as a compile switch (i haven't integrated it yet...)

Best Regards, Thorsten.

Great!! That worked! Thanks alot!

 

One last thing, how do i get it to use all 16 led's in the encoder rings? Right now it's only using the first 11 led's

Share this post


Link to post
Share on other sites
Great!! That worked! Thanks alot!

 

One last thing, how do i get it to use all 16 led's in the encoder rings? Right now it's only using the first 11 led's

Sorry!! Found it! in the mb65e_preset.inc of course!

 

Again thanks a lot!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now