Jump to content

MIDI IO Module - No response


Recommended Posts



I just tested the whole day the MIDI IO Module with my STM32F4-Core-Module.


First thing i tried was to display incoming midi messages with the 003_debug_messages tutorial. I connected the midi-out of my synthesizer to the midi-in of the midi-module and then the j1-interface of the midi-module to the j11e -interface of the core module. Playing some notes on the synthesizer didnt result in anything.

Then i connected the midi-out of the synthesizer via an midi-usb-cable directly to my mac and started the mac-midi-monitor -> saw the incoming messages.


Then i tried to send some messages via the core module + midi io module. For this, i connected again the core-module to the midi module (j11e to j1) and then from the midi-out either 1) to the mac-book via a midi-usb-cable or 2) to the synthesizers midi-in.

After that i updated the 003_debug_messages-tutorial with some code


void APP_Tick(void)
    MIOS32_MIDI_SendNoteOn(IIC0, Chn1, 1, 128);



I tried all of the IIC ports, but none of them worked, which means, that i didn't get any messages from the midi-module.

I also tried the iic_midi-troubleshooting code which showd me the following:


IIC1/2/3/4/5/6/7/8 NOT available.


i doublechecked all the pins i soldered and they are correct. I also get 4,6 V on the midi-module which should be allright ?!



Anyone got some suggetions how to test the midi-module or how to get it to work ?




Best regards,


Link to comment
Share on other sites

Do you mean the MBHP_MIDI_IO module: http://www.ucapps.de/mbhp_midi_io.html

or the MBHP_IIC_MIDI module: http://www.ucapps.de/mbhp_iic_midi.html


The IIC MIDI module requires further initialisation in the mios32_config.h file


A troubleshooting app can be found under apps/troubleshooting/iic_midi


Best Regards, Thorsten.

Link to comment
Share on other sites

Yes, I can communicate with the core via usb. the usb gives the power to the core.

The polarized components should be soldered the right way, besides that, the midi out should work even if i would have some soldering-mistakes in those components ?

I didn't add the midi activity circuits/leds

Link to comment
Share on other sites

the usb gives the power to the core.


But does it do anything else? Did you upload the correct application? Can you then forward MIDI events to the outputs via MIOS studio?



the midi out should work even if i would have some soldering-mistakes in those components ?


Who knows? You're right though, it's just 2 resistors for MIDI out. Did you try another ribbon cable?

Link to comment
Share on other sites

Yes it does do something else

For example the first tutorial works fine on the core. Playing some Notes on the MIOS32 results in a blinking LED on my stm32f4.

So it should also blink, if i play some notes on my synthesizer or my ipad, which is connected via an USB-MIDI cable  to the MIDI-IN of the MIDI IO Module, right ?

Link to comment
Share on other sites


now they are working... At least one IN and one OUT Port. The other two aren't working...

I can send Notes i played in the MIOS Studio via Midi to my Synthesizer, the debug_message for this port says: 10 in hex, which should be the USB0 port

And when I play notes on the Synth the LED blinks and the debug-messgae says port: 21 . Which should be the UART1 port

This only works for one in and one out port.

Edited by Saschaaa
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...