ChinMuzik

Power issue with MB6582

6 posts in this topic

I am currently trying to upload the MIOS app to preflashed PIC and for some reason the core is not communicating. I did the MIDI loopback and communication workup and everything is ok. 

 

So I checked the PIC socket for 5v and they are receiving 5v fine on necessary pons and GRD os ok too.

But I noticed when checking voltages that the 9v and 12v pins do not receive proper voltage. 5v is consistent but 12v will show .45 and 9v about 4.5v most of the time....very rarely will I see full 9v and 12v on the pins (or SID socket)

What could this be? Is this possible a bad PS?

Share this post


Link to post
Share on other sites

Could you plot your 9/12V inputs by scope and send a picture? It will show the input signal,if not well regulated or whatelse.
Reminder,there is a jumper to set for each SID to set 9 or 12V input,if not set.

I sometime noticed on some (bad) PSU that when current is almost 'inexistant' Voltage does not raise to its correct level.
Maybe trying again with some Resistor/LED plugged serial from voltage pin to ground and check voltage again?

Edited by Psykhaze

Share this post


Link to post
Share on other sites

The scope is showing a straight line on all rails. Even the 5v rail I cannot see a waveform, however, I test the 5v rail and all the sockets with a multimeter and it is supplying the 5v.

I'm testing from the test point pin headers. 

I tested the 9v and 5v pins on the power supply and took screenshots of those.

 

 

20160910_030817_017_01.jpg

20160910_030605_010_01.jpg

Share this post


Link to post
Share on other sites

What kind of PSU are you using? what are the specs (voltage/amps)?

Share this post


Link to post
Share on other sites

It's a 5vdc/9vac psu

It's hacked together from two different wallwarts to a single 7-pin DIN as my original c64 psu died.

 

Share this post


Link to post
Share on other sites

Hi,

May be the 9vac wallwart is too weak. The Sids are eating a lot . Which Sids and how many are installed ?

Regards,

Janis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now