simon-2

sidbox does not send sysex (on patch dump)

8 posts in this topic

hi all, 

i posted this question in the troubleshooting section first, but jaytee recommended to post it here to call more attention-  

i have a strange problem with my sidbox; it seems it does not send any sysex messages.

my setup:

-macbook with 10.9.5

-neusonik im/one midi-interface (successor of the uMIDI/O22 on the whitelist, claimed to be technically identic)

-sidbox (one core, two sids, latest firmware (v2_044))

Uploading the firmware works fine and i can also send patches from computer to sidbox (e.g. taken from the vintage bank). But if i click "receive patch" or "receive bank", the sidbox only sends short stuff like "F0 00 00 7E 4B 00 F7" or "F0 00 00 F7". Same thing when trying to dump with "shift+button5" from the sidbox CS. The different patch editors (tried jsynthlib, ctrlr and the MBSIDV2-Editor) also need bidirectional sysex, so don't work either.

i tried with another synth (ML-303; i think TK took a hand in this one, too :-D) to check if it is caused by the midi interface (or something else inside OSX or the software), but with this one, i can store/dump patches in both directions. 

i'm a bit perplexed; getting "Application is up & running!" and clock ticks indicates that the sidbox's midi-out port is working and there is no wiring error (there is only one TX-pin on the PIC..); the test with the 303 indicates that my midi-IF/computer/software setup should properly transmit sysex data in both directions. So why can't i get data from the sidbox? is there any option i could have missed? any ideas?

regards 

simon

Edited by simon-2
title did not fit

Share this post


Link to post
Share on other sites

i still could not fix this.

i walked through most steps of the midi troubleshooting page (although this does not really fit as i don't have any issues with code upload; i recently uploaded a customized version with improved button debouncing and 4-line LCD support, so i skipped some of the tests).

this is my screen when starting mios studio (indicating "everthing is fine"):started.thumb.png.0c868a0900a4d4f0575595

but when i try to receive Patch A065 (or any other patch) from the sysex librarian, i get this error:dumprequestfail.thumb.png.d314b3d8900e80

trying to dump the same patch from the control surface also sends 

f0 00 00 7e 4b 00 f7 
f7 

what i tried:

-read sid manual and issues/troubleshooting (multiple times :-D)

from the midi troubleshooting guide:

-TEST PC1: Loopback working in all cases,

-TEST MIDI1: ok; skipped TEST MIDI2 and directly continued with the core checks

-TEST OUT1: ok; skipped OUT2, but tried OUT3 (disconnect middle pin) without any difference

-skipped the input tests, as i can successfully send patches from macbook to sidbox

-CORE TEST1-8: everything checked at least twice...

-CORE TEST 10: i think, this looks similar, but a little different..? and i can't find a shortcut on my board

-CORE TEST 11: as this sounded suspicious to me, i replaced the bypass cap; still without a difference.

What else could i check? What could prevent it from dumping patches? Could the PIC itself have an error, that only affects midi-out? (everything else works perfectly fine!) There's still some space left on my bankstick and i could do more of them, but it would be more comfortable to backup, sort and rearrange them to "useful" soundsets on my notebook... and i could share some patches here ;-)    

regards, simon

 

Share this post


Link to post
Share on other sites

Do you have a core32? I have had good luck using one with the midi2x2 firmware when I am having issues with my other midi adapters.

Share this post


Link to post
Share on other sites

no; the sidbox is my first midibox, so i only have the core8 that's in the box. But i don't think it's caused by the adapter, as i can receive patches from another synth with it, and the loopback test works (also with long strings in the mios terminal).

 

 

 

Share this post


Link to post
Share on other sites

sorry to necro bump this old thread, but i am having the exact issue,

maybe maybe someone found out a solution for this, as I really would like ot use this librarian feature of the MIOS.

Thanks a lot.

 

Share this post


Link to post
Share on other sites

unfortunately, i did not find the solution; i rather gave up after all . Made more bank sticks instead :decayed:

but nice to hear i'm not the only one having this error. So if you find a solution, please let me know what has been wrong...

Share this post


Link to post
Share on other sites

oha still alive, did not believe this :)

 

My next step is to buy a new usb to midi converter for the PC and then try again, i am using a ultracheap china clone sub 10€ bought 10 years ago or so, but i could flash my midibox without any problems with this thing and MIOS studio also seems to work as it detects a running application and stuff.

I did use win7 and win10 to try it both with the same errors as you got.

Share this post


Link to post
Share on other sites

just a quick update, as i purchased the plyotec gm5, around 30€, it is working now, so maybe it really was the cheapo usb buy from amazon, amybe something else, but patch upload does work now :)

 

so maybe this helps everyone :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now