Sign in to follow this  
Followers 0
mex

MBHP_CORE_STM32F4 built not quite yet working with LCDs

8 posts in this topic

#Update 1:

working now, did forgot to solder the R33 resistor network on the bottom PCB under the STM32F4 eval board... silly me

This tends to happen quite a lot to me when i have half finished projects lying around everywhere.

So LCDs do work sweetly, but do not know exactly if the wilbas frontpanel is correctly working, seems quite random some of the led pattern, but i will have to look into that when i finish ubilding.

 

 

Hello,

as i did finish my MidiBoxSid  a while ago, I did follow the advice of some other member here and looked into the MidiSeq v4. So i simply ordered all the stuff, or had it at home anyway. Now i am running in some issues, which are probably easily solved by some of you guys who already have one:

 

So My MIOS32 bootloader did flash on my STM board easily without trouble, I can also detect and upload the MidiSeq newest firmware, and it is read by the MIOS studio software, it says 1 minor issue was detected while flashing, but also states that it could be solved whatever that means, so I think everything might be ok with the Code.

I can also open the MIOS file viewer and see that something is stored on the sd-cardm so I assume everything is working properly, right?

 

Now I did attach the Wilbas Frontpcb and the 2 LCDs, some from newhaven ordered via mouser, they run on 5V and the rest should also be connected fine :) at leats i do hope so right now, I did go thru the cabling quite a lot since it is kind of tricky since it is mirrored and stuff.

 

When I connect the USB cables for power then the backlight is lit on both, but i only get dark rectangles on the upper collumn, I thought maybe the midibox logo or version number should appear and so on, so something is not working right yet.

 

So here the big question?

Do i have to configurate something else? The LCDs should work without any Front-PCB attached, right? since they are not connected whatsoever.

Why do my LCDs not show the right things, maybe wrong LCDs, but I assume mouser is only providing the "right" ones.

maybe some file missing on the sd-card, but it should simply work without the sd-card, right? I mean for testing something should be printed on the LCDs?

 

MIOS Studio is stating that the right seque code is detected, so there should not be a problem with that, maybe i simply flash the bootloader again later and go on form there, check all the ICs.

 

And last question, the J8/9 cable, goes 1:1 to the mirrored plug form the frontpanel, or does it have to be mirrored just liek the LCD type???

This is specially confusing to me since it is not clear if SI is supposed to go on SI, or like ususally in communications, SI is going to SO!

Kind of tricky to document too,but luckily nothing be damages if this connection is wrong it simply wont work.

 

 

Thanks for reading and probably helping.

cheers.

 

Edited by mex
update1

Share this post


Link to post
Share on other sites

Yes the lcd will work with nothing else attached. You should get text on boot.

Check the contrast setting if it is up all the way on a regular LCD you will have black blocks and not be able to see the text.

The cable that goes to the front panel should be 1 to 1. if you make the cable and align the connectors the exact same way on the ribbon cable it will work as long as the header was soldered on the board the right way.

 

Make sure you have the cable built right. there is a good picture of the dual cable here:

http://midibox.org/forums/topic/18868-building-a-midibox-seq-v4-wilba-control-surface-photo-tutorial/

and here on the core page is a good picture of the single cable if you scroll to the lcd section at the bottom :

http://ucapps.de/mbhp_core_stm32f4.html

You may want to build a single cable and make sure both lcd are 100% I find it easier to work with less when trouble shooting then build up to work out the rest of the problem.

 

You do not mention what LCD you bought from mouser. They sell several. Maybe you have one that is not set up for parallel input? Often if you are getting black characters it is a cable issue though.

 

I would also check the 5v jumper J15 and the ganged resistors R33 on the core they are often a source of problems for people. Also check everything around IC2 and make sure the 595 is in the socket right.

 

Edited by gerald.wert
more details

Share this post


Link to post
Share on other sites

As always, it is good to test one thing at a time, so just hook up one LCD and see what you get. If you have the MBSeq loaded, you will get text on one LCD and an animated logo on the other when it boots.

Once you get one LCD working on both ports, then add the second one. This will make it easier to isolate problems.

Also - check the contrast and backlight trimpots, see if they are functioning properly.

Edited by goyousalukis

Share this post


Link to post
Share on other sites

got it working, but thanks for reading, i was a little fast, but you know how it is,

just writing about my problems usually gives me another point of thinking about it, so the LCDs are working, now i am a bit struggling with the

menu pages and wheather my fronpanel is working , i guess it should not work at all if the SI SO would been in wrong alignment,?

 

ok i think something is not yet working, maybe its a simple thing like , wrong file on the sd card.

Then i think my rotary encoders have wrong detents, and i have not quite figured out which LCD is the left and which the right?

I assume the logo appears on the right one on startup. My buttons dont seem to work , but it could also be that i simply dont understand the usage yet,

I did try to do the thing from the beginners guide:

press menu and events... but somethign else is happening,

And yes i think something is fishy, when i press the Divider button ( 5  or E ) the right diplay says:

 

step view

113-128

 

so i think something is wrong, i will check on how to get the file to the sd card again and hope i will have it all working in an hour :)

 

 

Share this post


Link to post
Share on other sites

You have to set the hardware file up for the front panel you are using. Just use mios studio to edit the MBSEQ_HW.v4 file  it or load the one for wilbas front panel if that is what you built from the SVN on your sd card. There are a lot of options so it depends on what you have built but you need to setup what you have for it to work right.

 

http://svnmios.midibox.org/listing.php?repname=svn.mios32&path=%2Ftrunk%2Fapps%2Fsequencers%2Fmidibox_seq_v4%2Fhwcfg%2F

Share this post


Link to post
Share on other sites

Update #1:

got the testprograms running the: wilba-seq-cs-hw-test-blinking.hex

 

so i know my encoders do all work, but the buttons do also work, but i dont know the exact numeration and if its important?

 

for example in the pdf the bottom right button is named: S51 and the LED is L51

But the program tells me it is Button Nr.6 and Led Nr 51 is the green one above the song button, in  the pdf named: L20

 

i dont know if that should be aligned, anyway i keep testing.

 

i dont know exactly how to flash back another testfile into the STM32 :) mios is not detected , hm maybe i need to flash it again, but i cant imagine that, i will keep on trying.

Share this post


Link to post
Share on other sites

ok everything is working fine, just finished screwing the stuff together, now MIDI Ports are missing, and then I am ready to go, think they are still on the way from modularaddict,

but igot some IIC MIDI outs with the PICs on, maybe ill try those first as long as the midi is on its way.

 

 

Share this post


Link to post
Share on other sites

IIC will work you will just not have midi in unless you use midi on the usb interface. You can always use a midi routing program like midi ox on a pc to route to the midi in for now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0