weasel

[SOLVED] SSD1306 again. Help an idiot find his mistake please.

4 posts in this topic

Posted (edited)

I wired up my 7pin SPI 1306 according to this diagram using 1k res and 10u cap.

DaUNRJE.png

 

 

but i'm failing to get anything out of the screen. trying to just print text through the console lcd command, or the hello world program or even the NG init message.

i did set the correct LCD type in the bootloader:

zVXyj8s.png

there's this other old thread where someone had to connect the OLEDs reset pin to some other core connectors GPIO pin iirc? is that really the way to go, no convenient simple conncetion available?

i tried manually setting the reset pin to 0/3.3 via the testlcdpin command, no success. while manual, that should do the same trick as the GPIO pin reset above, right?

edit: i realized the J15 reset pin is connected to the DC pin of the OLED? so no manual reset this way?

 

i tried doing some measurements. core board soldering seems ok. power/ground voltages are also where i think they're supposed to be everywhere.

is there a page or list with debugging measurement points on the STM32F4 core board? DINOUT and AINSER 64 work for what its worth.

 

more pictures of my "circuit"

RtkM8xF.png

IwTxCYC.png

i realized in the above picture the SDA cable was in p4 instead of p6, that was not the issue though.

OLED supposed to work on 2.8-5.5v, i tried both 3.3 and 5v jumper settings.

5YVGQAu.png

yeah i know my soldering is "sub par"

BFEiDao.png

GND and VCC from both j15 and the OLED going to the power strip on the breadboard, and the blue wire to the reset pin.

 

Edited by weasel

Share this post


Link to post
Share on other sites

well after a million tests and power cycles yesterday i just turned on my main system power supply this morning and got this

RYbOzKd.png

 

so consider this case closed.

Share this post


Link to post
Share on other sites

Sometimes I feel like there can be oxidation or other crap on the pins that prevents good contact and messes up the data transfer.

Share this post


Link to post
Share on other sites

yeah since i'm coming form woodworking - maybe the OLED had to adjust to room temperature first :decayed:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now