Jump to content

sammichSID hex upload problem


Recommended Posts

Hello all,


I have recently completed a Sammich that has been sitting on a friends shelf for the last 4 years!


I will explain what has happened so far to try and give a clear picture.


The build went really well apart from a lifted pad which was repaired (this only affected the low power LCD backlight) and is now working.


Everything electrical checks out, all test points are clear and there are no shorts, the correct jumpers are set for the 8508 SID's, the voltage jumpers are correct also.


Basically the Sammich turns on and the LCD shows some black squares, then tells me: MIOS v1.9g ©2009 T Klose, and then goes on to say READY.


I have an M-Audio 2x2 midisport usb interface, I have downloaded the latest MIOS Studio software (PC and Mac), and the latest setup_sammich_sid.hex, and the mios_v1_9g_pic18f4685.hex


My problem is that no matter what i do, it doesn't seem to want to let me upload the hex file to the PIC/Sammich.


when I first power on the sammich, if i press query in the mios studio immediately, i get the screen telling me its connected to the core and ready, and then i browse for the setup_sammich_sid.hex and hit start, and then it tells me it can't contact the core and to reboot the sammich, which i do, it tries to do it then it says it can't it and gives me an error saying: 


Upload aborted due to error #12: MIDI IN Frame ErrorNo response from core after 16 retries!


It only ever seems to give me the connected to core message immediately after I power it on, and press query, and then only very briefly, from what i understand, it is supposed to keep polling every few seconds for an upload if it doesn't have mios/hex burnt in.


I have tried doing this under windows 7 64bit, and OS X 10.10, using the same M-Audio 2x2 ( isee from the white/blacklist that this particular device may not work under OS X, hence why I'm trying under windows 7.


I have looked at the troubleshooting guide, and done the midi loopback tests from the PC and the sammich, and the check out fine.


I think i either have a duff midi interface, or something else is wrong.


I will post some screenshots incase anyone else can help by looking at them, any help is greatly appreciated.




I have now tried to upload the file from another 2 different types of midi interface on the Mac, but still have the same error in mios studio.




I have just purchased a Neusonik uMIDI/O22 to test with, once it arrives i will give it a go and see if it makes any difference.







Edited by Rave
Link to comment
Share on other sites



this behaviour indicates a bad MIDI interface (as you've already noticed).

SysEx strings sent by the PIC are correctly received, but the PIC doesn't receive well shaped MIDI messages.

This could also be related to a problem with the MIDI cable.


Is TEST MIDI2 passing at your side?


However, the Neusonik interface is really worth the money.


Best Regards, Thorsten.

Link to comment
Share on other sites

Hello Thorsten, 


Many thanks for your swift reply. 


I am currently away from home and the sammich, but I do believe I performed the suggested test and it came back OK. 


I am sure it probably is the midisport controller at fault, as one of the others I tried was a variation of the same model. 


Once I receive the new cable I will try again and report back here with the result. (which I hope is positive) :) 


Many thanks, 



Link to comment
Share on other sites

  • 4 weeks later...

Small update: Hello, I have been unable to Source a nuesonic midi cable as suggested, all suppliers are out of stock in all places I have checked. I bought a cheap no brand cable off ebay but unfortunately this didn't seem to work with the firmware flashing either under Windows 7 or 8. Is there another recommended cheapish cable I should get to try, or would someone be able to lend me one to test with? Alternatively is there anyone in the UK that I could send the sammich too to get it up and running? Thanks, Kai.

Link to comment
Share on other sites

I've offered my services to help Rave fix this issue.

I received the sammichSID today and have experienced the exact same issue as Rave with two different MIDI interfaces that I know work. I went through the trouble shooting guide which made me think is was a problem with the soldering/components rather than the interface.

I opened the unit up and check all the components in the MIDI I/O and found that R5 was 82k rather than 5.6k as per the MBHP Core 8 schematic. R5 connects pin 7 of the 6N138 to ground. I guess this would effect the MIDI in working correctly, thereby causing the upload problem.

Could this be the cause of the problem?

Link to comment
Share on other sites

From the documentation:


The Error Codes (0E)

      F0 00 00 7E 40 <device-id> 0E <error code> <additional information> F7

      <device-id>:  the MIOS device ID from 00 to 7F
      <error code>: see below
      <additional information>: for internal use, ignore it

   Error Code | Description
    0x01      | Less bytes than expected have been received
    0x02      | More bytes than expected have been received
    0x03      | Checksum mismatch
    0x04      | Write failed (verify error or invalid address)
    0x05      | Write access failed (invalid address range) - 
              | used by 1st level bsl
    0x06      | MIDI Time Out
    0x07      | Wrong Debug Command
    0x08      | 2nd level bsl: Read/Write command tried to access an invalid 
              | address range
    0x09      | 2nd level bsl: Read/Write address not correctly aligned
    0x0a      | BankStick not available
    0x0b      | MIDI IN Overrun (CPU load too high)
    0x0c      | MIDI IN Frame Error (Bad signal/Optocoupler)

You got 0xc -> bad signal or optocoupler.


If the resistor values are ok now, try another 6N138


Best Regards, Thorsten.

Link to comment
Share on other sites

I've updated MIOS to V1.9h, Intalled the sammichSID app and loaded all the patches.

I'll send it back without the optocoupler as I had to "borrow" one from my MB SEQ to check it was the problem.

You'll still need to source and install an 6N138 optocoupler.

The backlight circuit isn't working properly either but I haven't/won't look into why it's not working as I don't have the time right now.


Edited by Rowan
Link to comment
Share on other sites

Thank you so much Rowan :smile:


I look forward to getting it back and finally being able to try it after about 4/5 years of being parts!


And thanks to Thorsten and KPete for the help with diagnosis, what a fantastic community :D

Edited by Rave
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...