Jump to content

No device id on MIOS Studio


Recommended Posts

  • 7 months later...

Having a similar problem here..

I am running an STM32 core with an additional 2x2 module. The core was pre-programmed, Bootloader installed. When I first connected it there was already a MIDI 4x4 project.hex file on there, which worked because (MIDI IN/OUT in MIOS Studio were MIDI 4x4) I received MIDI messages on the left terminal after moving knobs on the hardware, that was connected to one of the 2x2-module's MIDI In ports.

So now I uploaded the NG template project, because this is what I would want to be working with, then the uplaod stops halfway and I get the error message seen above. Upon restarting I can now choose MIDIbox NG in the In/Out section in MIOS Studio, but still the same error. Pushing the black knob on the core module didn't do anything either, except for the sound on Windows that says that spomething has been removed and then re-attached.

I couldn't find anything in any guide about the "Device ID" that the error is inquiring about, what's up with that?

EDIT: Ok so I just saw now in the bootsloader newbie guide that the Device ID should only matter in the case of multiple MIDIboxes running in parallel.

I restarted MIOS Studio and the setting seems like it's okay. MIDI IN/OUT is MIDIbox NG as desired. Additional info might be that the STM32 is connected to a Windows 10 Laptop via a Micro USB cable. The problem is that now I don't get the MIDI messages from the connected hardware, that I got earlier.

The connected hardware is a Mavkie C4 Control, which sent a message on startup and of course for every knob/encoder that was triggered

Edited by m.str
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...