Noise-Generator

Members
  • Content count

    29
  • Joined

  • Last visited

Everything posted by Noise-Generator

  1. [MIDIbox SID v2] DIN module map trouble

    18f452 is for sid v1 Have you checked if all connections are good? If you use more than one dinx than built one more and check again.
  2. MIDIbox SID Walkthrough

    I own some stacks of the old one sided pcbs from mikes-midishop (the same which are pictured in the documentation) but not the wilba. But shipping inside eu isn't that safe anymore and expensive, too. I have just a good feeling by shipping inside germany.  It depends on your design. It's possible to mix the sids as you want but you need 9v for the 8580 and 12v for the 6581 and 1 core can manage 2 sid modules (left and right) so both sids get the same controller values. If you want that they work independed, you need a core for every sid. The wilba pcb is a system of 4 hardwired cores and 8 sid slots. I suggest to get a swinsid and if your setup works, you can get and test sids.  A swinsid is close to a sid but not 100% like a real sid. But cheap and you can use it as 8580 or 6581 by jumper setting. A 8580 is the newer sid and more precise The 6581 sounds more dirty and has more bass
  3. LPC Bootloader aufspielen

    Probier mal die zu kontaktieren ob sie dir die alte IDE geben können, oder hier im Forum auf englisch fragen ob die Jemand rumliegen hat bzw. in anderen Foren zB Mikrocontroller.net 
  4. Extra wires for core

    http://www.ucapps.de/mbhp/mbhp_core_v3.gif
  5. MB 6582 Final troubleshooting; encoders and presets

    Have you tried it without the SID?   
  6. OPL3 made in China

    Try it if you can risk 8$ ;)
  7. MB 6582 Final troubleshooting; encoders and presets

    Are you sure your SID is at full health? I've got a 6581 with close symptomes but this shouldn't explain the encoders behavior...
  8. asm to hex

    Yes, I do understand this, it's no accusing, it's complaining ;) It's not easy to understand and research this in a few minutes, it does need a lot of research...and you don't get the answers easy. Sooner or later I must do this, just would be nice to have all the 4 rows of my LCD, now. There is just nothing atm I would change with the inputs.
  9. Nice. I tested the PSUs now in case of noise ratio. I can NOT recommend this cheap China PSU it makes a really loud high noise output but the JAZ PSU doesn't do this, it's pretty damn good, I couldn't recognize that the MbSID is powered with earplugs, just after sending some midi note. Next I will test the power consumption with 1Core LCD and CS stuff, a slave Core and 4 SIDs.
  10. asm to hex

    I'm at the point now to have to change some stuff, too. The official procedure looks very complex and I can't really understand why there is a mplab and there is source code in asm, and can't just edit and compile an asm file, and I think it's because I have to include the files in the project and the question is where...and I don't know why this should be so hard. I don't want to reprogram mios, I just want to change some lines in the code...
  11. This one https://www.ebay.com/itm/120W-Universal-Power-Adapter-for-Notebook-Laptop-In-Car-DC-Charger-EU-Plug-bvg/303062986910?hash=item468ff6309e:g:w-UAAOSw-1ZcZmcc Pretty much overpowered, but just 1A at the 5v. I also have an old psu which offers 12/5 (0,75/1A), which does more fit the needed power  (could be a lil bit underpowered), it's the psu for an Iomega Jaz drive. At ebay someone is selling them in germany but with shipping 30€ As I wrote, I can't recommend those psus at this point because I did not tested it in all ways for a mixed sid setup, I just powered the core and one sid module. Yes, I use the 5v directly to feed the core and the 12v for the sid.  So the only thing what is to do, is to regulate the 12v to 9. Should be also no problem, but can't say this for sure. I read a thread a few days before here, where smashTV, I guess, has written some words about that there are newer voltage regulators out there in case of having more psu options, today and also describes which capacitors can be removed/changed. Can't find this thread again but just looked inside the sid section.  
  12. Well, would be better he also paid the shipping if he sells broken psus, but maybe you can get some bucks for the broken one. May you also have seen that there is a polish company selling new c64 psus on ebay (maybe not in usa), but those are really expensive. It's unusal that they deliever less volts than 5, normally, if the 5v rail is broken (regulator), it delievers more than that and kills everything inside the c64 what needs just 5v. (rip sid) Thats why c64 users today building "crowbar" protection stuff inside their psus and the community is still fighting each others solutions. As far as I read the last times... For a c64, a combination of a 9vac and 5v psu is an alternative and usual but I don't want to contradict latigid on, in case of a midibox you generate 20v ac by a magic act of mixing dc and ac, therefore this solution is profen exclusively at this psus. I do have some c64 psus but try not to use them. They may have the best noise ratio, Thorsten wrote, but I want to use a Laptop psu with a 12v and usb 5v rail, it's smaller and you get them for 17€. I can't recommend them at this point, I still did not tested em in mixed mode but 12 for the sid and 5v for the core, works (yeah, why shouldn't...). The question is still what happens by using the 12v for the old sid and transform this rail to 9 for the new sid.    
  13. That's not normal, a C64 PSU has 5.20V. 
  14. MIOS Studio upload of SammichSID app fails with Error #11 at 99%

    Hell yeah, me too ;) But next time you read someone, having the same issue, your first question will be…have you uploaded mios? It's better to upload first than to try uploading other stuff, uncessfully... I can't say if it's written where you have looked, I can't find either a wilba documentation or a sammich. You need to understand that these are one pcb designs which did come later and are based on the modular designs of multiple components and the creators may think, it's logic, you just need to look at the pages which handle the topic.  I red it on the core page, setting up the core, mios8 and there are readmes.  Have fun with your Sammich
  15. MIOS Studio upload of SammichSID app fails with Error #11 at 99%

    I'm just sceptic because you did need to install a special driver instead of a default. I'm used to have plugnplay with midi interfaces. Mios Studio worked good with my Win 10 but I don't like it and now my Windows machine has 7, and yeah, in case of old audio interfaces it's also the better choice. Btw, there is a rumor that if you update your win7 to win10 (by a previous installed 7 and the drivers you need) the possibility is given that those drivers still work under 10 but not if you install them in 10, just if you upgrade.
  16. MIOS Studio upload of SammichSID app fails with Error #11 at 99%

    You can read about the "Ready" Information at the LCD module page. You really need to be sure that your midi interface is working correctly and that it is supported (whitelist) , don't you have a friend or a shop where you can lend (or abbility to give it back) one?
  17. I´ve got a theory.  I think the PIC permanently restarts, thats why you get the upload request. Maybe it´s because of the 4,62v, the PIC can start, but breaks down because it needs constant 5v, so starts again... I must correct what I said about the upload request first, may there is a upload request every seconds BUT you don´t see this. The message:[1355.224] f0 00 00 7e 40 00 0f 00 00 f7 just appears by booting, rebooting the PIC.   
  18. The voltages seems a bit low, especially the 5v rail, but if your pic work, than it's ok.  The more I think about your problem, I don't think it's the pic.  But as I said, I'm not a pro and it's a pity that no one - maybe also don't have an answer - can say some more. I know how frustrating it is to stuck and start ordering things which might help, but it is like it is. What you could do by your own is to build a minimal core setup with a breadboard, so you can exclude connection or wiring mistakes and you also learn what does this and that and so on. It's not as hard as it seems to build the core with midi by your own.  
  19. LCD Trouble..

    Ok, I did the lcd interconnection test. I refused to, because I don't understand what's the difference vs signal checking with a Voltmeter. But first, results: Sending 5v at d4 gives me just 1.65v and d5 has 0.8v Sending 5v at rs = 0.20v And now, I don't understand why the Voltmeter tells me the lines are not touching each other.. because of touching in a microarea? Update, solved. Thank you! Data lines are more sensitive, right? I removed also the bridge pin 28 to j4. Also I put in the 1k resistor and diode for can Interface bevor but Im kind of sure it's not necessary for the LCD connection. Update, Checked the second Core and rs just gave me, 0.80v. I was kind of sure it´s the connection to r4, cutted the wire and voila. So, I still did not make an research by my own and maybe I overlooked something but either r4 is removed for the x4685 or I did a mistake.  Edit. Yes I soldered the bridge to the wrong pin at j4 at both cores...shame...sha...    
  20. LCD Trouble..

    Hello everybody, I already made a Thread in the SID section but I came a bit closer and did see that this section is better. Core V3 with Pic X685 Midi with MIOS Studio works MIOS 1.9 uploaded, done LCD 1602A (HD441) tested with Arduino UNO, works, perfect Works also with Core, but no Letters, just blocks Trimmed Luma and Contr, just blocks... I think I read everything about using the LCD and it should show at minimum "something with letters" :) By default the HD441 LCD should be supported or do I just did not read and know something which would open me the magic door to see some letters on my LCD, finally?  
  21. How do I debug the core?

    As I'm working now at my Core and LCD again and having trouble I may can give you some advices. So you have the core schematic and lcd wiring for 4bit? First Backlight, mostly pin 15, K=Katode connect to B- and pin 16, A=Anode, connect to B+ Backlight should light up if these two pins are connected and the luminace poti, should work. Second, Vs, Vd, V0 connect to lcd pin 1,2,3 contrast poti should work. If this is working correctly, you can connect the data stuff.    
  22. LCD Trouble..

    Yes.  I will study the interconnection test soon as I got time.
  23. LCD Trouble..

    Yes, I know that and read the readme but it confuses me a little bit and the better way for me was to get closer with LCDs with another method. It makes me kind of mad to understand what is wrong here, because I have another working Core and the LCD behaves also strange. Also, few other PICs And I have an 20268 LCD which Backlight is too weak, what I don't understand because it seems to need more than 5v. If I use it with the Arduino, you don't see enough. I will protocol next steps with more details, next time I make some tests.
  24. LCD Trouble..

    TY.  i did make pictures but I wasn't sure if they are helpful because of chaotic wiring.  but, here they are.
  25. I can´t confirm this, because I don´t have this board but the Cores should operate the same way. Normally this happens 1 time in a few seconds. Maybe it´s a wrong component? Have you proove the values? I dunno, still learning, every day.