Jump to content

SEQV4 (wilba PCB) - SD-Card Error


Recommended Posts

I built a SEQV4 for @C4M, now he has troubles with saving on the SD-Card...

the sequencer itself makes Files and Folders on the SD, but when it comes to the user who press "STORE" he get an Error --- it could be Software-Bug... why i come to that conclusion, please read our PM-Traffic: (RED: C4M, GREEN: ME)



Today I tried to save a project for the first time, I read the manual :



Allows you to save the pattern of the currently active pattern group:


Select the target bank with GP6, and the target pattern with GP7. While changing it, the name of the pattern which is already stored at this position will be displayed at the right LCD:


Finally press SAVE (GP8 button). You will be asked for a Category and Pattern name:

Use the first 10 GP buttons or encoders to cycle the characters (like on a telephone keypad), and the remaining buttons/encoders to select a character directly, move the cursor, delete/insert characters, selecting a preset (with the encoder) and finally to SAVE the pattern.


Expand  Expand  

I can select the track I want to save (Track 1- 4) but when i try to select a target it says "Bank #0 not available" , I tried to save anyway, choosed a name for my project, pressed save but there is a message " SD CARD ERROR / E131  (FatFs:  D   5)"

I find this topic but I don't understand a thing honestly



did you formated the sdcard on a pc with fat32. and if so do you have deleted all partitions on it (sometime there are preinstalled hidden drives on sticks and cards). do you use a small sd card? its better to only use cards <=4.5gb.    try to delete all folder and files on the card with a card reader first. if not working delete all partitions make a new and format with fat32 filesystem. if not try a other sdcard.


OK i think I have totally misunderstood, am I supposed to get a different SD card than the one already inside when you sent me the unit ??So I suppose this one is for implementing the software and now I have to get a new one to save my project ? Sorry for the newbie question lmao

hmm didnt remember there was already a card inside - sorry! check: is the card a small one? (<5gb?). if yes: take it out, plug it into a card reader (extern or laptop in dont matter). then delete all partitions. make a new partition. format the card with fat32. plug it into the seq again. if not working - try a other card. if still not working then: make a software update... i will give you instructions - but try the steps above before and give me feedback.


Ok there is "MBSEQ_HW.V4" on the SD card (4GB), I saved the file on my desk because the Midibox needs this file to work, right ? I erased the SD card with the disk utility on my macbook and choosed FAT32 but I can't partition because it's a MBR partition... don't know what it means..

Anyway I put the "MBSEQ_HW.V4" file on the SD card again  and inserted the SD card in the Midibox nothing's changed so I  suppose I have to find another SD card

mbr is right (gpt would be wrong)... i am a linux and win user... in windows you have to delete all partitions and then make a new one. then format with fat32about the hardware file you are right it has to bebon the root of the sd.   1gb cards are recomment, 3 or 4 should beworking also.     the card isnt write projected? (the switch). a and dont use sdhc micro with adapter - take the big formfactors...


No the card is unlock and it is not a micro with adapter..I found a 2gb card, formated it in fat 32, put the MBSEQ_HW.V4 on it and still it doesn't work so maybe the sd card is not the problem

then download miosstudio:


connect seq to mac, start mios studio, select the midiports, type in the miosterminal field " help" . a bunch of settings apears, one of them shoulf format the card.

to update the os stay in mios studio... and upload the hexfile for wilbas frontpanel, find it inhttp://www.ucapps.de/mios32/midibox_seq_v4_096.zip

then give me feedback


I connected the SEQ to my mac, selected the midiports, sent the help command in the MIOS terminal then uploaded the MBHP_CORE_STM32F4 .hex file but still it can't access the SD card

I tried to format the card again, put the MBSEQ_HW.V4 file I found in the Wilba folder on the SD card but it doesn't change anything.

Thing is when I format the sd card with my mac I have a very few options, I can just choose if I want "MS-DOS (FAT)", "ExFAT"...so maybe it's not formated the right way I don't know...

msdos is the right format. qestion: by typing help you got any format disk options?  sorry for the late answers i was until today in the mountains with poor telecom....

last plan is that you send it back to me and i check the electronic....  after formatting and putting the hwconfigfile on it, and after trying to save with the error msg, and then putting the sd card in your mac again: what did you see on the card? only the hw fild? or has the seq slftware built a folder or files on it? did you try to save some seq settings? if there are folders or files on the card we can say that its not a hatdware fault (99%)


Hello, I started over today and followed your instructions

I connected the Seq to my mac, sent the help command, I found a command named sdcard_format so I wrote the command, formated the Seq.

Then I uploaded the STM32F4 .hex file with Mios. I checked the sd card and a folder appeared : "Presets" and in this folder a bunch of files "Store v1" "Store v2" "TRKCATS.V4P"... etc.

I added the HW.V4 file on the sd card and try to save on the seq still it doesn't work (disk error)

Then i checked on the sd card if something new appeared but I don't think so

Maybe it's better I sent you the midibox unless you have more instructions to give me

ok... there are files on the card, so it shouldnt be  a hardware error (because hw error cant write files on the card - at least this is logical)   ... i will start a tread on the forum with the content of our communication... looks to me like a software bug - where outhers should help.

Link to comment
Share on other sites

  • 2 weeks later...

No idea about your error, I know some people have trouble formatting and the trick is usually to use another computer (Windows) or so. 

Why not create a verified SD card on your side and ship that to the customer? If it doesn't work, then if must be a hardware issue (e.g. SD socket soldered too hot).

Link to comment
Share on other sites

No problem, moved to the troubleshooting forum.

Please make sure the card is formatted with FAT32, that it is no XC (eXtended Capacity Card) and that the card itself is good. I've had damaged SD Cards that formatted well under windows (with the quick format basic windows formatter), but then could not be written on.

If the SEQ v4 can create directories, i would agree it does not look like a hardware problem -> recommend to exchange the card for another one, e.g. an 8GB or 16GB Sandisk Ultra (SDHC) which are available for 5-8€ or so.

It's also recommended to use a tool like SDFormatter (Windows) to do a low-level format of the card with FAT32, this tool can also do some extended error checking.

Best regards,

Link to comment
Share on other sites

The Wayback Machine is great for retrieving old site data, have a look:


I've spotted multiple snapshots and could even download a few old sequencer versions - not all are necessarily stored on their servers, but then you can just choose another snapshot from another date.

Good luck!

Best regards,

Link to comment
Share on other sites

ok since i am not a seqV4 user... i also come in trouble by creating a working sdcard... i needet also the bootloader "switch" because of a not reacting machine (because of not connected Hardware/Front-PCB ;)  )


my workflow below... i send the sd-card tomorrow, before the lockdown:



ok that was a hard one... its now formated, and i created 3 sessions on it... i send it to you tomorow.

in the meantime, you could try in the mios-studio: (the way i got it to work)

--- when typing "sdcard" and press Enter, i got the message  that the filestructure for session and so on doesnt exist --- a simple "store" or "save" wouldnt create it....

so, i made a first session...:

open mios studio

click into the miosterminal (with the mouse)

type "new session1"

wait  a few seconds, - it is creating a  new session.

type "store"

type "save"

type "reset"

close mios-studio

wait 10 seconds

open mios-studio again

type "sdcard"... you will see that a "session1" exist (or you take out the card, and look on your computer to see a older named "session1" with files in it exist...

type store or save, you should not get a error message.


now go and try to save on the machine itself.

(maybe the user got the error because no session filestructure was on the card... (like on my situation)


strange is that the mios-studio-ports says that "seqV4+" (its a seq v4 wilba FP without tpd)

Edited by Phatline
Link to comment
Share on other sites

15 hours ago, Phatline said:

strange is that the mios-studio-ports says that "seqV4+" (its a seq v4 wilba FP without tpd)

That's all right - for the software it is a SEQ v4+, if it has a STM32F4 with 1MB of flash memory - it just can't use the extended UI features of the midiphy SEQ v4+, primarily the secondary selection row and the TPD/Activity Matrix - using the Wilba hardware config file should work fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...