All Activity

This stream auto-updates   

  1. Today
  2. Troubleshooting midiphy SEQ v4+

    Make sure you clean up all of the pads (with desoldering braid) before resoldering IC2. Pin 16 can be bridged directly to C2, no problem.
  3. Troubleshooting midiphy SEQ v4+

    Just followed every of your recommandations. Checked R33 abcd : 3.2v on all you will find attached also the values that i have on both display ports pins and on the oled itself. after reworking on ic2 a saw a problem with the pin that was in front of C2 (solder did not stick) so in doubt i unsoldered IC2 and the pin was simply missing :/ . Do you think its the origin of oled problems ? also can i bridge directly the pin to C2 or i must bridge from somewhere else ? thanks !    
  4. Yesterday
  5. Troubleshooting midiphy SEQ v4+

    The soldering on the OLED headers could be better, try to rework. If the fillet looks like a teardrop, it might not be contacting the PTH properly. Try to get the heat into the pad and the solder will flow there. Soldering could be better on IC2, pin 8. Recheck R33abcd. Try swapping the OLED cabling to the other J15 port. Could be bad cables again, could also be that some pins on the cable short out components on the OLED, so isolate with even a scrap piece of plastic or card on the OLED PCB right under the connector.
  6. Troubleshooting midiphy SEQ v4+

    Hi there Everythig is done and before assembling the sequencer, I wanted to test all the functions (always with midibox ng and seq_l/r). R.A.S (good news) except for the screens that don't work. At the second boot I had the right screen (nothing on the left one) which displayed 88888...over its entire surface and at the next boot, nothing, the same for both screens. I test this way (core->JA board->lemec1->lemec2 + both screens) - I checked that J15S is set to 3.3V, -Rework each core weld (in case...) - Checked the voltages, I have the same results as on these images (posted by "SimonSays"): -tested the lcd command... no idea what to do at this stage;( thanks for any help !
  7. Last week
  8. [FS] MIDIBOX SEQv4 in nice red wooden case

    Send message via whatsapp! Hedi
  9. Troubleshooting midiphy SEQ v4+

    That might be a hard combination to tune. But yes, normally blue should have a lower-value resistor as it's typically dimmer.  At least on the older SEQ firmware, the measure LED was not "XORed" i.e. beat and measure would trigger at the same time. That might be a way to get all three going at once for white-ish, though I can't remember if it's still part of the current firmware.
  10. Troubleshooting midiphy SEQ v4+

    Hi there, not sure on how to proceed but i would like to have a blue /white scheme for the beat led. am i correct if go A->1k res->3 (blue) and B->4.7k res->1,2,3 or i should do fro B : B->4.7k res->1 B->4.7k res->2 B->4.7k res->3   thanks :)
  11. yeah since i'm coming form woodworking - maybe the OLED had to adjust to room temperature first
  12. Sometimes I feel like there can be oxidation or other crap on the pins that prevents good contact and messes up the data transfer.
  13. well after a million tests and power cycles yesterday i just turned on my main system power supply this morning and got this   so consider this case closed.
  14. The NG and the DSP...

    These look very interesting indeed. Not as obviously/conveniently freely programmable. I am currently building a synth on the axoloti platform. While rough around the edges the patching software for it is a really great balance between simple modular patching and hardcore coding. But the hardware is kind of outdated (same STM32F4) and the community rather slow these days. There are currently notions to develope upgraded hardware on an ARM m7 or other newer platform though. sorry i just kind of crashed into this thread from a search result, not sure if this might have been discussed before or even is way off topic. oops.
  15. I wired up my 7pin SPI 1306 according to this diagram using 1k res and 10u cap.     but i'm failing to get anything out of the screen. trying to just print text through the console lcd command, or the hello world program or even the NG init message. i did set the correct LCD type in the bootloader: there's this other old thread where someone had to connect the OLEDs reset pin to some other core connectors GPIO pin iirc? is that really the way to go, no convenient simple conncetion available? i tried manually setting the reset pin to 0/3.3 via the testlcdpin command, no success. while manual, that should do the same trick as the GPIO pin reset above, right? edit: i realized the J15 reset pin is connected to the DC pin of the OLED? so no manual reset this way?   i tried doing some measurements. core board soldering seems ok. power/ground voltages are also where i think they're supposed to be everywhere. is there a page or list with debugging measurement points on the STM32F4 core board? DINOUT and AINSER 64 work for what its worth.   more pictures of my "circuit" i realized in the above picture the SDA cable was in p4 instead of p6, that was not the issue though. OLED supposed to work on 2.8-5.5v, i tried both 3.3 and 5v jumper settings. yeah i know my soldering is "sub par" GND and VCC from both j15 and the OLED going to the power strip on the breadboard, and the blue wire to the reset pin.  
  16. The NG and the DSP...

    can you upload your own dsp code there? see nothing on there site...
  17. Need a LCD Display 240x64 for Yamaha RS 7000

    has anyone attempted repairing/changing the RM1x ?    which display is pin compatible with the EDMMR03Y00 LCD mentioned on the manual ?  
  18. Troubleshooting midiphy SEQ v4+

    i was finishing all the test then.....I can thank the all mighty god of randomness, i switched one of the lemec board cable with the core one then everything was......working  i have pretty luck after unsoldering twice the IC's that i didnt kill anything finally . I was far too confident with my cables, will check them twice for sure now ! i'm out of cable headers but finally the beast should be alive very soon
  19. Troubleshooting midiphy SEQ v4+

    If _NG is flashed and JA is working it's a good sign. The _l and _r .NGC files specify the position of JA. You can use _r to test lemec_L. It's possible to test lemec_R as the first board in the chain, but you need to reconfigure the file. The boards are chained JA-lemec_L-lemecR, correct?  You should measure +5V on the 74HC165 input pins and 74HC595 outputs should go to +5V with set dout all 1. Check the preceding pages of this thread or the datasheets for pin assignments. You can follow the SRIO chain (especially the SO signal) to see how far the data gets. Seeing as you have some DIN activity, consider replacing IC2/IC4, which were reversed and then heated up probably quite a lot during rework.   
  20. Troubleshooting midiphy SEQ v4+

    Double checked but yes, MB_NG is flashed (MIOS detect MIDIbox NG on midi IN/OUT) and i tested both seq_l and seq_r (with seq_r, all ja board leds are lighting up, what the exact diffrences of r & l config files, simply for left/right version ?) . Actually JA Board seems to works perfectly, i have correct feedback within MIOS console (push btns / alp push action / knob) and leds are working correctly when i test buttons. With MEC boards its another story and only knobs turning are sending feeback to MIOS (tested with both seq_l / r).ngc) here the screenshot of what i get in the console. for info between each knob test i'm pushing them (no action triggered in console as you can see), same for mec switches and the matrix on CC16 (chn 1), not working . No succes with "set dout" function either unfortunally (dunno if its possible to test ic with a multimeter ?).   So for you , only IC2/3 (on both MEC boards) need to be changed or its better to replace all IC's ? for now its only my second diy project (first one was a xoxbox few years ago), i didnt had ocassion to stock spare parts but for sure i'm going to order enough "in case of"  :)   Thanks  
  21. Troubleshooting midiphy SEQ v4+

    Just check first that the MB_NG app is flashed and you have loaded the correct seq_l or seq_r.ngc. Was testing of the JA board okay? To simulate DOUT behaviour you can try  set dout all 1 Or go through and count the dout pins (8 per chip) until you get to the correct IC -> replace all with the one you want to toggle. DOUT rows/cathode sink rows are given in previous pages. The matrix is controlled by ICs 2 (cathodes) and 3 (DIN). Having spare parts is always useful and could be used in future projects. I typically get 100 shift registers at a time.
  22. Troubleshooting midiphy SEQ v4+

    Okay, so I just checked the cables: no problem, obviously. I also unsoldered / soldered back ic2 and ic3 together without success. The problem is 100% identical on both lemec pcb. Under MIOS, when I turn the knobs, I have a correct return of the values from both boards with the debug mode enabled, but no action is triggered when I press one of the buttons (alp push or lemec switches). Out of curiosity, I tested the pcb lemec (the smallest) by completely removing IC3 and the problem is the same, maybe that can confirm that IC3 is dead ? In your opinion, does this mean that certainty both IC3s are dead (because of the inversion?) and does the problem with the matrix also correspond to these ICs? I am waiting for your answer and I will order some spare parts. Have a good day and thanks :)
  23. [FS] GM5x5x5

    Parting ways with the ultra-rare GM5x5x5 and most of other built and to be built DIY audio projects.   Comes straight out of my DIY audio box which seemingly have been left for far too long unattended, and life moves on at its own pace.    Not looking to profit, Shipping from Canada at cost. Kartoshka
  24. Troubleshooting midiphy SEQ v4+

    These are the same ICs, I unsoldered them with hot air and soldered them back with iron (my paste is poping !). I'll apply your advices in the evening and I'll give you a feedback:) With Mios I have a normal feedback by turning all the knobs but nothing from pushing them, same with mec switches on both pcb.  
  25. The NG and the DSP...

    This one could be the alternate an easier way to achieve our goal guys:
  26. Troubleshooting midiphy SEQ v4+

    No worries. It might be that IC2 was damaged by being reversed. Did you use new chips or the same? I was troubleshooting with @niles the past weeks on a similar problem. The same advice applies, so check cables, resolder IC2 and IC3. Many solder joints look "cold" Any MIOS output with  set debug on ?
  27. Troubleshooting midiphy SEQ v4+

    Thanks for your fast answer latigid :) , yes it's the core I was talking about but you have the eye and after welding in the right direction ic2 and ic4 (on both pcb) everything was working and I was finally able to do the test. In this case, the encoders work perfectly but their push action doesn't work, its the same for the mec switches and the matrix (i was on the correct cc/channel). Do you have any idea what I need to check ? pretty hard to debug when you are a noob i admit. thanks by advance
  28. Load more activity