fcebreros

Help troubelshooting button matrix please

7 posts in this topic

Hi,

I'm finishing my MB-6582 and can't find where I messed up.
Encoders work, LEDs work, buttons work but don't do what they should do.
Third bottom button for example makes third horizontal LED line blink, and
LED's go on and of everywhere every time I push a button (LCD menu also changes)
Encoders work fine.
With the matrix test every LED lights up except the Control Env LED.
When I push buttons nothing happens en the LCD.
No shorts on the U20, 5V on the pins coming from JD5 and 10kOhm to 5V
on every pin.
I have not used the BC547 transistors and have bridged across.
But that should work, right?

Will be great full for any insights!
Cheers
FC

1 person likes this

Share this post


Link to post
Share on other sites

FC,

I seem to remember having a few issues like this on mine. Double check all the solder points on the IC's along the bottom of the main board.

Justin

Share this post


Link to post
Share on other sites

Thanks for the info!

It seems the optional sinking transistors aren't that optional.
I put them in (used BC337) and now all works.

Cheers
FC

1 person likes this

Share this post


Link to post
Share on other sites

Yeah, they aren’t really optional. No idea why they’re listed as such. You’re not the first person to have this issue.

Share this post


Link to post
Share on other sites

Maybe "optional" in the sense that you can invert the current sink shift register states. Would have to recompile the firmware.

Share this post


Link to post
Share on other sites

Yeah, but that’s a super-niche technical note that should be buried in old forum posts or as comments in the actual code, not casually mentioned as “optional” with no further context in the official BOM.

Share this post


Link to post
Share on other sites

Perhaps update the docu then? There's been no edits on the wiki page for over seven years and Wilba's been gone for five or six...

Edit: okay, I've updated it. My comment was considering that if the issue had been noticed previously, it would've been nice to provide the info at that time... But yes, outdated doku sure is annoying...

Edited by latigid on
1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now