Phatline

AOUT_NG not working

7 posts in this topic

hei,

i have 2 of them here,

booth not working , they have not been working till the day

 

i first used my code, but since it did not work i uploadet the tutorial_16 svn

and edit the code for what I think is to be set for AOUT_NG:

  // initialize AOUT module
  AOUT_Init(0);

  // configure interface
  // see AOUT module documentation for available interfaces and options
  aout_config_t config;
  config = AOUT_ConfigGet();
  config.if_type = AOUT_IF_TLV5630;
  config.if_option = 0;
  config.num_channels = 8; // INTDAC: only 2 channels supported, 8 channels pre-configured for your own comfort
  config.chn_inverted = 1;
  AOUT_ConfigSet(config);
  AOUT_IF_Init(0);

 

The LED is lighting up, and i followed the connection from the chip 541 till the DAC  >>> from the beginning i have done right; to be sure for that, i copyed all info i found about that weired connection:

AOUT-INTERCOM.thumb.png.d62dd89ef4b10785

and i think there is something wrong with the documentation, the photo of the ng shows i (i think) a different pinning) also in every shematic or tutorial or wiki you get other names for that pins - its very confusing - can anybody check my multicolor painted connections in graphic above - thanx

 

for that i removed the Discovery board and "biept out" all connections, i finally replaced the 541 on the core.... R33 is also stuffed, and it is a 1K network - all right -but solved nothing.

i also tryed a second core, that i have (i have a pair of them),

 

i also measured carefully direct on the DAC GND and +5V all are there.

 

I measured DAC-A output aka "pin 0" and i have 0V to Digital Ground > so nothing.

 

I connected +-12V from a doepfer PSU2 - right from the beginning on...

 

and as far as i can say i have not heated the DAC to much while soldering, i made it quick and clean with a Weller Station where i can change the temperature...

 

 

i stuck a bit... maybe there is something wrong with the inital code (posted above)

 

thx for any tip

 

Edited by Phatline

Share this post


Link to post
Share on other sites

According to your diagram, it seems you connect SO to FS, SC to DIN and RC to SCLK it's totally wrong.
Must be:
SO to DIN
RC to FS
SC to SCLK

Best
Bruno

Share this post


Link to post
Share on other sites

so this

AOUT-INTERCOM-zugeschnitten.thumb.png.8f

 

i solder a new cable, and will report the result.

 

many thx!!! mike

Share this post


Link to post
Share on other sites

ok cable worked -thx

one aout-module is not functional > looks i killed the dac somehow.

the other module is working in unipolar mode from 0-11,4V all right

 but in bipolar mode it is only working from -+3V  - but i have connectecd +-12V... is this normal?, in doku is written that moog works with -+5V, (the ssm2164 working with the voltage?), or should i drive the the aout with +-15V or even more?

i controlled all Resistors with colorcode, and also the inprint of the trimmpot is correct, changed a tl074n also, i have about -12V @pin 11 and +12 @ pin 4 - also with plugged in tl074n

i set the jumpers to bipolar mode like describt in the ucapps.de side

 notice that the R200-Trimpots are getting worm, i have not connected any modules on the analog output... so it could be a conceptional thing (low resistor values) of the circuit that they get warm (+12V 2.2K >-200OhmTrim-<1,5K- >12V) so maybe not a failure

i measured the resistance like below:

AOUT-BIPOLAR-FAIL.thumb.png.592e863410c4

 

Edited by Phatline

Share this post


Link to post
Share on other sites
3 hours ago, Phatline said:

one aout-module is not functional > looks i killed the dac somehow.

 

Many have done the same. Some of the DACs seem quite sensitive to heat, which can result in a fully nonfunctional AOUT or weirdness on some channels.

 

3 hours ago, Phatline said:

but in bipolar mode it is only working from -+3V

Could be the known issue of a 1:1 voltage divider:

But it's already claimed to be okay for the quad VCA, if that's your usecase.

 

 

Share this post


Link to post
Share on other sites

Maybe the testaoutpin can help you to make sure the connections are ok to the board.

For me it wasn't working neither but when i did the following it started to work.

 

On 2/24/2018 at 10:42 PM, flyweight said:

Ah I seem to have sucses.  When I disabled th aout_ng in the config, saved it and turned the midibox off. Then turned it on again, selected - aout-ng and tweaking the calibration voltages gives me output!!!! ITS ALIVE!!!

It's to bad that most likely the first dac was fine as well and this does look like a bug. (not sure)

I will continue the tests another day.

Cheers,

F*cking happy Tim

 

Share this post


Link to post
Share on other sites

thx for the link, interesting stuff! that  closes the cycle i think...

 

2164 - quad, and ssm2044 duo yes

 

come on when thats a know problem no one changed the wiki, or told a admin to change it on ucapps.de  :cry: - a hell to desolder this double sided boards...

Quote

So although this will lead to more documentation effort and questions, I'd still prefer to generally suggest the first solution instead of a) having Smash change the contents of his kits and b) making the module harder to handle for the 95% of people that won't ever need the bipolar mode :)

I can only apologize for the confusion and this stupid design mistake... Wiki will be updated in the next days.

really?

i make a start, and document at least in the ssm2164 getting started wiki...  allthough the ssm2164 is unipolar - which is no problem  because we have the full range

and for:

**All SSM2044 builders:**\\
The module is designed with this (wrong) bipolar range, so you don't need to change anything on your AOUT_NGs.

 

i will at least for test phase need higher voltages   - because i make  "distortion > pre-vcf-vca(filterdrive) > vcf > pre-vca(drive)     -  channelstrips -   and i noticed when i encrease the cv-input of a vca dramatically  (that was a 303 clone) i got hot effects.  :grin:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now