Jump to content

Recommended Posts

Hey everyone! I have been working on my SID synthesizer for the past couple months. I have the Core and SID modules (that I got from SmashTV) assembled, and my parts for the minimal control surface finally came in the mail.

 

I have attached images of the 2x20 LCD that I will be using. The problem I am having is that I do not know where to go to find documentation on how to wire this display up so that it will function with the rest of my modules. I bought it assuming that these universal displays have some sort of standardization. Given that you guys have set up an LCD display before what would you suggest?

 

Now for the power supply. I am going to find an old C64 power supply for sale (the commodores I ordered did not come with them) and follow this schematic:

 

http://ucapps.de/mbhp/mbhp_sid_c64_psu.pdf

 

The ground, J2, and J3 go to an audio Jack but I don't plan on using one. I want to use the midi out to connect to my computer where I hope to control my synthesizer in Propellerhead Reason 7. Before I deviate from the documentation I wanted to ask your opinion on this change to the design.

 

Thanks in advance!

 

 

 

post-17968-0-58931800-1373058578_thumb.j

post-17968-0-08254200-1373058587_thumb.j

Link to post
Share on other sites

Hi and welcome,

 

First, congrats on your progress with your SID.

 

Regarding the display: I´m having difficulties finding a proper datasheet for this one. It might help if you told us where you bought it or, better yet, you contact your suplier yourself and ask for a datasheet.

 

 

...audio Jack but I don't plan on using one. I want to use the midi out to connect to my computer where I hope to control my synthesizer in Propellerhead Reason 7.

 

To be honest I´m a little confused. If you are not planing on using an audio jack at j3 (audio out!!!) how do you expect to hear the sound your SID makes. The midi connection itself doesn´t transfer audio signals, but MIDI data. If you want to integrate the SID into Reason the connections would be like this:

 

SID                       REASON

Midi Out ----------- Midi In (optional)

Midi In    ----------- Midi Out (required)

Audio Out --------- Audio In (into your PC/MAC audio interface then into Reason OR into another Audio processing device entirely (Mixer, Amp, FX Gear,.....)) 

 

I´m sorry if I´m stating the obvious here.

 

best regards

Link to post
Share on other sites

I have never had the chance of using a midi cable before. I assumed it processed the midi data and audio. Thanks for the information.

 

I ended up finding a datasheet for a 2x20 Densitron display with the same physical dimensions as the one I have. Even though the model number is not the same I plan on using it anyway.

 

As far as the power supply goes I now realize there are no 7 pin C64 PSUs in circulation. Everything on ebay is the 4 pin type which will not match up with my port that I will get from my C64. I think using this solution will work best for me:

http://www.teamliquid.net/blogs/viewblog.php?topic_id=359351

Sadly I could only find the 7 pin connector (as well as PCB mountable audio ports) for sale on eBay. These parts will ship from Hong Kong which will take a little less then a month to get here.

 

Until then I will be making the minimal control surface. This page: http://www.ucapps.de/midibox_sid_manual_fp.html tells me what the buttons are suppose to do, but it does not tell me how to wire them to the DIN module? A schematic would really help and answer all my questions on how to do this. Again, thanks!

Link to post
Share on other sites

Hi, take a look at this. Here you can see a standard button/encoder wiring to a DIN module. On this page at the bottom you find other docs and infos about connecting stuff.

 

But you don´t have to follow those wiring diagrams 1:1. You can simply connect the amount of buttons/encoders/leds (buttons/encodes to DIN, leds to DOUT modules) you´d like to use with your SID and reassign all the hardware components inside the firmware (look into the source code for a setup_*.asm file). Don´t worry, you don´t have to program anything, you just have to modify some variables, which are very well explained inside those setup_*.asm files.

After you assigned all your hardware inside this file, you recomplile the code and get a "setup_*.hex" file to upload onto your SID. You can find the necessary infos about the needed toolchain and the procedures for compiling a Midibox firmware here.

 

my regards

Link to post
Share on other sites
  • 1 month later...

Hello. Sorry for the delay in the reply. I did not want to post something until I made progress. The female connectors I ordered did not fit so I got new ones. I have also been out of town.

 

Finished with the power supply circuit. I checked the voltages and everything checks out perfectly on all modules. I inserted the ICs which got me to the screen that says "Ready" (yay I did not mess up). I am reading through the installation guide now.

 

I do not have an interface for the midi in or midi out, but luckily my friend gave me an adapter which goes to USB. I just got it today along with the right female connectors.

 

In summary I have no questions for now. Thanks for the explanation of the button set up. If I would have known that it was so easy, I would have bought more buttons and knobs for filters and envelopes. Hopefully my next post will be me telling you guys that the project was a success. I think I am at 90% completion as of now.

 

 

Link to post
Share on other sites
  • 3 weeks later...

I am still working on getting through the Quick Start Guide. SDCC, MSYS, and GPUtils have been installed.

Quote taken from the Quick Start Guide:

On the next line, replace <your application directory> with the location where you have unzipped the files you downloaded from ucapps.de.

I would like to know more about "the files" that I need to download from ucapps.de. What are the files called? 

 

At first I thought the guide was referring to the MIOS_Studio application. I downloaded that from ucapps.de. However, I can only assume they are reffering to something else I need to get.

 

Please correct me if I have made any assumptions that are wrong or irrelevant, thanks.

 

 

 

Link to post
Share on other sites
  • 2 weeks later...

I downloaded and extracted mios_base_v1_1 to my desktop.

 

I then changed the directory in command prompt to: "C:\Users\Jake Harper\Desktop\mios_base_v1_1>" (without quotes)

 

Next I needed to set the path. Code: "C:\Users\Jake Harper\Desktop\mios_base_v1_1>SET PATH=C:\msys\1.0\bin;%programfiles%\gputils\bin;%programfiles%\SDCC\bin;%PATH%" (without quotes)

 

I understand that "msys" is lower case and in the quick start guide they use uppercase. I use lowercase because the folder in my c drive is lowercase. On the next line I type "make", yet I get the error that reads: "make: *** No targets specified and no makefile found. Stop."

 

I noticed that my SDCC is stored in "programfiles(x86)" so I changed my code to: "C:\Users\Jake Harper\Desktop\mios_base_v1_1>SET PATH=C:\msys\1.0\bin;%programfiles%\gputils\bin;%programfiles(x86)%\SDCC\bin;%PATH%" (without quotes)

 

I received the same error. Naturally I have tried many more tweaks to the code to get command prompt to locate the makefile. Still unsuccessful. What do you guys suggest? 

Link to post
Share on other sites

Spaces in paths ("Jake Harper") are often an issue. Try to move the stuff down a few levels. c:\mios\ or something like that. All the stuff that happens in Windows is case-insensitive. So MSYS is the same as msys. Everything inside MSYS is a different story.

Link to post
Share on other sites

I moved the mios_base_v1_1 folder into the c drive. I then changed the directory to: C:\mios_base_v1_1>

 

I then typed: C:\mios_base_v1_1>SET PATH=C:\msys\1.0\bin;%programfiles%\gputils\bin;%programfiles%\SDCC\bin;%PATH%

and on the next line typed: make

 

I still received the same error: make: *** No targets specified and no makefile found. Stop.

Link to post
Share on other sites

I tried adding the "apps" folder to the directory. I received the same error as before. Because command prompt could not find the makefile, I looked into the template folder which contains 4 more folders and in those I found makefiles. I then added one of those folders to the directory (the asm_skeleton for example) and ran the make command. When I did this I think command prompt was able to locate the make file. However, I received these errors:

 

Makefile:21: /include/makefile/asm_only.mk: No such file or directory

Makefile:24: /modules/app_lcd/dummy/app_lcd.mk: No such file or directory

make: *** No rule to make target `/modules/app_lcd/dummy/app_lcd.mk'. Stop.

 

I did not expect this to work, but I wanted to get a response other than an error saying that no makefiles were found. At this point I have two ideas of what is preventing me from making progress:

 

1) My "SET PATH=C:\msys\1.0\bin;%programfiles%\gputils\bin;%programfiles%\SDCC\bin;%PATH%" command could be written wrong. I have triple checked this with the quick start guide to see if it is written correctly. However, My MSYS and SDCC files may be in different locations than what the tutorial suggests (and that might throw it off?). As said before I do have a "msys" folder in my c drive and a "SDCC" folder in my program files (x86) drive. Just letting you know in case this helps.

 

2) The quick start guide uses: "C:\MIOS\midibox_sid_v2_0_rc18" as the directory. Specifically the "midibox_sid_v2_0_rc18" part raises a red flag for me. I have not seen any file called this. It may be possible that the guide is out of date, but from what I have seen the midibox community has done a fantastic job of keeping guides up to date or letting others know if there have been changes.

 

Just throwing a bunch of ideas out there. Thanks nILS for the support.

Link to post
Share on other sites

I extracted that file you linked me which gave me the midibox_sid_v2_043 folder. I placed that folder inside the mios_base_v1_1 folder (again just trying to get my set up to look like the guide's) and I ran the make command. The result was 16 lines of code. None of which said error so I assume it worked. If you would like to see these results please let me know. I can type them up for you.

 

To my understanding doing this would give me .hex files as the guide says: 

 

Your .hex file(s) will be ready.

 

I read in the Mios Studio guide that I would need to browse for the project.hex file located in the "midibox_sid_v3" folder.

 

.../midibox_sid_v3/mios32/project.hex

 

I checked my "midibox_sid_v2_043" folder. I did not find any folder called "mios32" and I was not able to find a "project.hex" file. I did find a "setup_6581.asm" and a "setup_6581.hex" file. To be honest I have not changed any of the source code like John E. Finster told me to do earlier. I know that I will not be able to change parameters using the buttons and encoder. However, my goal right now is to get this box to make a sound using an initialized patch. I want to hear it work - not just see the "Ready" screen.

 

Does anyone know how I can get the "project.hex" file so that I can make use of Mios Studio?

Link to post
Share on other sites

Hold on - I was under the assumption you were trying to build v2 (for a PIC18F4685 core). So you shouldn't be looking for a "...v3" folder. After running "make" there should be a bunch of .hex files in that very folder. Do you see those?

Link to post
Share on other sites

I am building a v2 of the midibox sid. The core is stuffed with a PIC18F4685. The reason why I wrote v3 is because I was quoting the guide that I am following for MIOS Studio: http://www.ucapps.de/mios_studio.html Next to step 3, marked with a purple "3", the guide refers to a folder called "midibox_sid_v3". It might be a typo on their part because I don't think there is a version 3 of the midibox sid. 

 

Anyway, within the midibox_sid_v2_043 folder I have the following .hex files:

setup_6581.hex

setup_8580.hex

setup_mb6582.hex

setup_sammich_sid.hex

setup_tk.hex

setup_tk2.hex

sid_filter_table.hex

Link to post
Share on other sites
  • 2 weeks later...

I just wanted to point out something you mentioned earlier in the thread. You said all the eBay power supplies are 4-pins -- ALL C64 power supplies are 4pin, they just use a 7-pin connector. At least in North America this is true. The top 2 pins are +9VAC, the bottom is ground, and the one to the left or right of it is +5VDC.

 

See pics attached of mine!

 

post-20304-0-53162800-1380125757_thumb.j

post-20304-0-50824600-1380125763_thumb.j

Link to post
Share on other sites

I see. The pins are spaced so that even a 4 pin connector will fit into a 7 pin port.

 

On the subject of software installation, I have not made progress. I just started my first year of college, and am getting through the first week. This weekend I have time set aside for troubleshooting. Hoping to get it working. This "Ready" screen is taunting me.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...