Jump to content

LoopA V2 Introduction, Features & Support Thread


Recommended Posts

Congratulations on your hard work everyone involved! Nice to see a MIDIbox device finally get the recognition it deserves!

I just wanted to update the thread and say that I had the intermittent booting issue since I built my LoopA and since installing those 2 resistors Andy suggested, it has been flawless!

Such a fun little device to get ideas down quickly while remaining inspired and in the moment! One of the most important things for my workflow!

Edited by Smithy
  • Like 2
Link to comment
Share on other sites

And, its out! :)
LoopA firmware version 2.08 with a lot of new features has just been released - highlights:
- Autoloop recording (dynamic length clips, BPM detection)
- Session naming
- Undo, Redo, clip playback inversion
- Scene map - graphical active clip matrix overview
- Global direct track selection: push and hold upper-row keys
- Transposition of forwarded notes (via TRACK Fwd)
- Fine-granular note position adjustments now supported in note editor
- "Uneven" clip zoom levels are now supported for polyrhythmic experiments
- New "MIDI Panic" function available via hotkey
Enjoy! :)
Best regards and have happy holidays!
Link to comment
Share on other sites

Recently finished my LoopA build, enjoying this little beast!

I have a query regarding the FX section, more a feature request (if its even feasible); is it possible to dampen the velocity of a track based on an input rather than globally per track? I'm thinking along the lines of imitating a ducking effect or is there some other way to do this with the LoopA?


Edit: I've just found I can do something similar in the CC section of a track by applying a Sine4 across each bar and choosing CC#7 (volume) for my particular synth, but this would obviously be a case by case thing based on whatever synth I use for that channel. A more universal approach would be mint!

Edited by talon
Link to comment
Share on other sites

Thanks @talon and @Karg - hope you enjoy your LoopAs! :)

Talon, currently you can modulate the dampening only manually in the FX screen, but using the left SELECT encoder you can switch through tracks quickly while the dampening command is active and then you could use the right DATA encoder to change the dampening values quickly and "live" per track - is that good enough?

If not, and if external dampening control would be nice, it might be possible to add external CC control for the dampening values of the six tracks, but it's a longer shot, the next firmware release will mostly concentrate on adding MatriX support for the LoopA :).

Have a good new upcoming year 2021 ! :)
Best regards,

Link to comment
Share on other sites

  • 1 month later...


I just finished building my LoopA V2 and have an issue - the LoopA doesn't power on.

  • The soldering and all tricky header installations seemed to go just fine (although ground plane pads were sometimes hard to heat up).
  • When I plug it into my computer via USB, the green LEDs around the display start to blink very dimly in unison. I also had a popup on my computer saying too much power was being used on the USB port.
  • When I remove the Base PCB and Plate PCB, and plug in the Core PCB by itself, LED 1 to 4 light up (also LED 5 and 6 dimly), and I'm able to flash the 2.08 firmware with MIOS.
  • I didn't solder the 3.5 mm audio jack and the reset switch yet, since they were backordered.
  • I soldered R101 and R102 (220k and 330).
  • No SD card in the slot.

Any ideas that would explain this behavior? I've checked all the solder joints, but I suppose I could do it again...


Edited by mmontag
Link to comment
Share on other sites

Hi Matt, wonder if it is a short circuit to 0V (ground) somewhere. 

Test each board in turn for shorts on the +5V line. Easiest is across any 100nF cap. Did you solder in the Matias switches yet? Sounds like it is on the Base or Plate PCB?

Please upload sharp photos of the PCBs.

Some status LED illumination is expected if the audio jacks and PCB stack are disconnected.


Link to comment
Share on other sites

I wanted to post back here to close the loop on my question. Andy pointed out the problem: I soldered two shift register ICs backward. Fortunately, they weren't damaged. Once that was corrected, I had a lot of jittery activity on Footswitch 1 (called Button 1 in test mode). This was solved by touching up all the solder points (resistors, etc.) between the 1/4" footswitch jack and the J55 header.

Learned a lot during this build, including the "two soldering iron method" (with two big solder blobs) for desoldering SMT ICs.

Now the Loopa is working great and I'm just as soon coming up with feature requests. :grin:

Some kind of support for program change would be great (I think this was mentioned in Loopop's review too). 

Many thanks to Andy and Peter.

Link to comment
Share on other sites

Quick question - will https://github.com/midibox/mios32 be updated with the latest LoopA revision?
Currently looks like v2.06.

In the meantime I'm just jotting down some ideas here...

  1. Sleep/suspend/low-power mode
    • LoopA has no power switch. It would be nice to leave it unattended for days at a time, without unplugging.
    • Could be simple as turning off LEDs.
  2. Multiple undo/redo
    • Especially for incremental note recording; up to memory limit.
  3. Note cleanup
    • Bad note data can originate, for example, when a MIDI controller is sending on 2 channels at once and LoopA is listening on all channels.
    • Delete notes with 0 length (causes glitchy behavior).
    • De-duplicate overlapping notes.
    • Add missing note-off events to the end of a sequence.
  4. Sustain pedal behavior/stuck notes
    • Reset sustain pedal when stopping the sequencer, or when loop restarts, to avoid stuck notes.
    • In general, I'm doing a lot of MIDI panic; would be nice if that could be slightly more ergonomic one-handed key shortcut than Scene+Live.
  5. Repeat operation in Notes screen
    • It would be handy to repeat previous operation (i.e., all operations applied to the current note could be applied to a subsequent note). Inspired by the vim command.
Edited by mmontag
Link to comment
Share on other sites

Hi Matt,

great to hear that your LoopA works now and sorry for the late reply, there's a lot going on at the moment :).

Basically the LoopA has now maxed-out memory for everything (i see no chance for multiple UNDO levels) and it has been quite complex to fit every feature in 192kB RAM. I've added your requests on the development wishlist, but we're currently and still working hard to finally release the MatriX, so can't promise any direct LoopA code work in the immediate future.

You can save a lot of power, by using the new "OLED off" screensaver mode i think present since v.207 - a few single LEDs that are illuminated won't draw too much power, especially if the LoopA is stopped and you only have a single active track with no other mute/unmute LEDs being lit up.

Note clean-up, de-duplication and pedal handling is a tricky process, would need to look into it in more detail.

For the time being, we're discussing with Thorsten on how to proceed with general code releases (expect a statement from him in March 2021).

Many greets,

Link to comment
Share on other sites

  • 1 month later...

I'm having trouble getting Loopa to connect via USB to load the firmware. I get a red SMD PWR LED on the Waveshare board and that's it. My computer does not recognize that a device is connected, and I don't get the Green LED on the Loopa PCB.

I've tested all of the Waveshare header pins for any adjacent continuity, there is nothing touching (only the adjacent 3.3V pins near PA12 show continuity). I checked all of the 3.3V and the 5V pins and they all show the correct voltages. I've tested continuity between the CPU and the header pins, everything is connected to the CPU. I've tested continuity from PA11 and PA12 to R30 and R31 (near USB port), it's fine. I tried connecting my PC directly to the Waveshare board via the mini USB, it's the same result, unrecognized by the PC (but with the direct mini connection, I do also see the VBUS LED). I've tried multiple different USB cables, Mac and Windows PC.


Update: I read this entire thread, including Altitude's issues and the suggested checks / solutions. Nothing has helped so far. But I did see at one point Peter said "Two red small power LEDs should be lit on the Waveshare board when all is well." -- I am only seeing PWR LED, and not VBUS LED.

Update 2: Removed TVS diode, no change.

I've watched Peter's video a half dozen times and I can't see anything different between his board and mine. I got all my parts from Mouser, and I've done lots of SMD before so I think my work is really tidy. Just to be sure I fluxed and reflowed every connection on the board. It's still the same.

Pics here. Right click on the pic and select "View in new tab" to see the full size 4032x3024


Thanks for any help! I've been troubleshooting this for 3+ hours and can't find anything amiss. I'm happy to try JTAG stuff if someone can guide me through it. I have a STM32f0Discovery board and USBasp programmer and I generally know how to hookup the pins and such, but a bit unsure what software to use to erase and reflash this thing.

Edited by armandhammer
Link to comment
Share on other sites

So what happened, then? The bootloader somehow got borked?

I plugged in the full stack of PCBs and the display shows LoopA Testmode, the LEDs next to the display are flashing in a "chasing" pattern, and the status LEDs for Power, IN1, IN2, BLM are lit but the Footswitch and Gate LEDs are NOT lit. When I turn or push the encoders, it seems I get appropriate test responses on the display and the ring of LEDs. All the keycap LEDs light up.


Link to comment
Share on other sites

We have seen a case where trying to flash with the PA0 port left floating could lead to a corrupted bootloader. Hence the resistors R101 and R102 seem to be very important (that were not installed on your initial build).

The footswitch/gate LEDs are driven by the buffer chip IC6, so it is expected that they don't illuminate with no inputs.

Anyway, great that it seems to work well!

Link to comment
Share on other sites

Thanks for the great tech support! I didn't do R101 and R102 because they weren't installed in the assembly video, so I thought they weren't needed (seemed ok since so many other items on the board are also DNP) but now I do see that they are on the BOM spreadsheet. My bad!

One thing that would be helpful is to have more prominent links to this forum and wiki from the Midiphy product pages. I only found it by googling to see if anyone else had similar problems. I didn't even know that there was a community here... great! 

Anyway, I'm super excited to finish this in the morning and jam all day!!! Other than this one strange bootloader mystery, it has been a super simple build and everything is amazing high quality parts. Thank you for it, I really appreciate that this is available as a DIY kit to people like me who have more time than money :D You guys have really created something special.

  • Like 1
Link to comment
Share on other sites

Here’s one small thing that I noticed that I didn’t see mentioned. I hesitate to post it because it’s so trivial, but the 3D light shield on the lower middle key bumps up against the screw holding the top 2 PCBs. Since the 3D plastic is so soft, it was easy to nip off a bit to make it fit flush.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...