Jump to content

Recommended Posts

hello,

I'm new in the community, i'm planning to build a midibox with LPC17, but we can't download the LPCXpresso IDE recommanded (5.2.6). Only the ver 8.2.2.

have you test it and is there a guide to use it, or is there a place where we can download the 5.2.6 version?

Sorry for this question, but I'm new in Midi and microcontrollers. If someone can help

thanks for all

  • Like 1
Link to post
Share on other sites
54 minutes ago, midiwanted said:

antichambre so we can use ver 8.2.2?

Yes.

 

54 minutes ago, midiwanted said:

is there a guide because I can't use it (I'm newbee)

will be a good idea to update ucapps.de for people like me...

It's pretty the same method no matter of IDE version.
- Install and activate it, it's free.
- Choose a place for Workspace.
- Create a LPCXpresso C Project. (instead of FreeRTOS Project), You just need a blank Project and selecting the good Target.
- Choose the right Target, LPC1769.
- Go to Program Window, Select your Blank project, Select your available interface(LPC-Link)
- In the Programming window, browse and select the file \mios32_bootloader_v1_018\MBHP_CORE_LPC1769\project.bin  by putting *(any) in the extension combo box filter.
- Put 0(zero) in Base address if it's not already the case.
- OK > Done!

Best

Bruno
 

Edited by Antichambre
Link to post
Share on other sites
  • 3 months later...
  • 1 month later...
  • 3 years later...

Which OS do you use? as soon as the USB cable is plugged in, additional LPC drivers etc. are installed(automatically). You have to allow that and wait a little.

Edited by Rio
Link to post
Share on other sites

should work.... pls use LPCXpresso IDE v8.2.2. Otherwise try another usb port, please deinstall lpc/nxp drivers and reboot/reconnect. Have you activate the computer (or register with nxp)? 

Edited by Rio
Link to post
Share on other sites
35 minutes ago, Rio said:

should work.... pls use LPCXpresso IDE v8.2.2. Otherwise try another usb port, please deinstall lpc/nxp drivers and reboot/reconnect. Have you activate the computer (or register with nxp)? 

This is the version I'm using. I tried all USB ports, with 4 different cables, resinstalled the drivers, have rebooted, nothing happens. I have actived the IDE, is there another registration?

BTW there is a jumper provided with the board, what is it for?

Link to post
Share on other sites

Which revision are you using? I think the new boards were put into dev mode by a jumper. But give me more details - pic or number of jumper.

Edited by Rio
Link to post
Share on other sites
Just now, Rio said:

Which revision are you using? I think the new boards were put into dev mode by a jumper. But give me more details - pic or number of jumper.

There is it, bought from Mouser. When I plug it, the big LED flashes green, nothing shows up on the computer side.

 

20210216_174305.jpg

Edited by Number 6
Link to post
Share on other sites

try again from the beginning. should normally go now (reboot, reinstall, reconnect etc.) otherwise something went wrong .. or the linker type isn’t supported by 8.2.2 ?? I will take a look later. 

Edited by Rio
Link to post
Share on other sites

In some posts, people get in trouble with CMSIS-DAP. but take a look here:

https://community.nxp.com/t5/LPC-Microcontrollers/LPCXpresso-LPC1769-board-not-recognized-when-debugging-with-LPC/td-p/1200156

On the other hand, I read that it probably also worked with 8.2.2 ... I can't test it myself (i have only rev.A B C). Do you have the chance to grab an older revision? Don't you want to go to the newer CPU sooner if that is so much trouble? But you could still do some research ... it's up to something.

Edited by Rio
Link to post
Share on other sites

From the document "As supplied, (JP1 - no jumper fitted, JP2 - jumpered across 1-2, JP3 - no jumper fitted), the built in LPC-Link2 based debug probe works as a plug'n'play debug probe with the LPCXpresso IDE. The first time you start an LPCXpresso debug session, a compatible debug firmware image is downloaded to the debug probe allowing you the debug the onboard target MCU."

JP2 has no pin thus is not jumpered.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...