latigid on

Troubleshooting midiphy SEQ v4+

315 posts in this topic

Please post your troubleshooting issues here and we will do our best to get everything up and running!

The more info you provide, the better the answer can be formulated.

  • What did you try so far?
  • What wasn't working?
  • Pictures, pictures, pictures!

 

Edited by latigid on

Share this post


Link to post
Share on other sites

 

Just now, rbv2 said:

hi all,

made good progress so far buidling the pcbs with the help of perters video. the core seems to work since i succefully uploaded seq v4, also the sd card loader is working. but when connecting the JA PCB i get random flickering on all its leds no matter which app is loaded.

is there already a place to ask for help regarding the build?

thank you

 

Have you tried to flash with MB_NG, then "load seq_l.ngc"?

 

Edited by latigid on

Share this post


Link to post
Share on other sites

hi latigid on

thanks a lot for the fast reply.

 

so far tried the following:

- build new ribbon cable and checked connections (orientation of the cable and if header is corect) SRIO IN -- SRIO J8/9

-checked orientation and part numbers of all ICs (CORE PCB and JA PCB)

-visually checked for unwanted shorts (CORE and JA)

-reheated all the pins of the JA PCB

-loading differnt applications to see if it makes a diffence.. it doesn't  :P

when connecting the JA PCB to the Core i instantly get flickering or randomly lit leds.

also ubloaded mb ng as described in the video. but when i start the debug protocol i get an endless stream of messages (well sometimes it stops randomly and then move on)

this is just an excerpt of the protocol.

[1244367.345] set debug on
[1244367.348] Debug mode turned on
[1244377.828] MBNG_DIN_NotifyToggle(57, 0)
[1244377.828] No event assigned to BUTTON hw_id=57
[1244377.828] MBNG_DIN_NotifyToggle(58, 0)
[1244377.829] No event assigned to BUTTON hw_id=58
[1244377.829] MBNG_DIN_NotifyToggle(59, 0)
[1244377.830] No event assigned to BUTTON hw_id=59
[1244377.830] MBNG_DIN_NotifyToggle(60, 0)
[1244377.831] No event assigned to BUTTON hw_id=60
[1244377.831] MBNG_DIN_NotifyToggle(61, 0)
[1244377.832] No event assigned to BUTTON hw_id=61
[1244377.832] MBNG_DIN_NotifyToggle(62, 0)
[1244377.833] No event assigned to BUTTON hw_id=62
[1244377.833] MBNG_DIN_NotifyToggle(63, 0)
[1244377.834] No event assigned to BUTTON hw_id=63
[1244377.836] MBNG_DIN_NotifyToggle(64, 0)
[1244377.836] No event assigned to BUTTON hw_id=64
[1244377.836] MBNG_ENC_NotifyChange(3, 1)
[1244377.836] [EVENT] id=ENC:3 hw_id=ENC:3 bank=0 fwd_id=DISABLED:0 type=CC value=0 label=
[1244377.836] MBNG_MATRIX_NotifyToggle(0, 33, 0)
[1244377.837] MBNG_DIN_NotifyToggle(1033, 0)
[1244377.837] No event assigned to BUTTON hw_id=1033
[1244377.838] MBNG_MATRIX_NotifyToggle(0, 34, 0)
[1244377.838] MBNG_DIN_NotifyToggle(1034, 0)
[1244377.839] No event assigned to BUTTON hw_id=1034
[1244377.839] MBNG_MATRIX_NotifyToggle(0, 35, 0)
[1244377.840] MBNG_DIN_NotifyToggle(1035, 0)
[1244377.840] No event assigned to BUTTON hw_id=1035
[1244377.841] MBNG_MATRIX_NotifyToggle(0, 36, 0)
[1244377.841] MBNG_DIN_NotifyToggle(1036, 0)
[1244377.842] No event assigned to BUTTON hw_id=1036
[1244377.842] MBNG_MATRIX_NotifyToggle(0, 37, 0)
[1244377.843] MBNG_DIN_NotifyToggle(1037, 0)
[1244377.843] [EVENT] id=BUTTON:1037 hw_id=BUTTON:1037 bank=0 fwd_id=LED:1041 type=NoteOn value=0 label=
[1244377.844] MBNG_DOUT_NotifyReceivedValue(1041, 127)
[1244377.845] MBNG_MATRIX_DOUT_NotifyReceivedValue(1, 41, 127)
[1244377.845] MBNG_MATRIX_NotifyToggle(0, 38, 0)
[1244377.846] MBNG_DIN_NotifyToggle(1038, 0)
[1244377.846] [EVENT] id=BUTTON:1038 hw_id=BUTTON:1038 bank=0 fwd_id=LED:1043 type=NoteOn value=0 label=
[1244377.848] MBNG_DOUT_NotifyReceivedValue(1043, 127)
[1244377.848] MBNG_MATRIX_DOUT_NotifyReceivedValue(1, 43, 127)
[1244377.849] MBNG_MATRIX_NotifyToggle(0, 39, 0)
[1244377.849] MBNG_DIN_NotifyToggle(1039, 0)
[1244377.850] [EVENT] id=BUTTON:1039 hw_id=BUTTON:1039 bank=0 fwd_id=LED:1045 type=NoteOn value=0 label=
[1244377.851] MBNG_DOUT_NotifyReceivedValue(1045, 127)
[1244377.851] MBNG_MATRIX_DOUT_NotifyReceivedValue(1, 45, 127)
[1244377.852] MBNG_MATRIX_NotifyToggle(0, 40, 0)
[1244377.852] MBNG_DIN_NotifyToggle(1040, 0)
[1244377.853] [EVENT] id=BUTTON:1040 hw_id=BUTTON:1040 bank=0 fwd_id=LED:1047 type=NoteOn value=0 label=
[1244377.854] MBNG_DOUT_NotifyReceivedValue(1047, 127)
[1244377.855] MBNG_MATRIX_DOUT_NotifyReceivedValue(1, 47, 127)
[1244377.855] MBNG_MATRIX_NotifyToggle(0, 41, 0)
[1244377.856] MBNG_DIN_NotifyToggle(1041, 0)
[1244377.856] No event assigned to BUTTON hw_id=1041
[1244377.857] MBNG_MATRIX_NotifyToggle(0, 42, 0)
[1244377.857] MBNG_DIN_NotifyToggle(1042, 0)
[1244377.858] No event assigned to BUTTON hw_id=1042
[1244377.858] MBNG_MATRIX_NotifyToggle(0, 43, 0)
[1244377.859] MBNG_DIN_NotifyToggle(1043, 0)
[1244377.860] No event assigned to BUTTON hw_id=1043
[1244377.860] MBNG_MATRIX_NotifyToggle(0, 44, 0)
[1244377.860] MBNG_DIN_NotifyToggle(1044, 0)
[1244377.860] No event assigned to BUTTON hw_id=1044
[1244377.861] MBNG_MATRIX_NotifyToggle(0, 45, 0)
[1244377.862] MBNG_DIN_NotifyToggle(1045, 0)
[1244377.862] [EVENT] id=BUTTON:1045 hw_id=BUTTON:1045 bank=0 fwd_id=LED:1042 type=NoteOn value=0 label=

...

Share this post


Link to post
Share on other sites

Please check the part number of your resistor network: is it the isolated one or the bussed one? 

Share this post


Link to post
Share on other sites

it is labeled 4816P LF1-103 C1745 ..

this is the wrong one right?

 

edit:

it definetly is the wrong part. .which leads me to the next wrong part on the LE MEC RH PCB.. :D

thank you so much for you help!!!

Edited by rbv2

Share this post


Link to post
Share on other sites

It sounds so, sorry about that! If you have a hot air rework station, you should be able to remove it, just be careful not to melt the other components.

 

1 person likes this

Share this post


Link to post
Share on other sites

@latigid on

unfortunately not.. looks tricky. i will try it with a lot of solder.

thank you again

Share this post


Link to post
Share on other sites

hello,

i have another question. since i've ordered an early parts list it seems i have 22R resistors to use for the JR (LED COLOR) positions instead of 47R. Also i only have 220R for the SJ (LED brightness).

is it ok to use them?

thanks

 

Edited by rbv2

Share this post


Link to post
Share on other sites

For best brightness balance (and LED lifetime), use the latest specified values. The others will work though. You could also get creative with adding two 22R together if you happen to have spares.

What is your colour scheme? Normal red-green or something else? Note that the firmware will allow to swap LED colours around. Obviously this only works with the connected LEDs. Peter did a "cyan-red" version for his first build. You can do this by doubling up green and blue for example and use the extra pad located on the RJ.

Share this post


Link to post
Share on other sites

hi,

interesting info about mixing the colours :)

cyan sounds great but would like to do the green/red scheme.

Unfortunately i don't have any spare parts that will fit so it seems like I have to pause and wait for another parts delivery.

thanks a lot

Share this post


Link to post
Share on other sites

hi all,

finally i could go on with the build. after all the testing looks promising and i managed to upload the seq app i now have some strange behaviour when starting up. did a short video to demonstrate whats going on.

https://www.dropbox.com/s/me76qsg77vcayf4/VIDEO0148.mp4?dl=0

the app seems to work but there is something wrong with the oled-displays in conjunction with the buttons. i have tested the ja-board and the le-mec boards. all buttons, encoders and leds work properly.

i also interchanged the displays and corresponding cables with the same result.

could anybody please give me a hand?

thank you

 

 

Share this post


Link to post
Share on other sites

Looking good, the display issue should be fixable, too! :)

Andy is better in debugging this, but two thoughts come to mind:

1) Can you check that on the core on J15_S the displays are jumpered to 3.3V?

2) Can you check that R33D on the core is 560R?

Many greets!
Peter

 

Share this post


Link to post
Share on other sites

hello peter,

you were right about the jumper. i even forgot to install the header :D

you definately saved my evening. :)

thank you so much.

it's working <3

Share this post


Link to post
Share on other sites

Just what I would've suggested. Great that it's going now!

Best,
Andy

1 person likes this

Share this post


Link to post
Share on other sites

Here is the problem my OLED had:

5c2975285bb57_SEQV4_2.thumb.JPG.13664553 

 

It took some time to find out the real problem. First I thought it was a problem with the OLED PCB, because slightly twisting it on the left side got the display fully working. And of course I testet the header, connector and cable twice before.

So here is the problem:

The unisolated end of the flat cable had contact with a capacitor on the OLED PCB. I prepared a picture showing it a bit clearer:

display_short.thumb.jpg.58165bb53c3fee39

 

I think this problem could happen to everyone and the solution is to use a bit of isolating tape between the connector and the PCB, especially the three components the arrow is pointing at in the picture above.

Share this post


Link to post
Share on other sites

Great that you found the solution!

The mounting is very tight indeed, and insulation seems like a very good idea.

I wonder if it's better to rather mount the IDC directly to the OLED, for instance using:

HIF2E-14D-2.54RB(20)
(only 14 pins, but it would work, as the backlight is not required. HIF2E-16D-2.54RB(20) is not in stock at Mouser, but could be ordered. There's also the RA type (grey colour I think)

https://www.mouser.de/ProductDetail/Hirose-Connector/HIF2E-14D-254RB20?qs=sGAEpiMZZMs%252bGHln7q6pm7F1NlCFAzwf%2fz35lHmVYIJ7sqU4G2Cmfw%3d%3d

HIF2E-20D-2.54RB_20_SPL.jpg

 

Share this post


Link to post
Share on other sites

I had the same idea and wanted to use them. I have those connectors here but they do not work, because they will cover the mounting holes.

505805A4-E8E8-4D84-96D9-DB15A2A51764.thu

Share this post


Link to post
Share on other sites

I had the same conclusion, I've got regular LCD(not OLED, they are higher(not low profile) this is not possible to use normal IDC, I was obliged to solder wire directly.

Share this post


Link to post
Share on other sites

Posted (edited)

Andy,

For future case production, you can maybe open the metallic plates between the two left mounting hole and use this type of header:
ew_thumb.png
Just an idea, cheers!
Bruno

Edited by Antichambre

Share this post


Link to post
Share on other sites

I have a question regarding the MIDI8 PCB. I thought the I4/PWR port would work as a MIDI IN also when using a DIN8 socket. Mine doesn‘t. So I disassembled the whole SEQ v4+ again to find the failure.

There is no connection between pin4 of the DIN8 and the 220R to the optocoupler pin2.

But there is a connection from the adjacent solderpad to the 220R to the optocoupler pin2. This pad would be used when using a DIN5 socket.

Is this intentionally? Is this a failure on my board? Can I make this connection to the adjacent pad with a solderbridge? Or is there something I do not consider?

Share this post


Link to post
Share on other sites

BLM-MIDI_IN.thumb.JPG.da464c378b0fdabc00

 

If you wish, it is possible to bridge the pairs of pins 4/4 and 5/5 as shown (viewed from the top of the board). It isn't done by default, as simultaneous use with a BLM would cause a conflict and perhaps an expectation of an "extra" MIDI port. If you and any future owner of the SEQ are aware of this it should be okay.

Share this post


Link to post
Share on other sites
10 hours ago, Antichambre said:

Andy,

For future case production, you can maybe open the metallic plates between the two left mounting hole and use this type of header:
ew_thumb.png
Just an idea, cheers!
Bruno

A good idea and one I had considered, but I think the cutout would weaken the plate too much there. Plus, the clearance to the I2C board will be quite close when the case is in rack mode.

I had a look at headers mounted to a tiny PCB, but I think there's just not enough room, even with micromatch or "paddleboard" type. Consider 10mm spacing, 2.54mm plastic standoff on a straight-pin header, then a 1.6mm carrier PCB. I didn't find a header lower than that height difference. I would suggest to put a sliver of kapton tape on the components/IDC.

Share this post


Link to post
Share on other sites

Of course, you already though about it ;)
I understand about clearance and availability, that's something I didn't check and I totally believe you. But if you have to do it somewhere else don't be afraid to weak the plate, in this example the plate is very well supported on the side and the 'weaken' part only supports the LCD, if you need to do it in the future check with Adrian but I think it's very solid metal, not bending alu, and this is not a problem.

Best
Bruno

Share this post


Link to post
Share on other sites

I have a problem with the superflux LEDs, more precisely with the 6th LED of the second row (on the smaller board). I am on the red/blue color scheme. The fluxtest does not light up the red LED on the mentioned superflux LED, but everything else works. The LED itself is working, though - when I separate it from the circuit and test it with the multimeter, all three colors work, also red.

Where is this specific LED connected to? Should I search for a short circuit somewhere?

Share this post


Link to post
Share on other sites

A photo would be useful. So the other LEDs of the column light up? MEC and the other superflux? Also nothing else gone in the row? 

Is the cathode pin correctly soldered? 

Do the DINs work? 

When you say you've isolated the LED, you removed it? Did you try one of the spare parts? 

You could try to temporarily short to the other red LED in the column or the adjacent cathode in a row. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now